Collabora Online Development Edition - Self-Hostable Office Suite


#1

Collabora Online Development Edition

Integration level
Install Collabora with YunoHost

Overview

Collabora Online Development Edition also known as LibreOffice Online, is a server service built from the main LibreOffice project code which provides display and collaborative visual editing of a range of document types. It does not include any form of file system. To be fully functional, it has to be integrated with file access and authentication provision from an underlying stack of software.

Shipped version: 4.0.0 RC2

Screenshots

Configuration

To be sure it works, you need :

  • one Nextcloud on a dedicated domain and install this package on an other dedicated domain (or subdomain).
  • Let’s encrypt on each domain

More info here: https://yunohost.org/#/collabora

Documentation

YunoHost specific features

Supported architectures

  • x86-64b -
  • ARMv8-A -
  • Jessie x86-64b -

Limitations

CODE has a warning limitation

Additional informations

Links


Changelog

Testing branch

  • 30 Jan 2019 - 5dc8e3f
    • Upgrade to 4.0.0 RC2 and make it works

Master branch (Official release)


Developers infos

Please do your pull request to the testing branch.

To try the testing branch, please proceed like that:

sudo yunohost app install https://github.com/YunoHost-Apps/collabora_ynh/tree/testing --debug
or
sudo yunohost app upgrade collabora -u https://github.com/YunoHost-Apps/collabora_ynh/tree/testing --debug

#2

To people who tried to setup Collabora Online DE
@Skypy @rafi59 @aina @bjarkan @Limezy @tomdereub @mib @K-nar @schweineoede @fidoboulettes @don @Jaxom99 @Narvod @Oversu @Brogen67 @azelbiz @quentind @FosterBill @kaneda57 @michelw1

So I have made this package work again. It’s currently in a testing mode. Feel free to test it (not on your production server) as you have tried to setup it in the past.

If you have a problem to remove it, try this, and notice it here:

touch /etc/apt/apt.conf.d/25loolwsd
apt remove loolwsd

Note: i don’t know if i will maintain it (because i need to test onlyoffice too and choose the best for my use case)


#3

Random very boring remark but : if we could have consistent name between the manifest id (collabora), the repo name (collaboraonline) and the key in community.json (collabora), I would be sooo happy :stuck_out_tongue: (so maybe renaming the repo while the app still aint used a lot)

serveifefefefemage


#4

@ljf, when you’ll have tested both, could you give us a feedback?
Thanks!


Etherpads : problème installation
#5

Hi there, I was so happy to encounter an online LibreOffice Yunohost app being able to work with Nextcloud. I tried to install the Collabora app in the Yunohost admin environment, but it encountered an error and did not install, unfortunately (see the log below).

Does anyone have an idea why? Was it because I tried to install it on the same domain as my Nextcloud app? And is it really mandatory to create another subdomain for it to work?

I would be really happy if you could let me know what I need to do to get it to work :slight_smile: Many thanks in advance.

P.s. I see that this page linked above https://yunohost.org/#/collabora is “not yet available”. Some installation and configuration instructions would be very useful to have somewhere…

args:
  app: collaboradocker
  args: domain=ihost.mydomain.nl
  label: Collabora
  no_remove_on_failure: false
ended_at: 2019-04-01 19:28:48.201099
env:
  YNH_APP_ARG_DOMAIN: ihost.mydomain.nl
  YNH_APP_ID: collaboradocker
  YNH_APP_INSTANCE_NAME: collaboradocker
  YNH_APP_INSTANCE_NUMBER: '1'
  YNH_CWD: /var/cache/yunohost/from_file/collaboradocker_ynh-7acf7c84572734a5c6d8d396e0f01b0acf8e5bfc/scripts
  YNH_STDINFO: /tmp/tmpRGACJR/stdinfo
error: An unexpected error occured
operation: app_install
related_to:
- - app
  - collaboradocker
started_at: 2019-04-01 19:28:28.746337
success: false

============

2019-04-01 19:28:30,078: WARNING - + sh -c apt-get update -qq >/dev/null
2019-04-01 19:28:45,932: WARNING - + sh -c apt-get install -y -qq apt-transport-https ca-certificates curl >/dev/null
2019-04-01 19:28:48,041: WARNING - E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
2019-04-01 19:28:48,043: WARNING - !!
2019-04-01 19:28:48,045: WARNING -   collaboradocker's script has encountered an error. Its execution was cancelled.
2019-04-01 19:28:48,047: WARNING - !!
2019-04-01 19:28:48,049: WARNING - 

#6

By the way, I read about the inability to remove the Collabora app in this thread. Is that the case for my try as well? Is the failed install still on my system? In the log it said something about it being unable to uninstall because it did not exist…