Mot de passe incorrecte après l'installation de "menu"

Mon serveur YunoHost

Matériel: Raspberry Pi 3b+
Version de YunoHost: Je ne peux pas savoir
J’ai accès à mon serveur : En SSH | Par la webadmin | En direct avec un clavier/écran
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

Description du problème

Bonjour!
Je suis fan de Yunohost mais malheureusement après l’installation de l’application menu, il m’est impossible de me connecter à la page d’administration.
En effet, j’ai à chaque fois le message disant que mon mot de passe est soi-disant incorrecte.
J’ai modifié mon mot de passe en ligne de commande pourtant le problème reste le même.
Je tiens à préciser que j’ai toujours un accès en SSH (preuve que le mot de passe est bon) et je peux aussi me connecter en tant qu’utilisateur.
En cherchant sur internet, je me suis rendu compte que je ne suis pas le seul :



Pouvez-vous m’aider ?

Simon

Est-ce que la ligne de commande yunohost fonctionne en ssh ?

yunohost user list

par exemple

Merci de ta réponse !
Oui, la ligne de commande fonctionne bien en SSH :

root@pi:~# yunohost user list
users:
  simon511000:
    fullname: Simon Ledoux
    mail: simon@*****.fr
    mailbox-quota: 0
    shell: /bin/false
    ssh_allowed: False
    username: simon511000

ok alors essaie

systemctl restart yunohost-api

Non, je ne peux toujours pas me connecter à l’administration

Bonjour, très probable que ça ne soit pas ça mais ça me le fait régulièrement sur l’administration et le portail avec Firefox, il faut que j’efface les données et cookies du site : clic sur le cadenas à gauche de l’adresse dans la barre d’url et Effacer les cookies et données de site.
Sinon une autre fois j’avais du faire un (sudo?) yunohost tools adminpw depuis le ssh.

Bonjour, malheuresement ça n’a pas fonctionné pour moi, et j’ai essayé avec plusieurs appareils différents et plusieurs navigateurs et j’ai toujours le même problème

Même en changeant le mot de passe :frowning:
image

Je ne sais pas si ça peut vous aider mais j’ai ça comme erreur js :

Content Security Policy: Ce site (https://*****.fr) possède une politique Report-Only sans URI de rapport. CSP ne bloquera pas cette politique et ne pourra pas rapporter ses violations.
Cette page utilise la propriété non standard « zoom ». Envisagez d’utiliser calc() dans les valeurs des propriétés pertinentes ou utilisez « transform » avec « transform-origin: 0 0 ».

Non aucun lien ce n’est pas vraiment une erreur.

systemctl status yunohost-api

Cette commande indique bien que le service est actif et lancé ?

As tu une configuration navigateur particulière ? Peut tu essayer avec un navigateur vierge pour voir ?
Es tu sur de t’adresser au bon yunohost (je sais c’est bête comme question mais on ne sais jamais).

Que dise les logs: /var/log/yunohost/yunohost-cli.log et /var/log/yunohost/yunohost-api.log lorsque tu tentes la connexion ?

1 Like

Oui :

admin@pi:~ $ systemctl status yunohost-api
● yunohost-api.service - YunoHost API Server
   Loaded: loaded (/lib/systemd/system/yunohost-api.service; enabled; vendor preset: enabled)
   Active: active (running) since Thu 2020-02-20 05:20:34 GMT; 10h ago
 Main PID: 14571 (yunohost-api)
    Tasks: 2 (limit: 4915)
   CGroup: /system.slice/yunohost-api.service
           └─14571 /usr/bin/python /usr/bin/yunohost-api

Non, j’ai essayé avec firefox, chrome et même edge sur plusieurs appareils différents.

Oui, je suis sûr, j’y accède depuis le nom de domaine et aussi depuis l’IP local.

Rien n’est ajouté lorsque je tente de me connecter.

Voici ce qui est ajouté :

2020-02-20 15:55:23,153 DEBUG geventwebsocket.handler run_application - Initializing WebSocket
2020-02-20 15:55:23,154 DEBUG geventwebsocket.handler upgrade_websocket - Validating WebSocket request
2020-02-20 15:55:23,155 DEBUG geventwebsocket.handler upgrade_websocket - Can only upgrade connection if using GET method.
2020-02-20 15:55:23,159 DEBUG moulinette.authenticator.ldap __init__ - initialize authenticator 'default' with: uri='ldap://localhost:389', base_dn='dc=yunohost,dc=org', user_rdn='cn=admin'
2020-02-20 15:55:23,165 INFO geventwebsocket.handler log_request - 127.0.0.1 - - [2020-02-20 15:55:23] "POST /login HTTP/1.1" 401 148 0.011859

J’ai réinstallé Yunohost pour ne plus avoir de problème.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.