[Flarum] A lightweight forum

So,

My YNH account is jrd and it works with Flarum.

But my Jose account (which is a admin account) does not work :,(
Jose is not a YNH account.
Superusuer is in the Flarum database (in first) but does not work.

Thank you for your time :slight_smile:

I put tituspijean-auth-ldap.onlyUse to 0 (instead of 1)
Same connection interface.

Oh! That’s a bug I can replicate. :o With 0, it should display two links, one standard connection, one through YunoHost.
I will try to fix that.

2 Likes

@tituspijean
I backed to my initial settings.
Connection with my ynh account OK !
External users cannot open an account.

I have do an PR for bump the app into the new version 1.0.0!

1 Like
Initial call for testers
  • Testing branch status as of 2021-06-07: PR175
    • :arrow_heading_up: Upgrade to first stable release of Flarum, v1.0 :partying_face:
    • :information_source: Do not hide Flarum’s standard method by default
    • Upgrade LDAP extension accordingly.

cf. first post for installing and upgrading to a test release.

New release:

  • Master branch status as of 2021-06-14: PR175
    • :arrow_heading_up: Upgrade to first stable release of Flarum, v1.0 :partying_face:
    • Upgrade LDAP extension accordingly.
      • :information_source: Do not hide Flarum’s standard method by default
3 Likes

See the @farvardin’s post (in French)

It’s OK for me now. Thank you.

1 Like

:fr:
J’ai cherché à passer de 0.1.0-beta.13~ynh1 à 1.0 et ça coince pendant la mise à jour, vraisemblablement au niveau des extensions… Problème je n’arrive pas à les désinstaller via composer ni via le panneau d’admin, vous avez pas un tuto magique ?


:us:
I tried to upgrade from 0.1.0-beta.13~ynh1 to 1.0 but it fails, probably because of non upgraded or non compatible extensions. Problem is i’m unable to uninstall extensions from the admin panel or from composer, can anyone help ?


:stuck_out_tongue:

Anyway, if you want proper help, please share your upgrade logs and what commands you tried.

My bad

The full update failure log :
https://paste.yunohost.org/raw/basokehuyi

This is what i use to remove extensions :
/var/www/flarum$ php7.3 composer.phar remove fof/formatting

And i get
[RuntimeException]
The file "./composer.json" is not writable.

Has anyone managed to upgrade Flarum to version 1.1 which was recently released. It has some new features and bug fixes that I really need.

thanks in advance for any guidance …

Per the example above on installing extensions:, you need to perform the command as the app’s system user:

cd /var/www/flarum
sudo -u flarum php7.3 composer.phar remove fof/formatting

Hopefully someday Flarum will handle installing and removing extensions from its admin panel. :wink:

This returns me that, which is weird :
Désolé, l'utilisateur admin n'est pas autorisé à exécuter « /usr/bin/php7.3 composer.phar remove fof/formatting » en tant que flarum sur domain.tld

Switch to super user beforehand then: sudo su

You will need to wait and see, sorry… right now only 1.0 is packaged.

Alright it does the trick ! Thanks !

That being working now, which extensions do i need to remove in order to safely upgrade to 1.0 ?
Is it safer or better practice to delete everything, upgrade, and (painfully :smiley: ) reinstall extensions ?

Remove any extension you have installed yourself. The included ones should upgrade seamlessly.

Done, but the update still fails everytime. Still the same logs

OK, that definitely means there’s an issue with the app, but the log is not verbose enough. I will try to investigate, but since you already have an old version on hand, can you try this? (make sure you have a backup)

sudo su
cd /var/www/flarum
sudo -u flarum php7.3 /var/www/flarum/composer.phar require 'tituspijean/flarum-ext-auth-ldap:~1.0.0-p1' --no-update -d /var/www/flarum --no-interaction
sudo -u flarum php7.3 /var/www/flarum/composer.phar require 'flarum/core:~1.0.0' --prefer-dist --update-no-dev -a --update-with-all-dependencies -d /var/www/flarum --no-interaction

Thanks … I’ll wait then …

Tried the commands you gave me, first one went through, second one returned this :

/var/www/flarum# sudo -u flarum php7.3 /var/www/flarum/composer.phar require 'flarum/core:~1.0.0' --prefer-dist --update-no-dev -a --update-with-all-dependencies -d /var/www/flarum --no-interaction
Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/
./composer.json has been updated
Loading composer repositories with package information
Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - flarum/approval v0.1.0-beta.13 requires flarum/core ^0.1.0-beta.13 -> satisfiable by flarum/core[v0.1.0-beta.13, v0.1.0-beta.14, v0.1.0-beta.14.1, v0.1.0-beta.15, v0.1.0-beta.16] but these conflict with your requirements or minimum-stability.
    - flarum/approval v0.1.0-beta.13 requires flarum/core ^0.1.0-beta.13 -> satisfiable by flarum/core[v0.1.0-beta.13, v0.1.0-beta.14, v0.1.0-beta.14.1, v0.1.0-beta.15, v0.1.0-beta.16] but these conflict with your requirements or minimum-stability.
    - flarum/approval v0.1.0-beta.13 requires flarum/core ^0.1.0-beta.13 -> satisfiable by flarum/core[v0.1.0-beta.13, v0.1.0-beta.14, v0.1.0-beta.14.1, v0.1.0-beta.15, v0.1.0-beta.16] but these conflict with your requirements or minimum-stability.
    - Installation request for flarum/approval (locked at v0.1.0-beta.13, requir4ed as ^0.1.0) -> satisfiable by flarum/approval[v0.1.0-beta.13].

Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.

Installation failed, reverting ./composer.json to its original content.

And Flarum 1.0 update still fails the same way… I tried to tweak with composer.json (as shown in the flarum documentation) but it did not change anything so i reverted it back to original.


Since my install seems a bit sketchy, wouldn’t it be easier/safer to backup the forum files, reinstall a fresh 1.0 flarum and reinject the saved forum files ? Assuming those posts/photos/users/etc. are easily backupable and restored…