Flarum : connexion impossible / difficile suite maj

bonjour,

on a un soucis avec flarum. Après une maj récente de yunohost, l’accès autre que LDAP ne fonctionnait plus. cf. [Flarum] A lightweight forum - #180 by jrd10

j’ai vu ce soir qu’il y avait une nouvelle maj de flarum. Suite à cette maj, maintenant il n’y a plus aucun login possible, ni en normal (l’option n’est pas proposée), ni en ldap : si je me me connecte en ldap avec un compte existant, ça propose une inscription, si je clique sur inscription, ça indique que le compte existe déjà. Si je mets des informations bidons (compte ldap inexistant), ça affiche : “Une erreur est survenue lors du chargement de la page.”.

Si j’efface l’instance existante (qui est une maj), pour installer un flarum “neuf”, tout fonctionne : accès ldap, et si je désactive le module ldap, ça permet le login d’un compte non inscript sur yunohost (je n’ai pas testé plus loin). Donc le problème vient de notre base de données plus ancienne, qui ne prend pas en compte le rajout de l’extension ldap.

Si je renomme le dossier “/var/www/flarum/vendor/tituspijean/flarum-ext-auth-ldap”, ça indique “connexion” et à côté “connexion via” (sans rien après). La connexion tout court ne m’a pas permis de me connecter avec le mot de passe yunohost, du coup j’ai dû réinitialiser le mot de passe via l’email.

En revanche, maintenant que j’ai de nouveau l’accès admin, si je remets le dossier d’extension ldap comme avant, et si je vais dans les paramètres de cette extension ldap, si je décoche “Cacher le système de connexion standard de Flarum”, seul l’accès LDAP (qui ne fonctionne pas), est visible. Ce comportement également sur 2 instances “neuves” de flarum (dont une sur un autre serveur), donc pour moi y’a un bug à ce niveau.

J’ai installé une seconde instance de flarum, et comparé les 2 paramètrages pour l’extension ldap, grosso modo je vois les mêmes choses, je ne comprends pas ce qui bloque sur notre ancienne instance.

J’ai également fait un backup de l’ancienne base sql, installé à la place de l’ancienne une nouvelle instance, fait un backup de la nouvelle instance, copié l’ancienne base sql à la place de la nouvelle, recompressé la sauvegarde du backup de la nouvelle instance, et réinstallé la sauvegarde, mais le comportement est le même.

Bonjour,

Merci pour ce retour. Pour aller plus loin :

  • Active le déboguage dans /var/www/flarum/config.php: debug doit être mis à true, réessaie de te connecter.
  • Partage ton log de la mise à niveau de Flarum.

Edit: je viens de réaliser que je me suis sûrement emmêlé les pinceaux avec les dépendances de Flarum. Essaie de mettre à jour à la version 1.0.0 (ça reste en testing pour l’instant), qui semble fonctionnelle:

yunohost app upgrade flarum -u https://github.com/YunoHost-Apps/flarum_ynh/tree/testing

:crossed_fingers:

2 Likes

merci. Ça va déjà un peu mieux, vu que maintenant ça affiche les 2 options correctement (connexion, et “connexion via yunohost”, en entier). La connexion normale fonctionne, celle avec yunohost non, mais je pense que c’est un truc dans la base de données qui bloque, tant pis. Peut-être qu’une prochaine mise à jour débloquera ça…

J’ai activé le debug, mais ça n’affiche rien de plus ici, sauf si je clique sur inscription, et ça indique que l’utilisateur et déjà pris (forcément) :

Franchement, non, tant que je trouve pas le bug ça ne se débloquera pas tout seul. ^^
Techniquement, l’extension LDAP fait systématiquement une demande d’inscription à Flarum. Et si l’utilisateur existe, alors il est en fait connecté. Sinon c’est la fenêtre d’inscription qui s’affiche comme tu le vois.

Reste à savoir pourquoi l’utilisateur n’est pas connecté directement…

Sans aller voir ce qu’il y a dans la BDD et bidouiller le PHP pour lui faire dire ce qu’il se passe dans ses routines, je vais avoir du mal à t’aider. :confused:

A tout hasard, si tu es prêt à bidouiller:

  1. installe PHPmyadmin sur ton serveur
  2. Utilise-le pour explorer la BDD de Flarum, notamment la table login_providers et l’entrée correspondant à ton utilisateur eric. Le provider devrait être ssowat, émanant du temps où c’était l’autre extension que je n’arrivais plus à maintenir qui était en charge. Change-le pour ldap pour voir ?

:crossed_fingers:

PS: désolé, vraiment, pour ces tracas. Faire du bug-driven development n’est pas du tout mon intention. (j’en profite pour découvrir que l’expression existe vraiment :sweat: ).

1 Like