[Flarum] A lightweight forum

I could not replicate your issue, sorry. I have asked for support to the extension developpers over at Flarum. :crossed_fingers:

Hi ! I was wondering if some day flarum updates would not erase every extensions. It is a bit of a pain to reinstall everything with each update so i’m stuck with beta13 for now…

I agree it is not ideal, sorry for that, but it was the cleanest way I had found to upgrade. I will have another look.

Linked issue on GH.

1 Like

Just updated YNH and Flarum and unable to use our accounts!

First. Now it no more “Connexion” but “Connexion via YUNOHOST” ???

Secondly, what ever you do, direct access, by YNH or even to recreate a account as requested… you have this error message :slight_smile:

In “https://tricassinux.org/forum/auth/ldap”, Une erreur est survenue lors du chargement de la page.

Please note that in " Groupes et autorisations " superuser and I have the right to access to Flarum by YNH and as external user.

Groupes / utilisateurs actuellement autorisés à accéder à cette application :
xxx, all_users, xxx, visitors, superuser. 

Amicalement, José

Please enable debugging in /var/www/flarum/config.php and report back with the full error. :slight_smile:

Thank you for your quick feedback :slight_smile:

I am not sure to understand what you are asking me :slight_smile:
Thank you too for keeping/making YNH and its app affordable for non-sysadmin :).

See the file :slight_smile: /var/www/flarum/config.php

Error message:

Before the YNH and Flarum update, it was working :).

Thank you for YNH and Flarum.

Amicalement, José

'debug' => false, should become 'debug' => true, in that file. :wink:

Thank you.
OK, easy for me :slight_smile:

Errror message is:

LDAP error: (No LDAP query results for filter: [(&(&(objectClass=posixAccount)
(permission=cn=flarum.main,ou=permission,dc=yunohost,dc=org))(uid=jose))] 
in: [ou=users,dc=yunohost,dc=org], No LDAP query results for filter: 
[(&(&(objectClass=posixAccount)
(permission=cn=flarum.main,ou=permission,dc=yunohost,dc=org))(mail=jose))] 
in: [ou=users,dc=yunohost,dc=org])

Highlited line:

   throw new LdapRecordException('LDAP error: (' . implode(', ', $ldapErrors) . ')');

in https://tricassinux.org/forum/auth/ldap

Thank you for your time. José

Thank you! That’s weird, this conf is working for me. Can you try using the first email address associated with your YNH user? Can you check that your user has the main permission for Flarum, too?

Hi
Are you speaking about the “super user”. Yes.
With this super user account, it propose me to open an account??? Why not.
I accept (Note: I cannot modify the text field to create another account!)

and I have this “Debut message”
“Le username est déjà pris.” … “The username is already used”

Is this “Connexion via YUNOHOST” mandatory?
Simple “Connexion” was ok!

And now, impossible to open an account as external user. Before, it was possible!

Not at ease with this LDAP function!

Thank you for your time :).

Note: With phpMyAdmin, I can see that the superuser is the first user.

I was referring to your josue account. :wink: Is this account a user created within YunoHost?
I think I made a mistake by hiding the standard Flarum login. I will fix that in the next version.

And I was not at ease maintaining a dedicated extension for SSOwat. :slight_smile:

To re-enable the standard login method: in phpmyadmin, database flarum, table setting set the key tituspijean-auth-ldap.onlyUse to 0. And try logging in again.

Hi, thank you for your feedback.

  1. You mean ‘jose’ account :slight_smile:
    It seems to me, it is not exactly the same login but same email (I try with email).
    Let me check.

  2. But I cannot create an external account :).

  3. Let me see for “re-enable the standard login method”. That will be a pb for the upcoming update?

See you soon with my feedback. José

So,

My YNH account is jrd and it works with Flarum.

But my Jose account (which is a admin account) does not work :,(
Jose is not a YNH account.
Superusuer is in the Flarum database (in first) but does not work.

Thank you for your time :slight_smile:

I put tituspijean-auth-ldap.onlyUse to 0 (instead of 1)
Same connection interface.

Oh! That’s a bug I can replicate. :o With 0, it should display two links, one standard connection, one through YunoHost.
I will try to fix that.

2 Likes

@tituspijean
I backed to my initial settings.
Connection with my ynh account OK !
External users cannot open an account.

I have do an PR for bump the app into the new version 1.0.0!

1 Like
Initial call for testers
  • Testing branch status as of 2021-06-07: PR175
    • :arrow_heading_up: Upgrade to first stable release of Flarum, v1.0 :partying_face:
    • :information_source: Do not hide Flarum’s standard method by default
    • Upgrade LDAP extension accordingly.

cf. first post for installing and upgrading to a test release.

New release:

  • Master branch status as of 2021-06-14: PR175
    • :arrow_heading_up: Upgrade to first stable release of Flarum, v1.0 :partying_face:
    • Upgrade LDAP extension accordingly.
      • :information_source: Do not hide Flarum’s standard method by default
3 Likes

See the @farvardin’s post (in French)

It’s OK for me now. Thank you.

1 Like

:fr:
J’ai cherché à passer de 0.1.0-beta.13~ynh1 à 1.0 et ça coince pendant la mise à jour, vraisemblablement au niveau des extensions… Problème je n’arrive pas à les désinstaller via composer ni via le panneau d’admin, vous avez pas un tuto magique ?


:us:
I tried to upgrade from 0.1.0-beta.13~ynh1 to 1.0 but it fails, probably because of non upgraded or non compatible extensions. Problem is i’m unable to uninstall extensions from the admin panel or from composer, can anyone help ?


:stuck_out_tongue:

Anyway, if you want proper help, please share your upgrade logs and what commands you tried.