Tools_migrations_migrate failed because of a remaing earsed domain

,

Hi!

I tried to update my Yunohost to 4.1 today and the update failed on tools_migrations_migrate_forward.

Details below.

My YunoHost server

Hardware: Raspberry Pi 4/8 Go at home
YunoHost version: from 4.0.8.3 (stable) to 4.1.4 (stable)
I have access to my server: Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance?: no

Description of my issue

I simply tried to update through the web interface. And the update failed.

Here are the logs: https://paste.yunohost.org/oramapatih.sql

In these logs, I hid a domain name with myolderaseddomain%.tld. That domain name was the one I used at first with my Yunohost installation. Then, I changed it, and erased the old domain.

It seems the old domain remains somewhere (in NextCloud???). But I cannot figure out where to remove this old reminiscence.

Can anyone help me on that matter?

Eh alrighty can we run the following :

grep -nr 'yourolddomain%.tld' /etc/yunohost/apps/*/settings.yml

and possibly share the name of the correspond setting (or ideally what the result look like entirely)

I was trying to grep on all the data, but it was taking ages to finish.

grep -nr 'yourolddomain%.tld' /etc/yunohost/apps/*/settings.yml was straight forward and really shorter indeed. There is one instance of my old domain name in /etc/yunohost/apps/nextcloud/settings.yml

skipped_regex: myolderaseddomain%.tld/%.well%-known/.*

I removed the line, and then the migration tools_migrations_migrate_forward ended OK.

You were right to point me to settings.yml files!

Thanks a lot!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.