Problem doing system upgrade

My YunoHost server

Hardware: Raspberry Pi at home
YunoHost version:
I have access to my server : through the webadmin (haven’t yet tried SSH)
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hi all,

I tried updating my system from the webadmin this morning an have this output from the logs:

GET /logs/display

Traceback (most recent call last):
File “/usr/lib/python2.7/dist-packages/moulinette/interfaces/”, line 485, in process
ret = self.actionsmap.process(arguments, timeout=30, route=_route)
File “/usr/lib/python2.7/dist-packages/moulinette/”, line 592, in process
return func(**arguments)
File “/usr/lib/moulinette/yunohost/”, line 267, in log_display
metadata[“suboperations”] = list(suboperations())
File “/usr/lib/moulinette/yunohost/”, line 260, in suboperations
if submetadata.get(“parent”) == base_filename:
AttributeError: ‘NoneType’ object has no attribute ‘get’

Since then I see no apps on the user interface when logging in and apps nextcloud, rainloop and MyWebApp are not shown under applications in the administration interface:

Failed to get label for app rainloop ?

Failed to get label for app nextcloud ?

Failed to get label for app my_webapp ?

The server seems to be running correctly (at least nextcloud) when accessing from Android or the nextcloud client in Linux.

Thanks in advance for any help you can give me here.

Best regards


If you have access through SSH, can you run

sudo yunohost log display 20210109-092909-tools_upgrade --share

Hi Aleks,

Is this what you need:
This log is now available via
Seems like Disk space may be low:
2021-01-09 09:36:14,211: INFO - + You do not have enough space in /boot to install this package.
It also mentions an old domain which i deleted some time back:
The operation ‘Create permission ‘nextcloud’’ could not be completed. Please share the full log of this operation using the command ‘yunohost log display 20210109-094118-permission_create-nextcloud --share’ to get help
Could not migrate… trying to roll back the system.
System rolled back.
Migration 0019_extend_permissions_features did not complete, aborting. Error: Domain ‘’ unknown

Hope tha helps and please let me know what I need to do next.

Here’s also the result of df:
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/root 15100680 11064280 3380728 77% /
devtmpfs 440240 0 440240 0% /dev
tmpfs 473520 8 473512 1% /dev/shm
tmpfs 473520 6508 467012 2% /run
tmpfs 5120 4 5116 1% /run/lock
tmpfs 473520 0 473520 0% /sys/fs/cgroup
/dev/mmcblk0p1 44235 24065 20170 55% /boot
/dev/sdb1 61142052 27115420 30897752 47% /media/OwncloudUSB
tmpfs 94704 0 94704 0% /run/user/1007

This look like the same issue than Tools_migrations_migrate failed because of a remaing earsed domain - #3 by Beurt

You can probably fix the issue by running

nano /etc/yunohost/apps/nextcloud/settings.yml

remove the line about skipped_regex:

and save/exit with Ctrl+X and Y to confirm

then in the webadmin, re-run the migration by going in Tools > Migrations

Thanks Aleks - that did it!
Sorry I missed the other post!
Take care and stay safe

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.