Restauration d'une sauvegarde complète 4.0 en 4.1 (isProtected missing)

,

Salut, merci d’essayer de m’aider…
Je ne comprends pas du tout ce que cela veut dire, désolé…

Je vois à priori qu’il y a un souci d’autorisation de l’utilisateur root avec mysql, non ?

Je crois qu’Aleks réagit juste au fait que le log ait été traduit en français:
sleep 0.5 -> sommeil 0.5

La sauvegarde échoue la restauration de la base.

Que donne

systemctl status mysql
1 Like
mariadb.service - MariaDB 10.3.27 database server

Loaded: loaded (/lib/systemd/system/mariadb.service; enabled; vendor preset: enabled)

Active: **active (running)** since Sun 2021-01-10 16:28:30 CET; 9min ago

Docs: man:mysqld(8)

https://mariadb.com/kb/en/library/systemd/

Process: 30149 ExecStartPre=/usr/bin/install -m 755 -o mysql -g root -d /var/run/mysqld (code=exited, status=0/SUCCESS)

Process: 30153 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)

Process: 30155 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VAR= || VAR=`cd /usr/bin/..; /usr/bin/galera_recovery`; [ $? -eq 0 ] && systemctl set-environment _WSREP_START_POSITION=$VAR

Process: 30233 ExecStartPost=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)

Process: 30235 ExecStartPost=/etc/mysql/debian-start (code=exited, status=0/SUCCESS)

Main PID: 30202 (mysqld)

Status: "Taking your SQL requests now..."

Tasks: 31 (limit: 4915)

Memory: 48.3M

CGroup: /system.slice/mariadb.service

└─30202 /usr/sbin/mysqld

janv. 10 16:28:30 adnlife.nohost.me systemd[1]: Started MariaDB 10.3.27 database server.

janv. 10 16:28:30 adnlife.nohost.me mysqld[30202]: 2021-01-10 16:28:30 8 [Warning] Access denied for user 'root'@'localhost' (using password: NO)

janv. 10 16:28:30 adnlife.nohost.me mysqld[30202]: 2021-01-10 16:28:30 9 [Warning] Access denied for user 'root'@'localhost' (using password: NO)

janv. 10 16:28:30 adnlife.nohost.me mysqld[30202]: 2021-01-10 16:28:30 10 [Warning] Access denied for user 'root'@'localhost' (using password: NO)

janv. 10 16:29:43 adnlife.nohost.me mysqld[30202]: 2021-01-10 16:29:43 11 [Warning] Access denied for user 'root'@'localhost' (using password: YES)

janv. 10 16:29:44 adnlife.nohost.me mysqld[30202]: 2021-01-10 16:29:44 12 [Warning] Access denied for user 'root'@'localhost' (using password: YES)

janv. 10 16:29:44 adnlife.nohost.me mysqld[30202]: 2021-01-10 16:29:44 13 [Warning] Access denied for user 'root'@'localhost' (using password: YES)

janv. 10 16:36:49 adnlife.nohost.me mysqld[30202]: 2021-01-10 16:36:49 14 [Warning] Access denied for user 'root'@'localhost' (using password: YES)

janv. 10 16:36:51 adnlife.nohost.me mysqld[30202]: 2021-01-10 16:36:51 15 [Warning] Access denied for user 'root'@'localhost' (using password: YES)

janv. 10 16:36:51 adnlife.nohost.me mysqld[30202]: 2021-01-10 16:36:51 16 [Warning] Access denied for user 'root'@'localhost' (using password: YES)

**~**

**~**

**~**

**~**

**~**

**~**

**~**

**~**

**~**

lines 1-27/27 (END)

Est-ce que tu arrives à te connecter à la base de données mysql ?

cat /etc/yunohost/mysql
mysql -uroot -p

Pas besoin de donner le retour der la première commande, sauf si rien ne s’affiche…

Si c’est pas le cas essaie de régénérer la configuration mysql:

yunohost tools regen-conf mysql --force

ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: YES)

Alors qu’en fait je suis sûr du MP car je l’ai changé et la commande cat /etc/yunohost/mysql m’affiche bien mon nouveau MP… :roll_eyes: :sob:

Alors, je n’ai pas eu de réponse particulière avec cette commande mais je suppose que ça l’a fait…
Par contre du coup toujours impossible de se connecter à mysql. :frowning:

Comment tu as fait ce changement ?

Et bien en fait je cherche des solutions aussi de mon côté et j’ai suivit les étapes de @kanhu dans ce post => MYSQL root user is being denied permission while installing an app - #4 by kanhu

Au cas où, suivant je ne sais plus quel post avec problème similaire, j’ai tenté d’installer une App toute neuve type kanboard et j’ai effectivement le même problème de permission…

Je suis étonné car le problème finalement ne date pas d’aujourd’hui, certains ont réussi à réparer cette erreur mais là ça ne semble pas vouloir prendre…

Vu que la sauvegarde était une version antérieure de YunoHost, ne faudrait-il pas que je downgrad à la version antérieure pour que cela soit compatible avec ma sauvegarde ?

Ou ne puis-je pas downgrad uniquement mysql puis ensuite retenter d’installer ma sauvegarde des Apps ?

Pour l’instant seul la sauvegarde de Wiki JS a fonctionné mais il me semble que ça n’utilise pas mysql justement ?..

Le reste c’est toujours la même erreur que l’utilisateur root n’a pas la permission de se connecter à mysql… c’est vraiment étrange !

@Aleks t’avais pa sun script automagic pour réparer les mysql cassé ?

1 Like

(C’est Bram qui l’a codé)

Warning : aucune garantie que ça marche ni que ça n’empire pas la situation…

1 Like

Salut ! :slight_smile:

J’ai déjà essayé hier soir une partie des commandes car j’avais trouvé le lien via une autre discussion… j’ai tenté directement les commandes suggérées dans la discussion mais ça n’a pas fonctionné.
Ensuite j’ai tenté les 3 commandes en bas du tuto, mais ça n’a pas fonctionné non plus.

Je verrais ce soir en rentrant les autres commandes au cas où.

Ne puis-je pas désinstaller complètement mysql, le ré-installer, puis installer ma sauvegarde des Apps ?

Passez une bonne journée.
Merci pour votre aide.

Amicalement, Francis.

Tu risques de désinstaller le paquet yunohost en faisant la désinstallation de mysql.

Pour reset mysql, je crois que tu peux faire:

mysqld --initialize

Et remettre le mot de passe root définit dans /etc/yunohost/mysql

Bonsoir, je viens de rentrer…

Alors voici la réponse à cette commande :

2021-01-11 18:45:16 0 [Warning] option 'table_open_cache': unsigned value 4 adjusted to 10
2021-01-11 18:45:16 0 [Note] mysqld (mysqld 10.3.27-MariaDB-0+deb10u1) starting as process 20056 ...
mysqld: Please consult the Knowledge Base to find out how to run mysqld as root!
2021-01-11 18:45:16 0 [ERROR] Aborting

Je me permets un petit Up ! Je sèche complètement au niveau des idées, je ne sais plus quoi faire…
Je suis vraiment blasé en fait :frowning: je pensais pouvoir migrer tranquillement…
Comment se fait-il que ce problème soit a priori connu car déjà arrivé depuis longtemps mais pas de solution réelle ? Je suis dubitatif. :thinking:

Arf bon tentons autre chose. Est-ce que tu peux faire (en root sur le serveur) :

mysql_password="$(cat /etc/yunohost/mysql)"
mysqladmin -s -u root -pyunohost password "$mysql_password"

et voir si maintenant tu arrives à te connecter en sql avec mysql -uroot -p

Sinon j’ai une autre idée qui consiste à tenter ce qu’il y a ici mais un poil + complexe

Sinon en fait là ce serait plus simple qu’on se trouve un moment sur le chat pour faire ça en interactif et itérer plus facilement/rapidement

1 Like

Bonsoir,
alors j’ai essayé la 1ère solution ça ne fonctionne pas mais merci quand même d’essayer de m’aider. :slight_smile:

Concernant le lien que tu m’as fait suivre + complexe, je ne comprends pas vraiment quelle commande dois-je taper et est-ce que je remplace root_password ou password par un nouveau MP ?

Effectivement par le chat peut-être ça serait mieux, par contre quand ?
là je suis en formation encore demain, je serais de retour chez moi vers 18h, samedi matin je ne suis pas là et l’après-midi je ne sais pas encore…
Sinon après normalement Dimanche j’ai un peu plus de temps libre mais bon ça m’ennuie de t’embêter avec ça un dimanche, jours de repos pour tout le monde…

Bonjour @Aleks et @ljf !

Alors, en me faisant aider par un copain de la monnaie libre nous avons fini par trouver le souci avec l’autorisation de root@localhost qui n’a pas le droit de se connecter à Mysql…

En fait il s’agit d’un problème de connexion par le plugin de connexion de Mariadb…
Donc pou résoudre le problème je me suis connecté à Mysql en suivant les recommandations su lien MYSQL root user is being denied permission while installing an app - #4 by kanhu en s’arrêtant à l’étape use mysql; :

service mysql stop
mysqld_safe --skip-grant-tables &
mysql -u root
use mysql;

Ensuite ceci :

update user set plugin='' where User='root';
flush privileges;
GRANT ALL PRIVILEGES ON *.* TO 'root'@'localhost' IDENTIFIED BY '<password>';

Remplacer ‘password’ par le MP que vous souhaitez.

exit;
service mysql start

Ensuite, redonner le bon MP, le nouveau choisi à etc/yunohost/mysql :

nano /etc/yunohost/mysql
Là renseigner le MP choisi puis quitter en sauvegardant les modifications (ctrl x)

Enfin tester de se connecter à Mysql ! :

mysql -u root -p
ça demande le MP vous tapez et là magie ! Ça fonctionne :slight_smile:

Du coup recommencer l’installation des sauvegardes des Apps et c’est ok, ça fonctionne, enfin ça s’installe sans erreurs… ! #Enjoy !

Bon ensuite j’ai eu erreur 502 Nginx… une fois le WordPress installé, en fait il essayait d’utiliser encore php7.0-fpm au lieu de php7.3-fpm … bon on a pas trop saisi pourquoi ni comment car s’était un peu 2h30 du matin…

Aujourd’hui miracle de la technologie ! La mise à jours de YunoHost et de WordPress a réglé le souci :wink: ouf ! :sweat_smile:

Bon là maintenant c’est Gitea qui me fait 502 Nginx… mais là je crois que je ne vais pas me prendre la tête car je n’avais pas grand chose dessus et j’étais en mode tests, du coup je pense que je vais refaire une installation toute propre de cette App (mais peut-être vu que j’ai grave de RAM que je vais mettre GitLab à la place) et Idem pour NextCloud.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.