Restauration d'une sauvegarde complète 4.0 en 4.1 (isProtected missing)

,

(C’est Bram qui l’a codé)

Warning : aucune garantie que ça marche ni que ça n’empire pas la situation…

1 Like

Salut ! :slight_smile:

J’ai déjà essayé hier soir une partie des commandes car j’avais trouvé le lien via une autre discussion… j’ai tenté directement les commandes suggérées dans la discussion mais ça n’a pas fonctionné.
Ensuite j’ai tenté les 3 commandes en bas du tuto, mais ça n’a pas fonctionné non plus.

Je verrais ce soir en rentrant les autres commandes au cas où.

Ne puis-je pas désinstaller complètement mysql, le ré-installer, puis installer ma sauvegarde des Apps ?

Passez une bonne journée.
Merci pour votre aide.

Amicalement, Francis.

Tu risques de désinstaller le paquet yunohost en faisant la désinstallation de mysql.

Pour reset mysql, je crois que tu peux faire:

mysqld --initialize

Et remettre le mot de passe root définit dans /etc/yunohost/mysql

Bonsoir, je viens de rentrer…

Alors voici la réponse à cette commande :

2021-01-11 18:45:16 0 [Warning] option 'table_open_cache': unsigned value 4 adjusted to 10
2021-01-11 18:45:16 0 [Note] mysqld (mysqld 10.3.27-MariaDB-0+deb10u1) starting as process 20056 ...
mysqld: Please consult the Knowledge Base to find out how to run mysqld as root!
2021-01-11 18:45:16 0 [ERROR] Aborting

Je me permets un petit Up ! Je sèche complètement au niveau des idées, je ne sais plus quoi faire…
Je suis vraiment blasé en fait :frowning: je pensais pouvoir migrer tranquillement…
Comment se fait-il que ce problème soit a priori connu car déjà arrivé depuis longtemps mais pas de solution réelle ? Je suis dubitatif. :thinking:

Arf bon tentons autre chose. Est-ce que tu peux faire (en root sur le serveur) :

mysql_password="$(cat /etc/yunohost/mysql)"
mysqladmin -s -u root -pyunohost password "$mysql_password"

et voir si maintenant tu arrives à te connecter en sql avec mysql -uroot -p

Sinon j’ai une autre idée qui consiste à tenter ce qu’il y a ici mais un poil + complexe

Sinon en fait là ce serait plus simple qu’on se trouve un moment sur le chat pour faire ça en interactif et itérer plus facilement/rapidement

1 Like

Bonsoir,
alors j’ai essayé la 1ère solution ça ne fonctionne pas mais merci quand même d’essayer de m’aider. :slight_smile:

Concernant le lien que tu m’as fait suivre + complexe, je ne comprends pas vraiment quelle commande dois-je taper et est-ce que je remplace root_password ou password par un nouveau MP ?

Effectivement par le chat peut-être ça serait mieux, par contre quand ?
là je suis en formation encore demain, je serais de retour chez moi vers 18h, samedi matin je ne suis pas là et l’après-midi je ne sais pas encore…
Sinon après normalement Dimanche j’ai un peu plus de temps libre mais bon ça m’ennuie de t’embêter avec ça un dimanche, jours de repos pour tout le monde…

Bonjour @Aleks et @ljf !

Alors, en me faisant aider par un copain de la monnaie libre nous avons fini par trouver le souci avec l’autorisation de root@localhost qui n’a pas le droit de se connecter à Mysql…

En fait il s’agit d’un problème de connexion par le plugin de connexion de Mariadb…
Donc pou résoudre le problème je me suis connecté à Mysql en suivant les recommandations su lien MYSQL root user is being denied permission while installing an app - #4 by kanhu en s’arrêtant à l’étape use mysql; :

service mysql stop
mysqld_safe --skip-grant-tables &
mysql -u root
use mysql;

Ensuite ceci :

update user set plugin='' where User='root';
flush privileges;
GRANT ALL PRIVILEGES ON *.* TO 'root'@'localhost' IDENTIFIED BY '<password>';

Remplacer ‘password’ par le MP que vous souhaitez.

exit;
service mysql start

Ensuite, redonner le bon MP, le nouveau choisi à etc/yunohost/mysql :

nano /etc/yunohost/mysql
Là renseigner le MP choisi puis quitter en sauvegardant les modifications (ctrl x)

Enfin tester de se connecter à Mysql ! :

mysql -u root -p
ça demande le MP vous tapez et là magie ! Ça fonctionne :slight_smile:

Du coup recommencer l’installation des sauvegardes des Apps et c’est ok, ça fonctionne, enfin ça s’installe sans erreurs… ! #Enjoy !

Bon ensuite j’ai eu erreur 502 Nginx… une fois le WordPress installé, en fait il essayait d’utiliser encore php7.0-fpm au lieu de php7.3-fpm … bon on a pas trop saisi pourquoi ni comment car s’était un peu 2h30 du matin…

Aujourd’hui miracle de la technologie ! La mise à jours de YunoHost et de WordPress a réglé le souci :wink: ouf ! :sweat_smile:

Bon là maintenant c’est Gitea qui me fait 502 Nginx… mais là je crois que je ne vais pas me prendre la tête car je n’avais pas grand chose dessus et j’étais en mode tests, du coup je pense que je vais refaire une installation toute propre de cette App (mais peut-être vu que j’ai grave de RAM que je vais mettre GitLab à la place) et Idem pour NextCloud.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.