Raspberry Pi image available!

en
#1

Thanks to @matlink, we now have a properly made Raspberry Pi image. The good news is that it is compatible with all the Rapsberry Pi models excpeted for RPi a+.

Please note that the image is 7z compressed, so you will need to install 7z if you don’t already have it.

At the first boot, the filesystem will expand automatically, and SSH keys will be regenerated. Be patient :smile:

Please follow the (updated) documentation and do not hesitate to give @matlink feedbacks!

https://yunohost.org/install_on_raspberry

With love <3
Kload

1 Like
pinned globally #2
#3

I know it says it is compatible with all images, but I’ve been having trouble installing the image on my RPI A+. The last image was having problems too.

Has this image been tested on a PRI A+?

#4

Hi JaredHarrill,

Infortunaly, this image hasn’t been tested on RPi A+.
This is the only exception were the image shouldn’t works.

#5

… I wish I knew that before hand. We spent way too much time trying to get it to work on one.
Have now switched to the B+. Had to use the old img file, new image file didn’t like the B+1.

#6

I’m trying to install Yunohost on a Raspberry Pi B (v1) and have trouble doing so (see Yunohost not working on Raspberry Pi after upgrade (mysql setup error) for full description). Is it supposed to work currently on this Pi model?

(cc @matlink )

#7

It’s surprising since the new image has been tested on the RPi B by @kload and worked well.
I think the issue is not from the installation itself, but the upgrade of mysql-server.
If you want to be sure of that, grab the old yunohost image and try to install it on your raspberry. See if there is no issue.

#8

Where can I download the old image?

#9

There is this one yuno rpi September 2014, and you can find other ones over there build yunohost. You’ll have a lot of updates for sure, but you can previously run them on your desktop with qemu, if you want.

#10

Thanks, I’ll give it a try. BTW, is there a difference between installing your premade images and installing Raspbian and then Yunohost with the dedicated script? Just to know if it’s worth trying that other option in case the sept. 2014 image fails to upgrade too.

#11

I finally managed to upgrade the RaspberryPi image on YunoHost 2.2 \o/

You can download it as usual: https://build.yunohost.org/yunohost4rpi2.img.7z

We had an issue at RaspberryPi booting + an incompatibility between the RPi B/B+ and YunoHost 2.2. All fixed now.

Edit: If you already have a Raspberry Pi B/B+ running and you want to upgrade it to YunoHost 2.2, please follow the instructions of this topic

#12

D’oh! I already erased my installation to write the old image to my SDCard… :smile:

I’ll check this by my issues seemed related to MySQL server (maybe due to a lack of memory) rather than Nginx…

#13

Tried the new image and after a bit of a mess (installation apparently stuck, turned the Pi off and on again, re-installation that triggered two or three reboots), it goes to the login screen but the system can’t find the network connection. During boot, it complains that it can’t find eth0 and indeed, after login, ifconfig doesn’t show it; only the loopback interface. The /etc/network/interfaces file seems ok.

Note that during boot, I have a message saying something like “eth1 copied from eth0”, not sure if it’s relevant as there isn’t an eth1 either in interfaces or reported by ifconfig.

EDIT: I have a bit of a doubt: is it a new “beta” image? Is it a new version that happened to be released yesterday and wasn’t as a reply to my issues at all?

EDIT 2: maybe the eth0 interface missing is a consequence of switching from bind9 to dnsmasq?

unpinned #14
#15

(up) (@matlink @kload)

Any idea why the Pi can’t find eth0 with Yunohost 2.2?

#16

Yes, maybe the interface is called eth1. It’s a known issue.

#17

I am now running YunoHost on a VPS at Greenhost.

If I’d want to transfer it to my RPi, is there some instruction on how to do such a migration (with all files, users etc.)

#18

Is it fixable on my side or do I have to wait for a new image?

#19

It’s a quite random issue, we never now when and why it’s happening.
You can try to fix it by mounting your SD-card on your desktop computer, and go to the etc/networki/interfaces file, and change eth0 to eth1.

#20

Thanks, I added eth1 to the interfaces files and now it seems to work. Until the next issue. I’ll open a specific thread.