Yunohost not working on Raspberry Pi after upgrade (mysql setup error)

I’m trying to install Yunohost on a Raspberry Pi B (v1). I’ve first installed it in a VM on my PC to see how the install worked and then put the correct image on the Pi’s SDcard.

At first boot (without a display − I mean I don’t have a physical screen on which I can plug the Pi, not that it displays a black screen), I couldn’t ping the Pi’s IP, even after waiting quite some time. I managed to get a screen temporarily and saw that there was a message saying that it couldn’t perform a fsck and I had to do one manually. Not sure if there has been an error when writing the image on the card or if it is a normal behaviour because after that I resized the partition with GParted. Anyway, after resuming the fsck, the system booted up without problem and I could do the post-install. I didn’t check if the web interface was working, though, but the root and admin account work.

Then, I decided to update & dist-upgrade the system. During the process, I had an error from MySQL saying it couldn’t set the password. I didn’t pay much attention and resumed.

Now, I have no display again so I have to resort on the SSH session. There is still an error with MySQL and the web interface is not working (ERR_CONNECTION_REFUSED on Google Chrome). When I dist-upgrade again as root, I have the following:

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
5 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? Y
Setting up mysql-server-5.5 (5.5.43-0+deb7u1) ...
[ ok ] Stopping MySQL database server: mysqld.
[FAIL] Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing mysql-server-5.5 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mysql-server:
 mysql-server depends on mysql-server-5.5; however:
  Package mysql-server-5.5 is not configured yet.

dpkg: error processing mysql-server (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of yunohost-config-mysql:
 yunohost-config-mysql depends on mysql-server; however:
  Package mysql-server is not configured yet.

dpkg: error processing yunohost-config-mysql (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of yunohost-config:
 yunohost-config depends on yunohost-config-mysql; however:
  Package yunohost-config-mysql is not configured yet.

dpkg: error processing yunohost-config (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of yunohost:
 yunohost depends on yunohost-config; however:
  Package yunohost-config is not configured yet.

dpkg: error processing yunohost (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried to dpkg-reconfigure mysql-server but I get this:

/usr/sbin/dpkg-reconfigure: mysql-server is broken or not fully installed

At that point, I’m pretty much stuck… What should I do to fix the installation/update of mysql-server?

I have the exact same problem…

After trying to force reinstallation of mysql-server (or mysql-server-5.5 but I guess they’re the same package), I get the following error: E: Internal Error, No file name for mysql-server:armhf

It seems to be a known problem as there are similar issues on the Raspbian forums. I’m looking into this.

EDIT: nope. Tried to remove mysql-server and yunohost packages then reinstall them but I get the same error than yesterday with MySQL saying it can’t set the root password and I’m back at the beginning.

Didn’t see it at first but when trying to setup the MySQL password for root (which fails), I get the following output:

Setting up mysql-server-5.5 (5.5.43-0+deb7u1) ...
[ ok ] Stopping MySQL database server: mysqld.
150515  8:34:06 [Note] /usr/sbin/mysqld (mysqld 5.5.43-0+deb7u1) starting as process 9229 ...
150515  8:34:06 [Note] Plugin 'FEDERATED' is disabled.
150515  8:34:06 InnoDB: The InnoDB memory heap is disabled
150515  8:34:06 InnoDB: Mutexes and rw_locks use GCC atomic builtins
150515  8:34:06 InnoDB: Compressed tables use zlib 1.2.7
150515  8:34:06 InnoDB: Using Linux native AIO
150515  8:34:07 InnoDB: Initializing buffer pool, size = 128.0M
InnoDB: mmap(135987200 bytes) failed; errno 12
150515  8:34:07 InnoDB: Completed initialization of buffer pool
150515  8:34:07 InnoDB: Fatal error: cannot allocate memory for the buffer pool
150515  8:34:07 [ERROR] Plugin 'InnoDB' init function returned error.
150515  8:34:07 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
150515  8:34:07 [ERROR] Unknown/unsupported storage engine: InnoDB
150515  8:34:07 [ERROR] Aborting

150515  8:34:07 [Note] /usr/sbin/mysqld: Shutdown complete

Not enough memory on the Pi, maybe? But I thought Yunohost has been tested on it?

I’ve tried to restart from scratch, with a proper display this time, so I could see if there had been a mistake from me with the previous installation. Still the same: everything installs properly until the upgrade where MySQL is kind of broken.

Does this fixes the issue ?

Well, I can’t say as when this was announced, I had already reinstalled from the new Yunohost 2.2 image, on which I have other issues (see…