Upgrade on Raspberry Pi B/B+



As you may have noticed, the YunoHost 2.2 major upgrade broke the Nginx Web server on Rasberry Pi model B and B+.

It is related to the specific CPU architecture (armv6) of those first Raspberry Pi models. The Nginx package was compiled of a “standard” armv7 architecture, leading Nginx to throw some Illegal intructions.

We decided to maintain a specific package repository for now on, exclusively for those Raspberry Pi models.

If you have a Raspberry Pi B/B+ running and want to upgrade to YunoHost 2.2, you have to change your package repositories manually. To do so, edit the /etc/apt/sources.list file on your Pi, and change megusta by stable/rpi.

Your sources.list should look like this:

deb http://mirrordirector.raspbian.org/raspbian wheezy main non-free
deb http://archive.raspberrypi.org/debian wheezy main
deb http://repo.yunohost.org/ stable/rpi main

Then, just run the upgrade manually (there have been some dependencies upgrades, so you need to run a dist-upgrade):

sudo apt-get update
sudo apt-get dist-upgrade

You should now be able to use your YunoHost 2.2 properly.

Note: Once again, we apologize for this inconvenience. We do not actually have the manpower nor the time to maintain all our images properly, by testing, releasing and supporting them.
If you are interested by any mean in maintaining an image for a platform (like Raspberry Pi model B/B+), please let us know :blush:
And of course, your bug reports are really appreciated.

Thank you <3

Thank you VERY MUCH for all the work done!
And you 're forgiven :wink:

thank you,maybe i will try this weekend,after make a dd backup :smile:
have a good night people!

Hi, @kload,
it seems Metronome package also has some compilation problems. Here is the error thrown after upgrading it :

[…] Starting Metronome XMPP Server: metronomeIllegal instruction

Thank you for the distro

@ZeHiro What is your Pi model ?

@kload : it is running on a Pi B

I packaged the App on a model B… I don’t understand why you have this messgae

OK. Thanks. I’ll try a full reinstall, when I have the time.
I didn’t upgrade to jessie, could this be the problem?

It should not. Raspbian is still on Wheezy

hm, my instance looks pretty messed up now. If I reinstall, is there any way for me to continue using the .nohost.me domain I had?

@tiemay Contact me via private message for that. Otherwise you will not be able to use it again.

after edit the /etc/apt/sources.list to:

deb http://mirrordirector.raspbian.org/raspbian wheezy main
deb http://archive.raspberrypi.org/debian wheezy main
deb http://repo.yunohost.org/ stable/rpi main

i did

apt-get update
apt-get dist-upgrade
yunohost app fetchlist
yunohost app upgrade

update process:
automatic removes openresty

A processar ‘triggers’ para man-db …
dpkg: openresty: problemas com dependências, mas mesmo assim a remover conforme você pediu:
yunohost-config-nginx depende de openresty (>= 1.4.1) | nginx-extras (>= 1.4.1); no entanto:
O pacote openresty vai ser removido.
O pacote nginx-extras não está instalado.

(A ler a base de dados … 56041 ficheiros e directórios actualmente instalados.)
A remover openresty …
dpkg: aviso: ao remover openresty, o directório ‘/usr/local’ não estava vazio, por isso não foi removido

when updating i say no (default) to:

this is the errors about metronome upgrade:

A preparar para substituir metronome 3.5~megusta4 (a usar …/metronome_3.6-6.rpi_armhf.deb) …
rm -rf /usr/lib/metronome
rm -rf /usr/lib/metronome/modules
rm -f /usr/bin/metronome
rm -f /usr/bin/metronomectl
rm -f metronome.install
rm -f metronomectl.install
rm -f metronome.cfg.lua.install
rm -f metronome.version
make clean -C util-src
make[1]: Entering directory '/usr/share/yunohost/metronome-src/util-src’
rm -f *.o
rm -f .so
rm -f …/util/
make[1]: Leaving directory '/usr/share/yunohost/metronome-src/util-src’
A descompactar substituto metronome …
metronome: unrecognized service

have this lines too:

update-rc.d: warning: default start runlevel arguments (2 3 4 5) do not match raspi-config Default-Start values (S)
update-rc.d: warning: default stop runlevel arguments (0 1 6) do not match raspi-config Default-Stop values (none)

everything is working except the metronome,is not working and i have errors telling me on boot about metronome start/tls keys failed to load from certmanager seems linked to example certs.
have a error udisk-glue automonter failed on boot
i need to upgrade some app manually and give the url later.
need to do some tests,but seems all ok.
my plattaform is raspberry pi2

so what can i do to put metronome working without need to restore to the old yunohost version ?

Maybe a apt-get install --reinstall metronome

thanks @kload but its not so simple,i replace the file domain.cfg.lua from the cfg.lua.old still not working,no error on boot but when i try connecting say server not compatible,gona check all th conf files,one by one, from the old backup and try to replace the diferent to the metronome folder,maybe this way i will find whats wrong.
update:not working,try to change all th files and if i tail -f /var/log/metronome/metronome.err
the log tell me this:

modulemanager error Unable to load module ‘legacyauth’: /usr/lib/metronome/modules/mod_legacyauth.lua: No such file or directory
Jun 05 21:39:04 modulemanager error Unable to load module ‘auth_ldap2’: /usr/lib/metronome/modules/mod_auth_ldap2.lua: No such file or directory

so i just copy all the old img folder usr/lib/metronome/modules/ to the new one
and is now working:)

Hi, I have upgraded the Raspberry PI image and it needs tests. You can download it from here: http://build.yunohost.org/yunohost4rpi2.new.7z

The autoresize of the fs at the reboot of the PI does not seem to be working, the fs was read only for me after rebooting on a RPI B.
I may have expanded the fs with gparted before the first boot. Do you check if it already expanded after forcing the expansion?

woop! Got a working install again on my RPi B+ with that new image. I expanded the ext4 fs with gparted before booting, and then during boot I ran into this:

        (i.e., without -a or -p options)
fsck died with exit status 4
failed (code4).
[FAIL] And automatic file system check (fsck) of the root filesystem failed. A manual fsck must be performed, then the system restarted. The fsck should be performed in maintenance mode with the root filesystem mounted in read-only mode. ..
[warn] The root filesystem is currently mounted in read-only mode. A maintenace shell will now be started. After performing system maintenance, press CONTROL-D to terminate the maintenance shell and restart the system.. ... (warning).
Give root password for maintenance
(or type Control-D to continue):

but after logging in as root, and doing fsck then exit, it automatically rebooted and then started up ok. Post-installation also went ok, as did updating packages (though it only had one update).


@tiemay You don’t need to use Gparted, a script is taking care of resizing your main partition at the first boot.

Works fine! Many Thanks!