Migration rpi4 from ARMHF to ARM64

Hello everyone. I start this topic with the idea of, once it will be done, document how to migrate from a raspberry with (legacy ?) 32 bits architecture to 64 bit. The project is motivated by nextcloud being deprecated with 32 bits architectures.
What I have done so far:

  • create backup on ARMHF rpi
  • flash brand new ARM64 yunohost image to new disk
  • sudo yunohost restore <my_backup> --system
  • Trying to restore my apps one by one.

Problems encountered not solved :

  • emails did not recovered yet
  • any app restoration is impossible because of already existing permissions
  • domain nginx conf did not follow : for now, I deleted all the domains and recreate them

Didn’t start the nextcloud work yet…
Any idea on the problems ? Of course I continue to work on my side.
All the best,

1 Like

As always, we can’t have any idea on the problems with only a vague description. We need logs / accurate error message and detailed context

Thanks, yes sure, regarding the existing permissions, here are the logs for the simplest app, the multi_webapp : https://paste.yunohost.org/raw/onekehatep
I already tried sudo yunohost user permission remove multi_webapp.main .
Regarding the emails, I don’t know how to get more precise logs…
Thanks, and sorry for my first message which was a bit short…

Annnnd did you do anything special related to this app before this restoration attempt ? Like what is the log of the very first restoration attempt ?

No I didn’t, nor this one nor any other, for which I have similar/exactly logs.
Regarding emails, I noticed that the folder recovered, but not the main box

Ok, something (maybe not the cleanest solution) which works regarding permission problems during app restoration : try a fresh install of the app which will fail but allow you to make a clean remove of the app. Then, the restore works (at least with multi_webapp and kanboard, roundcube, grav, I will continue this way). Hope this helps

Did you check this post ?

It says

if some apps are borken, i pretty sure if you force the upgrade of the app after the restore it should be ok.

Thanks, I am sure it will help when I will get to more complex apps (now working on vaultwarden…), and I am very anxious about nextcloud… I will report here.
UPDATE : I had at first 502 error after successful restore of vaultwarden, and a yunohost app upgrade vaultwarden --force did the job. Thanks also to [RĂ©solu] Migration 64bits plantage vaultwarden
UPDATE 2 : I had a chown error during nextcloud restoration, tried this fix : One of my Nextcloud installs is missing after a system upgrade - #3 by colmoneill

So this is the end of it. There were no more difficulties than the three stated in the first message:

  • emails
  • incoherent nginx configuration files for domains causing errors.
  • app restoration impossible at first because of existing permissions
    The fixes which worked for me:
    -Regarding emails, I did manual copies from the backup tarball to the new system.
  • Regarding the nginx confs, I deleted and re-added all my domains manually.
  • Regarding app restoration. I followed a cycle yunohost app install <myapp> => permissions already exists error => yunohost app remove <myapp> => yunohost backup restore <mybackup> --apps <myapp>. It worked like this for all the apps but vaultwarden which needed after “sucess” in restoration a forced upgrade.
    I also had a chown error during my first attempt of nextcloud restoration but this was an old problem due to uid < 1000 and unrelated to the restoration. Fix is in One of my Nextcloud installs is missing after a system upgrade - #3 by colmoneill .
    Finally, this migration went fine with a bit of work, thanks for your help @gauthier67 and @Aleks !
    Best regards,
1 Like

I think I did the same, without any problem I can recall.

My desk was full of Orange Pi Zero’s from my children and some classmates that did not have a reliable internet connection at home, and I ran out of USB power supplies (and ports on my switch).

One by one I created backups via the yunohost backup, and restored them on LXC-containers.

Orange Pi zero is built around an Allwinner H2+ CPU that with Cortex A7 architecture, which is 32 bit.

My Proxmox is running AMD64; the backups went from 32-bit ARM to 64-bit Intel.

This does not help you a lot of course, but I think your problems are not related to the architecture.

Do you still have your original installation? You could try with one backup for system and apps combined, if you did not try so yet.

Thanks for your contribution @wbk , indeed I don’t think my problems were related to the architecture, which is the good news ! I was a bit anxious about this transition and could not find so many info on it, so I decided to create this topic to add data on it. And I think more and more rpi users will engage into it as apps get deprecated for 32bits architectures. You are right, maybe the restoration in one step would have avoid some of the errors I had… But I made the choice to restore step by step because of the time needed every time to prepare the backup for restore when restoring everything in one time. I don’t have a final opinion on it. But definitely, it is possible to migrate from a 32 to a 64bits architecture on raspberry pi with yunohost.

Typing my message crossed your message that the problems were solved.


Have fun with your old new installation :smiley:

1 Like