[Jitsi Meet] Ni son, ni image de l'autre utilisateur - No sound or image of the other user

,

My YunoHost server
Hardware: HP Proliant Gen10 hosted at home
YunoHost version: 3.7.1.1 (stable)
Host: Debian 9.12
Kernel: 4.9.0-12-amd64
Server access: SSH

Hello,
I installed Jitsi Meet on my Yunohost instance and completed my DNS zone at my registrar ( OVH ) and redirected the necessary ports (tcp 4443 and UDP 10000) in my Freebox. I can launch a Jitsi Meet session in Chromium and invite a correspondent who also uses Chromium, in this case another computer using another IP address thanks to a VPN installed on this machine.

  1. I can’t see or hear the correspondent. On my side (moderator) his thumbnail indicates that his microphone is not open and his camera is disabled whereas this is not the case. On his side (guest) it’s the same thing; the moderator’s microphone and camera are indicated as closed while this is not the case. Beside, the private message exchange works both ways


  2. When I invite a caller on my phone with data only without wifi access, I get the following message in the Android app: "You’ve been disconnected. Please check your network connection. Reconnect in XX sec
"[Settled by installing a Let’s Encrypt certificate on the sub-domain auth.jitsi.mondomain.tld]

  3. root@mydomain:/# iptables -L returns me :

ACCEPT tcp - anywhere anywhere tcp dpt:4443
ACCEPT udp - anywhere udp dpt:10000

root@mondomane:/# yunohost firewall list returns me

opened_ports:
22
25
53
80
443
587
993
4443
5222
5269
5347
5353
10000

If anyone who has managed to get Jitsi Meet running on their own home-hosted server comes by, help would be welcome.

Thank you in advance.

Edit 23/04/2020 : I installed a Let’s Encrypt certificate for mydomain.tld and the Jitsi sub-domain; this works for jitsi.mydomain.tld / conference.jitsi.mydomain.tld / jitsi-videobridge. jitsi.mydomain.tld and focus.jitsi.mydomain.tld *but with the indication “The configuration file ‘/etc/nginx/conf.d/auth.jitsi.jychanel.net.conf’ was removed manually, and will not be created”.
But the certificate installation fails for auth.jitsi.modomain.tld
.
[Settled]

Mon serveur YunoHost

Hardware : HP Proliant Gen10 hebergé à la maison
YunoHost version : 3.7.1.1 (stable)
Host : Debian 9.12
Kernel : 4.9.0-12-amd64
AccĂšs au serveur : SSH

Bonjour,
J’ai procĂ©dĂ© Ă  l’installation de Jitsi Meet sur mon instance Yunohost et complĂ©tĂ© ma zone DNS chez mon registrar OVH et rĂ©dirigĂ© les ports nĂ©cessaires (tcp 4443 et UDP 10000) dans ma Freebox. Je peux lancer une session Jitsi Meet dans Chromium et inviter un correspondant qui utilise lui aussi Chromium, en l’occurence un autre ordinateur utilisant une autre adresse IP grace Ă  un VPN installĂ© sur cette machine.

  1. Je ne vois ni ne peux entendre le correspondant. De mon cotĂ© (modĂ©rateur) sa vignette indique que son micro n’est pas ouvert et sa camĂ©ra dĂ©sactivĂ©e alors que cela n’est pas le cas. De son cotĂ© (invitĂ©) c’est la mĂȘme chose ; le micro et la camĂ©ra du modĂ©rateur sont indiquĂ©s comme fermĂ©s alors que cela n’est pas le cas. Par contre, l’échange de message privĂ© fonctionne dans les deux sens


  2. Quand j’invite un correspondant sur mon tĂ©lĂ©phone uniquement en data sans accĂšs au rĂ©seau wifi, j’ai le message suivant dans l’application Android : “Vous avez Ă©tĂ© dĂ©connectĂ©. veuillez vĂ©rifier votre connexion rĂ©seau. reconnexion dans XX sec
” [RĂ©glĂ© grace Ă  l’installation d’un certificat Let’s Encrypt sur le sous-domaine auth.jitsi.mondomaine.tld]

  3. root@mondomaine:/# iptables -L me renvoie :

ACCEPT tcp – anywhere anywhere tcp dpt:4443
ACCEPT udp – anywhere anywhere udp dpt:10000

root@mondomane:/# yunohost firewall list me renvoie

opened_ports:

  • 22
  • 25
  • 53
  • 80
  • 443
  • 587
  • 993
  • 4443
  • 5222
  • 5269
  • 5347
  • 5353
  • 10000

Si quelqu’un(e), qui a rĂ©ussi a faire fonctionner Jitsi Meet sur son propre serveur hebergĂ© Ă  domicile, passe par lĂ , une aide serait la bienvenue.

Merci d’avance

Edit 23/04/2020 : j’ai installĂ© un certificat Let’s Encrypt pour mondomaine.tld et le sous domaines de Jitsi ; cela fonctionne pour jitsi.mondomaine.tld / conference.jitsi.mondomaine.tld / jitsi-videobridge.jitsi. mondomaine.tld et focus.jitsi.mondomaine.tld) avec chaque fois l’indication "The configuration file ‘/etc/nginx/conf.d/auth.jitsi.jychanel.net.conf’ was removed manually, and will not be created".
Mais l’installation du certificat Ă©choue pour auth.jitsi.modomaine.tld
 [RĂ©glĂ©]

Yes it’s a kown problem: there are issues about that: https://github.com/YunoHost-Apps/jitsi_ynh/issues/29 and https://github.com/YunoHost-Apps/jitsi_ynh/issues/10.

And an ongoing PR to try to solve that: https://github.com/YunoHost-Apps/jitsi_ynh/pull/43

Thank you for your answer and your investment (and by the way, for all the maintainers).
I’ve reached my level of incompetence but I’m hanging in there trying to keep up with the github discussions
 It’s tough .
Thanks again

Merci de ta réponse et de ton investissement (et au passage de celui de tous les mainteneurs).
J’ai atteint mon niveau d’incompĂ©tence mais je m’accroche pour essayer de suivre les discussions sur github
 Dur dur.
Merci encore

1 Like

No problem, it was just to let you know that for now jistsi_ynh only work beetween two chromium
 But there’s ongoing work to make it completly available in Yunohost

1 Like

Thank you for your message. Indeed between a Chromium under Linux and a Chrome under Windows 10, sound and image are not transmitted. I will follow the discussions on github. Congratulations for the work done and good luck for the future!

PS: Is it justified to test the testing, coturn or fix_video branches? Given that you either need to add a sub-domain coturn.jitsi.domain.tld or remove the sub-domains from jitsi (and the DNS zone rules at my registrar 
?) I’m afraid I’ll make a mess


Merci de votre message. Effectivement entre un Chromium sous Linux et un Chrome sous windows 10, le son et l’image ne sont pas transmis. Je vais suivre les discussions sur github. Bravo pour le travail effectuĂ© et bon courage pour la suite !

PS: est-ce justifier de tester les branches testing, coturn ou fix_video ? Etant donnĂ© qu’il faut soit ajouter un sous-domaine coturn.jitsi.domain.tld soit alors supprimer les sous-domaines de jitsi (et les rĂšgles de la zone DNS chez mon registrar 
?) Je crains de mettre le bazar


it’s better to wait.

  • in the testing there’s no more than the master
  • coturn branch was a try to bypass jitsi-videobridge error
  • fix_video has to wait Metronome 3.13.5 that would be included in YunoHost 3.8. and with this branch it’s no more needed to create additional domains

Thank you for that clarification. As Master Yoda said, you must have patience, my (young) padawan


1 Like

Bonjour,

  1. J’ai le mĂȘme souci que celui Ă©voquĂ© par ‘pointnemo’ mais aussi par ‘jaakj’ dans les issues du github de Jitsi-meet (https://github.com/jitsi/jitsi-meet/issues/2826 :: Guests are connected but can’t see and hear each other).

  2. Mon instance de Jitsi est sur une Yunohost installé sur un VPS Gandi.
    J’ai lu qu’une solution proposĂ©e consistait Ă  modifier un fichier de conf pour rĂ©gler le problĂšme :

I added two lines into /etc/jitsi/videobridge/sip-communicator.properties:
org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=‘my-private-ip’
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=‘my-public-ip’

Mais, il n’y a pas d’adresse privĂ©e sur mon VPS (ou bien je me trompe ?) donc pas de rĂ©ponse de ce cotĂ© lĂ .
D’ailleurs, il y a 2 fichiers de conf dans Yunohost correspondant à ce ‘sip-communicator.properties’ :

  • un situĂ© Ă  : /etc/yunohost/apps/jitsi/conf/sip-communicator.properties
  • un situĂ© Ă  : /var/www/jitsi/.sip-communicator/sip-communicator.properties
  1. Je n’ai pas compris la(les) solution(s) proposĂ©e(s) par ‘yalh76’ car elle(s) ne me semble(nt) pas correspondre au problĂšme Ă©voquĂ© !

  2. Est-ce un problÚme de Firewall ? En ce cas, comment le résoudre ?

  3. Je ne suis pas sĂ»r que ce soit un problĂšme de navigateur car c’est la mĂȘme histoire entre 3 participants : un ordiphone sous Chrome/android, un laptop sous Firefox/Debian et un laptop sous Chromium/KaliLinux
    Chacun se voit lui-mĂȘme (super ! Merci Narcisse
) mais les deux autres sont cochĂ©s muets en audio ET vidĂ©o !

Merci donc d’avance pour un dĂ©but d’aide extĂ©rieur.
Je tourne en rond (vous me direz qu’en ce moment, ca peut occuper !)

Bonjour,

  1. Pour le fichier de conf dont tu parles, j’ai bien un fichier sip-communicator.properties mais je ne comprends pas de quelle adresse IP il s’agit : l’adresse de mon serveur (auto-hĂ©bergĂ©) sur mon rĂ©seau local ? (en 192.168.0.XXX) ou alors son adresse publique (celle de ma box) ?

Par ailleurs sur ce mĂȘme fichier de configuration, j’ai org.jitsi.videobridge.TCP_HARVESTER_PORT=__PORT__ pour la version dans le rĂ©pertoire /etc/yunohost/apps/jitsi/conf/
et
org.jitsi.videobridge. TCP_HARVESTER_PORT=4443 pour la version dans le répertoire /var/www/jitsi/.sip-communicator/
Etrange ?

  1. Ce que j’ai compris des solutions proposĂ©es par yalh76 c’est qu’il fallait attendre que le paquet yunohost de jitsi-meet soit modifiĂ© pour rĂ©gler ce problĂšme de micro et camĂ©ra du correspondant dĂ©sactivĂ©s. Donc patience et longueur de temps


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.