Images upload with XMPP / Metronome

This was from 23 days ago, anyone know if the upload functionality has been updated in the official build?
Are there still configuration changes needed to make it work?

This is part of YunoHost 3.8 changelog, currently in testing : YunoHost 3.8 testing / Call for feedback

1 Like

awesome! If I read correctly I still need to open port 5290 and 5291 correct?

Uuuuh dunno where you read this ? As far as I know you just need the port mentionned on

  • XMPP: 5222 (clients), 5269 (servers)

Oh, I thought there were different ports for file uploads on xmpp

I saw it above in this thread, though I likely misunderstood.


Maybe you’re partially right : nginx seems to act as a reverse proxy for that port :

But I don’t know all the details, maybe pitchum who worked on the actual implementation does

1 Like

okay, I was being overly optimistic that I’d missed a step but it still doesn’t work even after editing the metronome config (though I may try again).

I’ve been fighting with this for some time (although I’m more of an enthusiast than technically capable), I guess I’ll just hold my breath until it makes it into the release.

@lps are you already using yunohost 3.8?
If yes could you please give more details?

If not I guess you’re trying to hack your yunohost install to achieve the same but beware that there are multiple changes to perform, not only in metronome’s config. Also in nginx, in regen_conf, …
If you feel confident you may find inspiration in the PR-831 but keep in mind that most of these changes will need to be adapted.

But I would suggest to wait for yunohost 3.8 instead.

1 Like

Thanks @pitchum yes I was trying to modify a 3.7 version of Yunohost to achieve this but I think it’s wise for me to wait.

Is the official 3.8 far off? Will 3.8 overwrite any incorrect changes I may have made?

Last question:) I’ve read that the XMPP app Conversations has the ability to use video and audio calling in the latest release, is the Metronome server cable of supporting this? Sorry, if this is a really naive question.

I don’t think so. But you’ll probably see many error messages from regen-conf complaining about your changes and you’ll be able to overwrite your changes in metronome with something like yunohost tools regen-conf --force metronome. @Aleks please correct me if I’m wrong.

I haven’t explored this yet but I’m pretty sure it won’t work out of the box because this feature needs some additional software to work properly: a STUN server and if possible a TURN server. As far as I can see metronome does not provide these services and you will probably have to install coturn for example and add some more DNS records and probably add some configuration in metronome module mod_disco.

It won’t overwrite, but maybe in that specific case, considering there are many changes in metronome/nginx conf related to this happening in new files, it might create a huge mess and create inconsistencies in the conf … But yeah you can always force the regen-conf (all of this will be advertised in the diagnosis interface)

Anyway at this point I would just advise to upgrade to the testing 3.8 as it’s already pretty stable rather than tweaking everything by hand…

1 Like

Thanks! I’m pretty sure I made backups of the original configs before I started so all should be good. Alternatively I’ll keep the regen-conf command in mind.

Is it possible to downgrade or restore a backup if there are issues with 3.8?

Restore a backup yes … Downgrading uh no

1 Like

Thanks, I’ll wait a bit longer:)

It seems that voice and video calls don’t work in 3.8 ‘out of the box’

Seems someone is working on it though. Fingers crossed


Any outcome on this? :stuck_out_tongue:

Well file upload is now integrated / available in the core since version 3.8 if you correctly setup the xmpp-upload subdomain as advised by the diagnosis

1 Like

A, thanks, I was referring to the audio/video capabilities actually to work with Conversations :slight_smile:

1 Like

audio and video is working with Conversations:)

Whaaaaaat??? It is?? Then something is wrong with my setup…

Hhmm, just saw that XEO-0215 External Service Discovery is unavailable…Very strange… What ports does this service listen to?