Images upload with XMPP / Metronome

Thanks gives me green lieghts gives me the info that the porst are blocked

http_interfaces = { “”, “::1” }
http_interfaces = { “*” }

did not solve the problem - still can´t send images :frowning:
Any idea ?

What do you see when visiting http://upload.yourdomain.tld:5290?
And what do the log (/var/log/metronome/metronome.log) say?

thanks for your help massimilliano,

http://upload.yourdomain.tld:5290 does give me NO conection :-(( - not working

in the error log I found this:

Feb 08 14:00:21 modulemanager	error	Error initializing module 'websocket' on 'upload.yourdomain.tld': /usr/bin/metronome:149: loop or previous error loading module 'util.websocket'
stack traceback:
	/usr/lib/metronome/core/modulemanager.lua:30: in function </usr/lib/metronome/core/modulemanager.lua:30>
	[C]: in function '_real_require'
	/usr/bin/metronome:149: in function 'require'
	/usr/lib/metronome/modules/mod_websocket.lua:20: in main chunk
	(tail call): ?
	[C]: in function 'xpcall'
	/usr/lib/metronome/core/modulemanager.lua:30: in function 'pcall'
	/usr/lib/metronome/core/modulemanager.lua:163: in function 'do_load_module'
	/usr/lib/metronome/core/modulemanager.lua:240: in function 'load'
	/usr/lib/metronome/core/modulemanager.lua:61: in function '?'
	/usr/lib/metronome/util/events.lua:67: in function 'fire_event'
	/usr/lib/metronome/core/hostmanager.lua:119: in function 'activate'
	/usr/lib/metronome/core/hostmanager.lua:51: in function '?'
	/usr/lib/metronome/util/events.lua:67: in function 'fire_event'
	/usr/bin/metronome:288: in function 'prepare_to_start'
	/usr/bin/metronome:384: in main chunk
	[C]: ?

Does this tell you something?

If you folks want to dig in this issue, you might want to read :

i see now you added host name in yunohost that causes conflict, so you need to remove the file /etc/metronome/conf.d/upload.yourdomain.tld.cfg.lua
or at least move it with
mv /etc/metronome/conf.d/upload.yourdomain.tld.cfg.lua /etc/metronome/conf.d/upload.yourdomain.tld.cfg.lua.backup

And if you want to use https then you need to edit as follow:
Host " * "
https_ports = {}
https_ports = { 5291 }
https_interfaces = { " * " }

Component “upload.yourdomain.tld” “http_upload”
name = “yourdomain.tld Sharing Service”
ssl = { key = “/etc/yunohost/certs/upload.yourdomain.tld/key.pem”, certificate = “/etc/yunohost/certs/upload.yourdomain.tld/crt.pem” }
http_file_size_limit = 12 * 1024 * 1024 --without the spaces before and after the *
http_file_quota = 60 * 1024 * 1024 --without the spaces before and after the *
http_file_allowed_mime_types = { [“txt”] = “text/plain”, [“png”] = “image/png”, [“pdf”] = “application/pdf”, [“jpg”] = “image/jpeg”, [“jpeg”] = “impage/jpeg”, [“gif”] = “image/gif”, [“mp4”] = “video/mp4”, [“mpeg”] = “video/mpeg”, [“m4a”] = “audio/m4a”, [“ogg”] = “application/ogg”}


/etc/metronome/conf.d/upload.yourdomain.tld.cfg.lua does not exist on my yunohost

do you mean i should creat this file?

also the folder
does not existed on my yunohost

If the file is not there is ok then.
That also mean that the cert can’t be there either witch means you can only use http and not https for file upload.

so if i have xmpp installed on a domain which runs https i have no chance - right ?

It uses different port so it doesn’t matter.

See here if you have still issue:

1 Like

but sorry - this does not work at my yunohost… the server still does not upload images

share your entire config here (delete any sensible data before).

Ok with

`nano /etc/metronome/metronome.cfg.lua`

i can edit the file.

Can you tell me a quick an easy way to downlaod or copy the file? Thanks

Best way is to copy it over here:

Again, just delete any sensible/private data (passwords or things like that)

yes - but how do i get the copy?

I do not understand, sorry.
You need some basic technical skills and background to move on.

You have to access you Yunohost box via SSH and copy the content of /etc/metronome/metronome.cfg.lua over a pasting service. I can’t help more until you do that.

I leard and did it :wink:

Just tried this:

but did not work on my server…


Finally there is maybe an solution for the problem:

Hi Metronome Guys,

I am new to the club. I am an iOS developer. I currently have trouble configuring and using Metronome IM. For the sake of all newbies and me, is there anyone who would be kind to tell us something about basics of configuring and setting up Metronome to listen for clients ?

acutally xmpp shoult work with yunohost out of the box… but as you can read in this thread - images and attachments so not work jet… but maybe with this adaptions soon: