Images upload with XMPP / Metronome


#1

I tested the yunohost xmpp metronome server… i can send messages (great !!!) but no images or file attachments.

Is a extra configuration of the server needed?
thanks


#2

you can try this, it worked for me
https://forum.yunohost.org/t/metronome-envoie-de-fichier/6607


#3

So you are saying this configuration has to be added?

–Component “upload.{{ main_domain }}” “http_upload”

– name = “{{ main_domain }} Sharing Service”

– http_file_size_limit = 6 1024 1024
– http_file_quota = 60 1024 1024

I´m a newbie – can you tell me how I can add this command by ssh ?

thanks


#4

A new version of metronome was release, which might fix the issue if I understand correctly.

So maybe a simple apt update && apt dist-upgrade would fix the issue.


#5

nano /etc/metronome/metronome.cfg.lua

STEP1 uncomment to get this

https_ports = { 5291 }
https_interfaces = { “127.0.0.1”, “::1” }

STEP2 comment to get this
—Set up a HTTP Upload service
–Component “upload.your_domain” “http_upload”
– name = “your_domain Sharing Service”
– http_file_size_limit = 610241024
– http_file_quota = 6010241024

STEP3

service metronome restart


#6

@mrmars : is it still really needed with the latest metronome version …?


#7

was up to date the 30 december 2018…I’ve missed a few updates except the last one from yesterday that appeared on my system update.

it works :slight_smile:


#8

Thanks Aleks,

Last night I tried the update…

since there was a change in a configuration file – I thought it is ok to overwrite files…

I was asked two times by the server to overwrite files and two times I said “Y” - "yes2 … maybe an mistake… now I cant´t reach the server with my Gajim client: If I try to connect Gajim just says:

“The value ot the „to“ attribute provides by the initiating entry in the stream header does not correspond to a hostname that is hosted by the server.”

What can I do? Thanks for help.


#9

Please run yunohost service regen-conf metronome --force


#10

thanks Akeks

now the server is responding again …

but I can´t send images - same thing as before… any idea?


#11
~# nano /etc/metronome/metronome.cfg.lua
Component "upload.{{ main_domain }}" "http_upload"
        name = "{{ main_domain }} Sharing Service"

        http_file_size_limit = 6*1024*1024
        http_file_quota = 60*1024*1024
--Component "upload.{{ main_domain }}" "http_upload"
--        name = "{{ main_domain }} Sharing Service"
--
--        http_file_size_limit = 6*1024*1024
--        http_file_quota = 60*1024*1024
~# service metronome restart

:wink:


#12

Thanks for your help…

it still does not work

have a look at the screenshot


does this look right?

I´m running the server on a Sub.Domain - i set all the records for this Sub.Domain as discriped in the documentation… But do i have to set a CNAME Record for “upload.domain.tlh” as well ? - I just did it - but it has no effect.

Custom WebApp ist installed but I have also a problem to conect by SFTP to my server. Have a look at the logs here:

Could it be that this problem is related to the “no image” issue?


#13

I am trying to get http_upload_external to work but still didn’t get it to work.
Does someone knows the right settings for that. I have a upload.domain.tld conf with the share.php in it that correctly loads when visiting the domain. Added component http_upload_external with secret setted and url.
I don’t know what else to do. Can someone help?


#14

still have not solved the problem – Still can´t receive images when it they are sent form my server.

From Accounts on other servers images CAN be sent to me – so that´s why I think now it has nothing to do with the set records

What else could be the reason

SFTP works now


#15

do you have the host option enabled?
If no here is my config for it in /etc/metronome/metronome.cfg.lua

– HTTP server
Host “"
http_ports = {}
http_ports = { 5290 }
http_interfaces = { "
” }

Host “"
https_ports = {}
https_ports = { 5291 }
https_interfaces = { "
” }


#16

that how it look on my server - OK?

– HTTP server
http_ports = { 5290 }
http_interfaces = { “127.0.0.1”, “::1” }

–https_ports = { 5291 }
–https_interfaces = { “127.0.0.1”, “::1” }


#17

Try to change
http_interfaces = { “127.0.0.1”, “::1” }
In
http_interfaces = { “*” }
Just to be shure.
And also make shure port 5290 is not blocked


#18

Thanks

On the Router and on the YunoHost firewall i opened up port 5290 and
5291 but if I make a test e.g. by a site like this
https://www.geoips.com/de/tools/check-ports

it says the ports are closed or filtered - so the ports ARE blocked

what could be the reason, What can i do?


#19

There is also the firewall settings in the yunohost panel.


#20

Hi,

And this link to check ports
https://ports.yunohost.org/

ppr