Metronome envoie de fichier

Salut,

J’ai fais la migration de mon ynh 2 (jessie) vers ynh 3 (stretch) sur un serveur dédié ovh
ça s’est bien passé, a part quelques services qui ne redémarraient plus a cause de fichiers de config modifiés que j’ai régénéré avec yunohost service regen-conf metronome --force (par exemple)
j’ai également oublié de virer l’app letsencrypt avant de faire la migration, du coup je l’ai fais après, ça semble fonctionner

Suite a cela j’ai un souci avec metronome, je ne peux plus du tout envoyer de fichiers, avant la migration ça fonctionnait très bien :frowning: (testé avec conversation android et gajim arch linux)

je ne trouve pas vraiment de log pertinants, rien ds /var/log/metronome/metronome.err ou /var/log/metronome.log
le seul truc c’est gajim qui me dit Invalid filename or unallowed type

ma config /etc/metronome/metronome.cfg.lua semble ok
https://figureslibres.io/zerobin/?31f070e8960fce75#xdKWodu+y3prveUpdlNe9sDusi2vdNUSu7tJkymhWk4=

j’ai plus trop de piste là, ou en tout cas je vous demande conseille avant de commencer bidouiller les configs

$ yunohost tools diagnosis
host: Debian 9.6
kernel: 3.14.32-xxxx-grs-ipv6-64
packages: 
  yunohost: 
    repo: stable
    version: 3.3.3
  yunohost-admin: 
    repo: stable
    version: 3.3.1
  moulinette: 
    repo: stable
    version: 3.3.1
  ssowat: 
    repo: stable
    version: 3.3.2
backports: 
system: 
  disks: 
    md3: Mounted on /home, 1.8TiB (967.5GiB free)
    root: Mounted on /, 19.1GiB (10.7GiB free)
  memory: 
    ram: 15.6GiB (13.7GiB free)
    swap: 1022.0MiB (1006.2MiB free)
nginx: 
  - nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
  - nginx: configuration file /etc/nginx/nginx.conf test is successful
services: 
  avahi-daemon: running (enabled)
  dnsmasq: running (enabled)
  dovecot: running (enabled)
  fail2ban: running (enabled)
  glances: running (enabled)
  gogs: running (enabled)
  metronome: running (enabled)
  mysql: running (enabled)
  nginx: running (enabled)
  nslcd: running (enabled)
  php7.0-fpm: running (enabled)
  postfix: exited (enabled)
  redis-server: running (enabled)
  rspamd: running (enabled)
  seafile-server: running (enabled)
  slapd: running (enabled)
  ssh: running (enabled)
  ttrss: running (enabled)
  yunohost-api: running (enabled)
  yunohost-firewall: exited (enabled)
applications: 
  agendav: AgenDAV
  baikal: Baikal
  dokuwiki: Dokuwiki
  gogs: Gogs
  jappix: Jappix
  jirafeau: Jirafeau
  kanboard: Kanboard
  keeweb: Keeweb
  nextcloud: Nextcloud
  rainloop: Rainloop
  roundcube: Roundcube
  seafile: Seafile
  ttrss: Tiny Tiny RSS
  wallabag2: Wallabag
  zerobin: Zerobin
security: 
  CVE-2017-5754: 
    name: meltdown
    vulnerable: None

bon alors il se trouve que ma migration n’était pas finalisé, il manquait les deux dernieres étapes, postgresql et root passwd

ça c’est fait mais le probleme metronome demeure

par contre j’ai un nouveau message de gajim (en utilisant un png cette fois) qui me fait dire que ça viendrait bien de letsencrypt
le service a retourné un transport non sécurisé (http)

to be continued

[edit]
ces deux lignes étaient commentées dans ma conf metronome

https_ports = { 5291 }
https_interfaces = { "127.0.0.1", "::1" }

je les ai décommenté et maintenant j’ai une nouvelle erreur
[Errno 2] Nom ou service inconnu

Salut Bachy,

Je t’invite à commenter :

Component "upload.{{ main_domain }}" "http_upload"
        name = "{{ main_domain }} Sharing Service"

        http_file_size_limit = 6*1024*1024
        http_file_quota = 60*1024*1024

en :

--Component "upload.{{ main_domain }}" "http_upload"
--        name = "{{ main_domain }} Sharing Service"
--
--        http_file_size_limit = 6*1024*1024
--        http_file_quota = 60*1024*1024

Puis, à redémarrer Metronome.
Ça devrait fonctionner avec Conversations.
Les clients ne vont pas que HTTP_upload est fonctionnel, mais ça fonctionne.

Il faudrait tester la dernière version de Metronome, si c’est corrigé.
Ou remonter le bug upstream.
Perso, je préférerais me concentrer sur la migration vers Prosody.

2 Likes

super ça marche, merci @Moul !
est-ce que ces lignes ne vont pas manquer pour d’autres trucs ?

À ma connaissance, elles servent uniquement pour le téléversement de fichiers.
Donc, ça ne devrait pas poser de problème. Par contre, pour les évolutions de Metronome, il faudra en tenir compte.

Ok, I manage to send file through HTTP_upload with Metronome v3.11.5.

In the main configuration file, the upload component shouldn’t be commented.
The upload.domain.tld domain must exists, but its configuration file should be removed because of conflict.
I don’t know how could we manage to not create /etc/metronome/conf.d/upload.domain.tld.cfg.lua
The admin should also have this domain name and a DNS redirection on it.

Here is the ticket to follow the evolution upstream: https://github.com/YunoHost/issues/issues/1278

1 Like