[Flarum] A lightweight forum

New release !

  • Master branch status as of 2021-11-12: PR178
    • :arrow_heading_up: Upgrade to v1.1.1 :partying_face:
    • Fix the extensions dependencies upgrade and let Composer install the suitable versions
    • Fix a bug with app helper, you need to upgrade to YunoHost v4.3 beforehand

@Aristid @jrd10 let me know if that fixes your issues.

3 Likes

Good news : update worked flawlessly but bad news : i cannot reinstall any extension as this command for example :

/var/www/flarum# sudo -u flarum php7.3 composer.phar require clarkwinkelmann/flarum-ext-comicsans

gives this output :

Using version ^1.0 for clarkwinkelmann/flarum-ext-comicsans
./composer.json has been updated
Running composer update clarkwinkelmann/flarum-ext-comicsans
Loading composer repositories with package information
Updating dependencies
Lock file operations: 1 install, 0 updates, 0 removals
  - Locking clarkwinkelmann/flarum-ext-comicsans (1.0.0)

Installation failed, reverting ./composer.json and ./composer.lock to their original content.


  [ErrorException]
  file_put_contents(./composer.lock): failed to open stream: Permission denied


require [--dev] [--dry-run] [--prefer-source] [--prefer-dist] [--fixed] [--no-suggest] [--no-progress] [--no-update] [--no-install] [--no-scripts] [--update-no-dev] [-w|--update-with-dependencies] [-W|--update-with-all-dependencies] [--with-dependencies] [--with-all-dependencies] [--ignore-platform-req IGNORE-PLATFORM-REQ] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--apcu-autoloader-prefix APCU-AUTOLOADER-PREFIX] [--] [<packages>]...

Ah… what’s the output of ls -la /var/www/flarum ?

drwxr-x---   6 flarum www-data    4096 nov.  12 14:20 .
drwxr-xr-x+ 19 root   root        4096 nov.  12 14:06 ..
-rw-r-----   1 flarum www-data    1757 mai   27 10:54 CHANGELOG.md
drwxr-xr-x   3 root   root        4096 nov.  12 14:06 .composer
-rw-r-----   1 flarum www-data    1310 nov.  12 14:16 composer.json
-rw-r--r--   1 root   root      316087 nov.  12 14:07 composer.lock
-rwxr-xr-x   1 root   root     2216568 nov.  12 14:06 composer.phar
-rwxr-x---   1 flarum www-data     534 nov.  12 14:06 config.php
-rw-r-----   1 flarum www-data     361 mai   27 10:54 .editorconfig
-rw-r-----   1 flarum www-data     265 mai   27 10:54 extend.php
-rw-r-----   1 flarum www-data     634 mai   27 10:54 flarum
-rw-r-----   1 flarum www-data    1168 mai   27 10:54 LICENSE
-rw-r-----   1 flarum www-data    1764 mai   27 10:54 .nginx.conf
drwxr-x---   3 flarum www-data    4096 mai   27 10:54 public
-rw-r-----   1 flarum www-data    2665 mai   27 10:54 README.md
-rw-r-----   1 flarum www-data    1800 mai   27 10:54 site.php
drwxr-x---  10 flarum www-data    4096 mai   27 10:54 storage
drwxr-xr-x  43 root   root        4096 nov.  12 14:07 vendor

Oui, cela fonctionne bien, il s’est bien mis à jour

Flarum 1.1.1
PHP 7.3.31-2+0~20211022.89+debian10~1.gbp745ac7
MySQL 10.3.31-MariaDB-0+

J’ai testé, tout va bien :slight_smile:

Du coup, je vous passe le lien du dernier post :slight_smile:
https://tricassinux.org/forum/d/270-plan-daction-logiciels-libres-et-communs-numeriques

Et justement, comment peut-on faire “passer” cette image dans le lien (avec Flarum) ?

Dans le brouillon, il apparaît ce message :slight_smile:

Sorry, we were unable to generate a preview for this web page, because the following oEmbed / OpenGraph tags could not be found: description, image

Merci de cette mise à jour et de ton temps

Cordialement, jrd10

1 Like

Ah yeah sorry. We are missing a chown in the script. I will release a patch by tomorrow.

1 Like

New patch release !

  • Master branch status as of 2021-11-13: PR180
    • :bug: Fix file ownership
    • :bug: Make sure the version requirements for language extensions are loosen

@Aristid @jrd10 let me know if that fixes your issues. :wink: Please open a dedicated thread if not.

Nah. Adding extensions after installation just dont work. I’m upset haha. Seriously guys, please update the faq.

./composer.json has been updated
Running composer update vendor/extension --with-dependencies
Loading composer repositories with package information
Dependency “app/core” is also a root requirement. Package has not been listed as an update argument, so keeping locked at old version. Use --with-all-dependencies (-W) to include root dependencies.
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Root composer.json requires vendor/extension ^0.1.1 → satisfiable by tvendor/extension.
- vendor/extension requires vendor/extension ^0.1.0-beta.10 → found bla bla but it does not match your minimum-stability.

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.

Installation failed, reverting ./composer.json and ./composer.lock to their original content.

Fascinating. I am not sure how withholding information in your log can help me help you. Please open a dedicated App support thread and ping me there.

1 Like

Thanks… and sorry!

i think this is the 5th failed installation for the say. :face_holding_back_tears:
here’s the log.

as always, any help is more than welcome.

What do you mean?

It looks like it does not like your password. Can you try with only alphanumeric characters?
Does your current password have special characters?
It’s mainly an issue with Bash variables parsing. :confused:

sorry, just that it’s the 5th app i try to install today, but fail to.
missing context, my bad.

ok, it happened with another app as well, so i guess it is an issue related to yunohost then? or it might be that many apps don’t like that specific special character?
just trying to understand as a reference for future installations. eheh!

and you were right btw.
new password and it all worked. thanks. :heart:

Hello,
I have 2 questions
1- How not to loose every additional installed extensions each time I upgrade Flarum ?
2- What is the command line procedure on yunohost to install properly them ?

composer require vendor/extension

don’t work, I do

sudo su
app=flarum
cd /var/www/$app
sudo -u $app php7.4 composer.phar require vendor/extension

1- Hello, by keeping posted on Do not remove all extensions while upgrading · Issue #168 · YunoHost-Apps/flarum_ynh · GitHub, hopefully I’ll find how to fix that someday.

2- “Don’t work” is quite useless. Share the outputs of the command.

bash: composer : commande introuvable

That is not the command shown on the first post and neither the one at the end of your first message. :confused:

This should work.

To update flarum i follow the steps shown in the official flarum documentation and updates work great without losing any extension. YNH update system is a bit confused about that but i just ignore the flarum updates it wants to perform.

Thanks, I succeed upgrading with your solution.
any way to remove flarum upgrade proposition from webadmin to prevent mistakes (it stills in 1.6.2) ?

Nope