dpkg/APT (the system package managers) seems to be in a broken state

My YunoHost server

Hardware: Old laptop or computer at home
YunoHost version: 4.3.6.3
I have access to my server : Through the webadmin | direct access via keyboard / screen
Are you in a special context, or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

When attempting to install 2 different applications, bludit and Automad I received the error

You cannot do this right now because dpkg/APT (the system package managers) seems to be in a broken state… You can try to solve this issue by connecting through SSH and running sudo apt install --fix-broken and/or sudo dpkg --configure -a.

I tried to use these commands in terminal but received this error

https://paste.yunohost.org/ivonuwiqat.sql

Thank you in advance for any advice:)

I just attempted to update some system files via System Update and received a similar error

I’ve attempted the command

sudo dpkg --force-all --configure -a

Unfortunately, this did not fix the issue, the same error persists:(

It seems there is also an encryption key error when connecting to the repository as well:

https://paste.yunohost.org/yeciyumere.pas

Can you share the output of dpkg --audit ?

Hi, thanks for the response:)

Here’s the output of that command:

https://paste.yunohost.org/fafekodixu.vbs

Ah well, the issue regarding initramfs was in your initial post, sorry for not being attentive:

pigz: abort: write error on <stdout> (No space left on device)

Basically you probably ran out of space in /boot/ I’m guessing, which is a common issue when /boot/ is smaller than a few hundred MBs

Usually this can be solved by forcing to uninstall old kernels (usually this is easier when there’s more than 2~3 kernel versions intsalled)

Can you share the output of ls -l /boot/ ?

Thanks, np:) Here is the output of that command:

https://paste.yunohost.org/sojukacasu.hs

Alrighty I think we can check with uname -r which version of the kernel you’re currently using

Then assuming you’re not currently using 4.19.0-18, we can probably try :

dpkg --remove linux-image-4.19.0-18-generic

?

okay, that give this result:

sudo uname -r
4.19.0-20-amd64

I’m not sure if it makes more sense to put the result in here in this case vs pastebin but just let me know if you prefer it the other way

thanks

Yes here is fine as it’s just a couple line, pastebin/yunopaste is preferred for very long outputs

Let’s proceed with dpkg --remove linux-image-4.19.0-18-generic

On my side, /boot is often full (on my personal computer) and I solve it with sudo apt autoremove

That’s odd it said it wasn’t installed, weird:

sudo dpkg --remove linux-image-4.19.0-18-generic
dpkg: warning: ignoring request to remove linux-image-4.19.0-18-generic which isn’t installed

but it’s clearly there in the previous output

sudo ls -l /boot/
total 178120
-rw-r–r-- 1 root root 206267 Sep 29 2021 config-4.19.0-18-amd64
-rw-r–r-- 1 root root 206331 Mar 7 16:13 config-4.19.0-19-amd64
-rw-r–r-- 1 root root 206331 Mar 17 15:48 config-4.19.0-20-amd64
drwxr-xr-x 5 root root 1024 Mar 27 06:46 grub
-rw-r–r-- 1 root root 51858707 Oct 10 2021 initrd.img-4.19.0-18-amd64
-rw-r–r-- 1 root root 51861573 Mar 10 06:58 initrd.img-4.19.0-19-amd64
-rw-r–r-- 1 root root 51866968 Mar 27 06:45 initrd.img-4.19.0-20-amd64
drwx------ 2 root root 12288 Oct 5 2019 lost+found
-rw-r–r-- 1 root root 3423029 Sep 29 2021 System.map-4.19.0-18-amd64
-rw-r–r-- 1 root root 3425681 Mar 7 16:13 System.map-4.19.0-19-amd64
-rw-r–r-- 1 root root 3425737 Mar 17 15:48 System.map-4.19.0-20-amd64
-rw-r–r-- 1 root root 5291264 Sep 29 2021 vmlinuz-4.19.0-18-amd64
-rw-r–r-- 1 root root 5299456 Mar 7 16:13 vmlinuz-4.19.0-19-amd64
-rw-r–r-- 1 root root 5299456 Mar 17 15:48 vmlinuz-4.19.0-20-amd64

Hmyeah it’s maybe not that exact package name

Let’s check the output of dpkg --list | grep '4.19'

and dpkg --list | grep linux-image

the first didn’t return anything at all but the second returned this:

~$ sudo --list | grep ‘4.19’
admin@1146:~$ sudo dpkg --list | grep linux-image
rc linux-image-4.19.0-14-amd64 4.19.171-2 amd64 Linux 4.19 for 64-bit PCs (signed)
rc linux-image-4.19.0-16-amd64 4.19.181-1 amd64 Linux 4.19 for 64-bit PCs (signed)
rc linux-image-4.19.0-17-amd64 4.19.194-3 amd64 Linux 4.19 for 64-bit PCs (signed)
ii linux-image-4.19.0-18-amd64 4.19.208-1 amd64 Linux 4.19 for 64-bit PCs (signed)
ii linux-image-4.19.0-19-amd64 4.19.232-1 amd64 Linux 4.19 for 64-bit PCs (signed)
ii linux-image-4.19.0-20-amd64 4.19.235-1 amd64 Linux 4.19 for 64-bit PCs (signed)
rc linux-image-4.9.0-13-amd64 4.9.228-1 amd64 Linux 4.9 for 64-bit PCs
rc linux-image-4.9.0-14-amd64 4.9.246-2 amd64 Linux 4.9 for 64-bit PCs
ii linux-image-amd64 4.19+105+deb10u15 amd64 Linux for 64-bit PCs (meta-package)

Ah so the command is probably:

dpkg --remove linux-image-4.19.0-18-amd64

That worked, thanks:)

sudo dpkg --remove linux-image-4.19.0-18-amd64
(Reading database … 183514 files and directories currently installed.)
Removing linux-image-4.19.0-18-amd64 (4.19.208-1) …
/etc/kernel/postrm.d/initramfs-tools:
update-initramfs: Deleting /boot/initrd.img-4.19.0-18-amd64
/etc/kernel/postrm.d/zz-update-grub:
Generating grub configuration file …
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Found linux image: /boot/vmlinuz-4.19.0-20-amd64
Found initrd image: /boot/initrd.img-4.19.0-20-amd64
Found linux image: /boot/vmlinuz-4.19.0-19-amd64
Found initrd image: /boot/initrd.img-4.19.0-19-amd64
done

Should I be trying a system update now via the web panel?

Yup

1 Like

Unfortunately, same error


I’m going to run these commands again to give you the outputs

The first command returns this:

https://paste.yunohost.org/oyekoqikoy.sql