Bug de mise à jour DynDns?

,

Bonsoir ppr,

Faut-il faire les alias sur le domaine yunohost ou sur le domaine principal (mondomaine.ga chez moi)?
Pour l’instant, ce que j’ai fait n’a pas solutionné le problème chez moi.

Merci.

Bonsoir,

Ce n’est a priori pas une question de domaine.

Pour les alias il faut les ajouter, un par un, à l’utilisateur principal de ton instance YunoHost. C’est l’utilisateur que tu as créé en premier lors de l’installation de ton YunoHost et qui a les droits d’administration (installation et désinstallation des applications, ajout et suppression d’utilisateurs, …).

ppr

Merci ppr pour ta réponse.
J’ai effectivement ajouté les alias à mon premier utilisateur (celui dont je me sers) mais ça n’a visiblement pas résolu le problème chez moi.

Bonsoir,

Si tu n’as pas modifié manuellement la configuration DNS, as-tu essayé de passer cette commande :

sudo yunohost dyndns update

ou celle-ci pour forcer cette mise à jour :

sudo yunohost dyndns update --force

ppr

Ah, j’ai ajouté l’alias “admins” hier soir, je n’ai pas encore reçu d’emails aujourd’hui :slight_smile:
Je vais attendre quelques heures pour valider la solution, si ça ne bouge plus…

PS: ceci dit, je viens de tomber sur ce message et je ne sais pas si sa solution est meilleure (si celle de CE fil est bonne) ?

Sans vouloir te casser le moral, je n’ai rien fait et aujourd’hui je n’ai reçu aucun message d’erreur.

1 Like

J’ai également le même souci sur un Raspberry à la maison derrière une Freebox. Un domaine en nohost.me. Je reçois le message tous les jours. Le dernier date de ce midi (09/11/2022). Le sudo yunohost dyndns update --force a été lancé mais ça n’a absolument rien changé.

Je peux fournir plus de détails si nécessaire mais je ne sais pas où chercher.

Bonjour,

Hier il y a effectivement eu un épisode important de denie de service.
@Aleks pourra confirmer mais cela vient d’un problème d’infra côté serveur .ynh; nohost etc.
Aujourd’hui je suis revenu à un rythme d’un ou deux.

1 Like

bonne nouvelle
j’ai proposé également "en aval " de /dev/null cette solution.

Cela est une solution pour des serveurs en #IP fixe et sous domaine #yunohost
A chacun la possibilité de trouver le juste milieu, car faire un check toutes les 10minutes n’est pas fondamentale dans cette situation.

NB: ce changement du fichier cron agit de son coté sur le diag et donc de l’envoie d’un courriel.

J’ai aussi depuis hier une avalanche de message 14 et 11 aujourd’hui.
j’ai aussi rajouté admins et abuse qui n’était pas dans mes alias.
je croise les doigts.

Ah oui, aujourd’hui un nouvel email. Enfin, non, daté d’hier soir. Avec un:

Failed to resolve AAAA for blablabla.nohost.me

Le quadruple A, je l’ai reçu en tout 3 fois depuis octobre…

Bon, retour des emails. Déjà deux reçus aujourd’hui.

Idem pour moi. Ça me le fait depuis la mise à jour.

Hier soir, j’ai appliqué les commandes mentionnées dans le message cité ci-dessus, et pour l’instant, pas de nouveau mail. Je ferai un nouveau rapport ce soir ou demain matin :slight_smile:

bonjur,
pour ma part je viens de recevoir un message plus complet

=================================
DNS records (dnsrecords)

[WARNING] Some DNS records are missing or incorrect for domain xxx.ynh.fr (category xmpp)

  • This domain’s DNS configuration should automatically be managed by YunoHost. If that’s not the case, you can try to force an update using ‘yunohost dyndns update --force’.
  • According to the recommended DNS configuration, you should add a DNS record with the following info.
    Type: CNAME
    Name: vjud
    Value: xxx.ynh.fr.
  • According to the recommended DNS configuration, you should add a DNS record with the following info.
    Type: CNAME
    Name: xmpp-upload
    Value: xxx.ynh.fr.

[WARNING] Some DNS records are missing or incorrect for domain xxx.ynh.fr (category extra)

  • This domain’s DNS configuration should automatically be managed by YunoHost. If that’s not the case, you can try to force an update using ‘yunohost dyndns update --force’.
  • According to the recommended DNS configuration, you should add a DNS record with the following info.
    Type: A
    Name: *
    Value: ...
  • According to the recommended DNS configuration, you should add a DNS record with the following info.
    Type: CAA
    Name: @
    Value: 128 issue “letsencrypt.org

mais lorsque je vais sur la page web admin il me dit que tut est géré automatiquement et tout ok,
et en ssh , j’ai comme message lors d’un yunohost dyndns update --force no domain registered with dyndns ???

mon cloud fonctionne bien j’ai accès a tout et j’ai peur de finir par faire des bêtises.
j’ai juste desactive sur mon domain le xmpp puisque je n’utilise aucune messagerie instantanée

ps) je suis autodidacte et je ne parviens depuis des années a gérer tout cela grace a la somme de vos connaissances.

Mister

J’ai aussi reçu quelques-uns de ces emails au cours des 2 derniers mois, mais je pense que c’était dû à des manipulations chez les gestionnaires chez Yunohost.

Sinon, je confirme que je n’ai pas reçu de nouvel email depuis que j’ai effectué les commandes mentionnées précédemment. Pour l’instant. :smiley:

Bonsoir,

Si je comprends bien le message de ljf, il n’est pas possible d’utiliser ce stratagème pour un domaine ynh.

Pour ma part, j’en suis toujours au même point

1 Like

C’est une bonne nouvelle @GoustiFruit !
Mais en lisant le message que tu indiques, j’ai l’impression qu’il ne s’applique pas à mon cas car j’ai un domaine en ynh.fr
Je ne vais pas faire le rm -Rf indiqué…

1 Like

cela tourne au sketch, après avoir effectué une tonne de test divers et variés en suivant les conseils des un et des autres, je n’ai plus le message:
`Failed to resolve A for nom_du_domaine’

j’ai maintenant des messages:
[ERROR] Service yunomdns is failed :slightly_frowning_face:

  • You can try to restart the service, and if it doesn’t work, have a look at the service logs in the webadmin (from the command line, you can do this with ‘yunohost service restart yunomdns’ and ‘yunohost service log yunomdns’).

je ne sais plus par quel bout prendre le problème.

je semble avoir régler un problème en ajoutant des alias qui manquaient (admins et abuse) et j’ai déactivé xmpp que je n’utilise pas et j’ai enlevé le yunohost.local de mes domaines car je l’avais mis en faisant diverses manipulation mais sans comprendre pourquoi.

une de ces manipulation explique le problème ?

Tu as appliqué les commandes données ici ?

EDIT ljf: ATTENTION si vous faites les commandes indiquées dans cet autre topic, vous devez être sûr que vous n’avez plus besoin de votre domaine ynh.fr, noho.st ou nohost.me.

En corrigeant la deuxième par:

yunohost tools regen-conf yunohost --force

C’est ce qui a fonctionné pour moi avec un nom de domaine en nohost.me, ce qui devrait être pareil avec des noho.st et ynh.fr.