Yunohost update to fail due to Mailman

My YunoHost server

Hardware: VPS bought online
YunoHost version:
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? :

  • custom borg backup script
  • tweak of the OnlyOffice nginx conf (CSP and max upload size)

Apps: Nextcloud, OnlyOffice, Mailman, Custom Webapp

Description of my issue

I am trying to update my instance from a version.

I’ve tried using the web interface or through SSH and got the same result.

<3 <3 <3

Looks like this is because the Mailman update requires a user input.
I got the following when running apt upgrade manually.

Meh … but we run apt with every “noninteractive” flags as possible (DEBIANFRONTEND, confold, etc…) :

I don’t understand why mailman can’t just fallback to a reasonable default on its own -.-"

But anyway … looks like you have undelivered files in the mailman queue which is the root cause ?

Yes. I was indeed able to fix my issue however I wanted to post this message so other users having the issue could fix theirs.


Install the packages using the command line (through SSH) using apt upgrade and accept the printed message.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.