YunoHost DynDNS update returns "Could not update IP address to DynDNS"

:uk:/:us: Could not update IP address to DynDNS

My YunoHost server

Hardware: Old laptop
YunoHost version: (stable)
I have access to my server : Keyboard/screen, SSH and webadmin using private IP or webadmin manually using public IP.
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hello guys (sorry, my French is extremely limited, so I’ll stick to English),

I have been using Yunohost on this old laptop for about half a year without any problems at all, but recently I have trouble updating the DNS records on my domain.

Last time I was able to fix the issue by manually executing the yunohost dyndns update --force command (which ran without error), but this time the command returns an error that I can’t really understand.

I already tried rebooting both the server and the router and I checked to make sure that I have proper connectivity (ping on, no problems).

The logs that I uploaded using the webinterface are here:

And this is the output when I tried to do the update manually in the console (I took the liberty of redacting the IPs and domain names):

root@<name>:~# yunohost dyndns update -d <my-domain> --force
Info: Updated needed, going on...
Outgoing update query:
;; ->>HEADER<<- opcode: UPDATE, status: NOERROR, id:      0
;; flags:; ZONE: 0, PREREQ: 0, UPDATE: 0, ADDITIONAL: 0
;                     IN      SOA

<my-domain>     0       ANY     ANY
<my-domain>     0       ANY     ANY
_xmpp-client._tcp.<my-domain> 0 ANY ANY
_xmpp-server._tcp.<my-domain> 0 ANY ANY
muc.<my-domain> 0       ANY     ANY
pubsub.<my-domain> 0    ANY     ANY
vjud.<my-domain> 0      ANY     ANY
xmpp-upload.<my-domain> 0 ANY   ANY
<my-domain>     0       ANY     ANY
<my-domain>     0       ANY     ANY
mail._domainkey.<my-domain> 0 ANY ANY
_dmarc.<my-domain> 0    ANY     ANY
*.<my-domain>   0       ANY     ANY
*.<my-domain>   0       ANY     ANY
<my-domain>     0       ANY     ANY
<my-domain>     3600    IN      A       <new-IP>
<my-domain>     3600    IN      AAAA    <new-IPv6>
_xmpp-client._tcp.<my-domain> 3600 IN SRV 0 5 5222 <my-domain>
_xmpp-server._tcp.<my-domain> 3600 IN SRV 0 5 5269 <my-domain>
muc.<my-domain> 3600    IN      CNAME   <my-domain>
pubsub.<my-domain> 3600 IN      CNAME   <my-domain>
vjud.<my-domain> 3600   IN      CNAME   <my-domain>
xmpp-upload.<my-domain> 3600 IN CNAME   <my-domain>
<my-domain>     3600    IN      MX      10 <my-domain>
<my-domain>     3600    IN      TXT     "v=spf1 a mx -all"
mail._domainkey.<my-domain> 3600 IN TXT "v=DKIM1; h=sha256; k=rsa; p=<base64-string>"
_dmarc.<my-domain> 3600 IN      TXT     "v=DMARC1; p=none"
*.<my-domain>   3600    IN      A       <new-IP>
*.<my-domain>   3600    IN      AAAA    <new-IPv6>
<my-domain>     3600    IN      CAA     128 issue ""

; Communication with <some-IPv6>#53 failed: operation canceled
; Communication with <some-IPv4>#53 failed: operation canceled
Info: The operation 'Update the IP associated with your YunoHost subdomain '<my-domain>'' could not be completed. Please share the full log of this operation using the command 'yunohost log share 20220311-171634-dyndns_update-<my-domain>' to get help
Error: Could not update IP address to DynDNS

From the console output I figured it was a connectivity problem, but I could not find anything about that in the logs. Also pinging the dyndns-server did work and I have not changed the network setup since I set up the server (and dyndns worked before).

Others are having similar trouble: unreachable / Could not update IP address to DynDNS. Maybe the Yuno DynDNS service is down again.

Wouldn’t that mean that pinging dyndns should not work?

So just wait and see if it starts working again after some time?

YunoHost DNS server has been fixed. Let us know if your issue persists.


I just checked on my instance and everything seems to be in order again.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.