Yunohost admin page has gone blank, everything else working fine

My YunoHost server

Hardware: VPS
YunoHost version: 4.2
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no tweaking but back up was being
If yes, please explain:
I was using the webadmin interface to create a backup as finally the system was setup and running smoothly. After some time the backup threw a server timeout error.

Description of my issue

i ignored and refreshed the page so as to restart it, but since then the web admin interface is not loading.

To get help efficiently, please explain what you are trying to achieve, in which context, what you tried and provide detailed error messages and logs if you can.
I am trying to open the webadmin panel which is just showing a white page. it shows no error, no password authentication…nothing, just loads as a white blank page. My domain/yunohost/sso is working fine and i can access the app icons, the sso login page loads fine, my wordpress website is running okay and i can login using wp-admin. I did a yunohost service status check and everything is running, no errors. I stopped the usual suspect service like yunohost-api and even rebooted the server, but webadmin page hasnt come back. i can use the CLI to run yunohost commands as well and i am able to connect using SSH and SFTP.
I had recently changed the sshd config file to replace it with yunohost written file using cli, but even after re-instating the old version, it hasnt shown effect.


Now i am really stumped…i reinstated the snapshot on my server and rebuilt it from when everything was working fine and still no admin page. How is it possible!

Mokay, naively can you try to :

  • force refresh the browser cache (Ctrl Shift R on Firefox)
  • try in another browser or machine if you reproduce the issue ?
1 Like

Done both…can log in using ip address (saw another post from 2019 where the same issue but no resolution), but still stumped on the TLD not working

@Aleks thanks for taking out the time to answer this. I just saw your query and auto-reponded so came back to express gratitude.

@Aleks How to login after install? - #6 by merchmanager

this thread from 2019, a little similar, except that in my case i was able to log in mydomain/yunohost/admin which is now showing blank but ipaddress/yunohost/admin is loading the admin password page fine.

Hmmmokay interesting

If you’re comfortable with computer tinkering you could try to open the browser console (F12 on Firefox) and go to the Network tab, and check what happens when you reload the webadmin page that’s blank

1 Like

Hi @Aleks Thanks for pointing in the right direction, its working now. I use Cloudflare CDN, and was tinkering with the rocket JS and couple of other settings it promises to noobs like me to make their website faster. I used the chrome inspect to see what was happening. Essentially two things
(1) Rocket loader JS was being blocked by google chrome as being unsafe and cloudflare was trying to load everything from cache.
(2) To resolve, i went to cloudflare, shut off rocket loader, purged cache at cloudflare end and then came back and did the same thing again at browser and voila , it loaded.
However the inspector is still showing two nagging errors
(1) Permission header mismatch - not something that i have set, its default yunohost
(2) second is the redirect post login that yunohost does.

  1. Error with Permissions-Policy header: Unrecognized feature: ‘interest-cohort’.

  2. /yunohost/admin/#/login?redirect=%2F:1 Refused to execute inline script because it violates the following Content Security Policy directive: “script-src ‘self’ ‘unsafe-eval’”. Either the ‘unsafe-inline’ keyword, a hash ('sha256-XXXXXXReallyBigAlphanumericXXX, or a nonce (‘nonce-…’) is required to enable inline execution.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.