YunoHost 4.3 testing

Then I guess the bug ain’t related to zeroconf version …

Would be interesting to debug what’s the content of ips here, in case there’s anything special related to it:

 File "/usr/bin/yunomdns", line 139, in <module>
     zc = Zeroconf(interfaces=ips)

Are there iso files with which to test a fresh install or is it only a conversion script for existing installations? I tried looking at and find 0 byte sha256sum files for 4.2.7



I am annoyed with the diagnosis :

Certains enregistrements DNS sont manquants ou incorrects pour le domaine *** (catégorie xmpp)

When I try to sudo yunohost dyndns update --force :

admin@:~$ sudo yunohost dyndns update --force
Info: Updated needed, going on…
Outgoing update query:
;; ->>HEADER<<- opcode: UPDATE, status: NOERROR, id: 0
;; flags:; ZONE: 0, PREREQ: 0, UPDATE: 0, ADDITIONAL: 0

update failed: REFUSED
Info: The operation 'Update the IP associated with your YunoHost subdomain '’’ could not be completed. Please share the full log of this operation using the command ‘yunohost log share 20210926-092953-dyndns_update-***’ to get help
Error: Could not update IP address to DynDNS

Is there anything to do on my side ?

Edit :
yunohost service restart yunomdns won’t start.

  • Sep 26 11:40:27 systemd[1]: Started YunoHost mDNS service.
  • Sep 26 11:40:28 yunomdns[23240]: Traceback (most recent call last):
  • Sep 26 11:40:28 yunomdns[23240]: File “/usr/bin/yunomdns”, line 139, in
  • Sep 26 11:40:28 yunomdns[23240]: zc = Zeroconf(interfaces=ips)
  • Sep 26 11:40:28 yunomdns[23240]: File “/usr/lib/python3/dist-packages/zeroconf/”, line 410, in init
  • Sep 26 11:40:28 yunomdns[23240]: listen_socket, respond_sockets = create_sockets(interfaces, unicast, ip_version, apple_p2p=apple_p2p)
  • Sep 26 11:40:28 yunomdns[23240]: File “/usr/lib/python3/dist-packages/zeroconf/_utils/”, line 346, in create_sockets
  • Sep 26 11:40:28 yunomdns[23240]: normalized_interfaces = normalize_interface_choice(interfaces, ip_version)
  • Sep 26 11:40:28 yunomdns[23240]: File “/usr/lib/python3/dist-packages/zeroconf/_utils/”, line 158, in normalize_interface_choice
  • Sep 26 11:40:28 yunomdns[23240]: result += ip6_addresses_to_indexes(choice)
  • Sep 26 11:40:28 yunomdns[23240]: File “/usr/lib/python3/dist-packages/zeroconf/_utils/”, line 124, in ip6_addresses_to_indexes
  • Sep 26 11:40:28 yunomdns[23240]: result.append(ip6_to_address_and_index(adapters, iface))
  • Sep 26 11:40:28 yunomdns[23240]: File “/usr/lib/python3/dist-packages/zeroconf/_utils/”, line 91, in ip6_to_address_and_index
  • Sep 26 11:40:28 yunomdns[23240]: return (cast(Tuple[str, int, int], adapter_ip.ip), cast(int, adapter.index))
  • Sep 26 11:40:28 yunomdns[23240]: AttributeError: ‘Adapter’ object has no attribute ‘index’
  • Sep 26 11:40:28 systemd[1]: yunomdns.service: Main process exited, code=exited, status=1/FAILURE
  • Sep 26 11:40:28 systemd[1]: yunomdns.service: Failed with result ‘exit-code’.


Indeed I reproduce the issue with dyndns update, will investigate :stuck_out_tongue_winking_eye:


Problem identified in the first post of the thread, work ongoing over at Fix yunomdns by tituspijean · Pull Request #1335 · YunoHost/yunohost · GitHub :innocent:


Upgraded yunohost on my RPI3 and lost ability to log in as a user ( domain no longer found), and when trying to use the web interface with the IP address to log in as admin i get:

Not sure what to check via the CLI, but I did a ‘yunohost dyndns update’ which came back with some errors listed here:

You should probably force the browser cache to refresh with Ctrl Shift R


Thanks! that worked…

The 4.3.1 iteration was released moments ago !

Notable changes

  • [fix] diagnosis: new app diagnosis grep reporing comments as issues (#1333)
  • [enh] configpanel: Bind function for hotspot (core/79126809)
  • [enh] cli: rework/improve prompt mecanic (#1338, moulinette#303)
  • [fix] dyndns update broke because of buggy dns record names (core/da1b9089)
  • [enh] dns: general improvement for special-use TLD / ynh dyndns domains (core/17aafe6f)
  • [fix] yunomdns: various fixes/improvements (#1335)
  • [fix] certs: Adapt ready_for_ACME check to the new dnsrecord result format… (core/d75c1a61)
  • [fix] app install: choice questions broken, rendered as classic string (webadmin/64ae24fa)
  • [fix] dns push: simplify callback / fix ux message issue (webadmin#403)
  • [fix] app install: broken when missing ‘ask’ property (webadmin#402)
  • [fix] webadmin: User CSV import was broken (webadmin#401)
  • [mod] webadmin ui/ux: Make logs unselectable to force people clicking the damn share button >_> (webadmin#400)
  • [i18n] Translations updated for French, Galician, Indonesian, Russian, Turkish, Ukrainian

Thanks to all contributors <3 ! (axolotle, Eauchat, Éric Gaspar, Félix Piédallu, José M, Kayou, liimee, ljf, tituspijean, Tymofii-Lytvynenko)


Alors, je viens de faire cette petite mise à jour, et de retenter de pousser des DNS (ça tombe bien, mon IP avait changé cette nuit).
Résultat un peu meilleur, mais toujours imparfait :

2021-09-30 10:50:41,878: INFO - [#############.......] > create   A   / @
2021-09-30 10:50:42,923: ERROR - Échec de l'enregistrement create A/ : list indices must be integers or slices, not str
2021-09-30 10:50:42,928: INFO - [##############......] > create   A   / pad
2021-09-30 10:50:45,569: INFO - [##############......] > update AAAA  / *
2021-09-30 10:50:57,865: WARNING - Enregistrements DNS partiellement mis à jour : certains avertissements/erreurs ont été signalés.

De nouveau cette mystérieuse erreur : list indices must be integers or slices, not str

Will there be a testing image or can we request one?

No, there will not be a testing image. You can however install YunoHost with its standard methods, including with an image, then perform the command described in the first post to switch to testing.

1 Like

A post was split to a new topic: Blocked on Github

(Small bump, we’re still looking for testers / feedback, we’re planning a stable release during next week)


I’ve got my hands on a RaspberryPi, downloaded the YunoHost image from the main website, installed it. But when I try to update I get:

Unable to update the cache of APT (Debian's package manager). Here is a dump of the sources.list lines, which might help identify problematic lines:
sources.list:deb buster main contrib non-free rpi
sources.list.d/yunohost.list:deb buster stable testing
sources.list.d/raspi.list:deb buster main

And when I ssh and try to switch to testing:

E: Repository ' buster InRelease' changed its 'Suite' value from 'stable' to 'oldstable'

N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.

Any tip to switch to testing?

Does this Updates may fail because "Repository [...] changed its 'Suite' value from 'stable' to 'oldstable'" work for you?

sudo apt update worked, thanks!

I have tried using the new DNS tool for Dinahosting. Some records were pushed, some weren’t. This is the log of the action:

No token or special settings needed — regular username and password only. This is the documentation they provide: ¿Qué es dinaIP y cómo lo uso? - Ayuda | dinahosting

Also, tried setting the webadmin interface to Basque. Most of the dialogs still show in English (fallback lang).

Not sure if you find this useful. I have been busy and haven’t had the chance to try as many things as I would’ve liked.


Yes thank you very much :+1:

I think I saw an epic amount of updates for Basque but they may not be merged/released yet, but will surely be in the next iteration :+1:

1 Like

I don’t know what percentage was translated when I started, but it should be at 100% now. Still, a lot more needs to be done to standardise all strings. I also have some questions regarding translation, but I guess this is not the right place to ask them.

As for the DNS auto configure tool, I’d like to try it with Dreamhost as well, but for some reason my DNS records don’t propagate. They tell me to wait, but I don’t know how many days they expect me to just sit and wait. That’s why I usually use Cloudflare.

However, as far as I know, if the registrar is Dreamhost and DNS records are managed by Cloudflare, there is no way to use the autoconfigure tool.

1 Like