YunoHost 4.3 testing

Thanks! that worked…

The 4.3.1 iteration was released moments ago !

Notable changes

  • [fix] diagnosis: new app diagnosis grep reporing comments as issues (#1333)
  • [enh] configpanel: Bind function for hotspot (core/79126809)
  • [enh] cli: rework/improve prompt mecanic (#1338, moulinette#303)
  • [fix] dyndns update broke because of buggy dns record names (core/da1b9089)
  • [enh] dns: general improvement for special-use TLD / ynh dyndns domains (core/17aafe6f)
  • [fix] yunomdns: various fixes/improvements (#1335)
  • [fix] certs: Adapt ready_for_ACME check to the new dnsrecord result format… (core/d75c1a61)
  • [fix] app install: choice questions broken, rendered as classic string (webadmin/64ae24fa)
  • [fix] dns push: simplify callback / fix ux message issue (webadmin#403)
  • [fix] app install: broken when missing ‘ask’ property (webadmin#402)
  • [fix] webadmin: User CSV import was broken (webadmin#401)
  • [mod] webadmin ui/ux: Make logs unselectable to force people clicking the damn share button >_> (webadmin#400)
  • [i18n] Translations updated for French, Galician, Indonesian, Russian, Turkish, Ukrainian

Thanks to all contributors <3 ! (axolotle, Eauchat, Éric Gaspar, Félix Piédallu, José M, Kayou, liimee, ljf, tituspijean, Tymofii-Lytvynenko)

9 Likes

Alors, je viens de faire cette petite mise à jour, et de retenter de pousser des DNS (ça tombe bien, mon IP avait changé cette nuit).
Résultat un peu meilleur, mais toujours imparfait :

(...)
2021-09-30 10:50:41,878: INFO - [#############.......] > create   A   / @
2021-09-30 10:50:42,923: ERROR - Échec de l'enregistrement create A/informatiquelibre.fr : list indices must be integers or slices, not str
2021-09-30 10:50:42,928: INFO - [##############......] > create   A   / pad
2021-09-30 10:50:45,569: INFO - [##############......] > update AAAA  / *
(...)
2021-09-30 10:50:57,865: WARNING - Enregistrements DNS partiellement mis à jour : certains avertissements/erreurs ont été signalés.

De nouveau cette mystérieuse erreur : list indices must be integers or slices, not str

Will there be a testing image or can we request one?

No, there will not be a testing image. You can however install YunoHost with its standard methods, including with an image, then perform the command described in the first post to switch to testing.

1 Like

A post was split to a new topic: Blocked on Github

(Small bump, we’re still looking for testers / feedback, we’re planning a stable release during next week)

2 Likes

I’ve got my hands on a RaspberryPi, downloaded the YunoHost image from the main website, installed it. But when I try to update I get:

Unable to update the cache of APT (Debian's package manager). Here is a dump of the sources.list lines, which might help identify problematic lines:
sources.list:deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
sources.list.d/yunohost.list:deb http://forge.yunohost.org/debian/ buster stable testing
sources.list.d/raspi.list:deb http://archive.raspberrypi.org/debian/ buster main

And when I ssh and try to switch to testing:

E: Repository 'http://raspbian.raspberrypi.org/raspbian buster InRelease' changed its 'Suite' value from 'stable' to 'oldstable'

N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.

Any tip to switch to testing?

Does this Updates may fail because "Repository [...] changed its 'Suite' value from 'stable' to 'oldstable'" work for you?

sudo apt update worked, thanks!

I have tried using the new DNS tool for Dinahosting. Some records were pushed, some weren’t. This is the log of the action: https://paste.yunohost.org/raw/qenokiseru

No token or special settings needed — regular username and password only. This is the documentation they provide: ¿Qué es dinaIP y cómo lo uso? - Ayuda | dinahosting

Also, tried setting the webadmin interface to Basque. Most of the dialogs still show in English (fallback lang).

Not sure if you find this useful. I have been busy and haven’t had the chance to try as many things as I would’ve liked.

2 Likes

Yes thank you very much :+1:

I think I saw an epic amount of updates for Basque but they may not be merged/released yet, but will surely be in the next iteration :+1:

1 Like

I don’t know what percentage was translated when I started, but it should be at 100% now. Still, a lot more needs to be done to standardise all strings. I also have some questions regarding translation, but I guess this is not the right place to ask them.

As for the DNS auto configure tool, I’d like to try it with Dreamhost as well, but for some reason my DNS records don’t propagate. They tell me to wait, but I don’t know how many days they expect me to just sit and wait. That’s why I usually use Cloudflare.

However, as far as I know, if the registrar is Dreamhost and DNS records are managed by Cloudflare, there is no way to use the autoconfigure tool.

1 Like

Ah indeed we didn’t really think about this … How did you configure the relation between Dreamhost and Cloudflare ? Did you define some sort of special record like NS or SOA ? (Maybe Cloudflare has a tutorial somewhere describing this ?)

My skills are not that broad. I just change the NameServers (on Dreamhost control panel) to those provided by Cloudflare when I signed up: derek.ns.cloudflare.com… and add all DNS records on Cloudflare.

I have tried two more registrars:

  • Freenom
  • Namecheap

Both are managed by Cloudflare.
They are set up the very same way as my Dreamhost domain (see above).

In these two cases (Freenom and Namecheap), YunoHost thinks that Cloudflare is the registrar —this didn’t happen with Dreamhost—, so I think it’s a good thing.

  • domain_config_auth_username: your email
  • Authentication token: global API key
  • domain_config_zone_id: zone ID (click on your domain and scroll down to find this number on the Overview tab)

I only tried with an A record but it worked. If you want to check the log: https://paste.yunohost.org/raw/xuxafuqugo

Ah indeed we may need to tweak a few things here … : Lexicon explains that there are two (three?) ways to configure stuff, either using username+token, or token alone (or token + zone ids)

But Yunohost asks for all three which is incorrect … :

I just updated my post :wink:

I think asking or using the global API key is a bit too much. But I’m glad it works!

1 Like

Haha indeed, cool to know that you were able to get it working ! Still probably too confusing / technical compared to Yunohost spirit … but we could probably just add some guidance in the doc - we already did such thing for OVH and Gandi to help people obtaining their API credentials which is usually not straightforward even for tech-savvy people

1 Like

A couple of days ago I said that I couldn’t use YunoHost 4.3’s auto DNS tool to push/update records of a Dreamhost domain that was managed by Cloudflare. This isn’t true.

I have tried once more today and it’s working the same way Freenom and Namecheap domains do — if records are managed by Cloudflare, YunoHost’s tool does the job.

1 Like