Yunohost 4.1 install usb is not shown as bootable

Hardware: Dell inspiron 5480
YunoHost version: 4.1*

Hello, i have used yunohost on my rpi3 before and thought it might be a good idea to upgrade to a laptop, so i tried booting my laptop with the "64-bit Regular Computer " version of the iso but sadly i can’t see it in the boot menu.

I tried using 3 different usb’s and i tried both windows and linux to try and burn the image. I used etcher, imagewriter, burnimage,dd… But none of them works. Also i tried to boot it from two different computers but the same result :frowning:

What do you think i can do to boot the installer?
(i know about the debian way of installing yunohost but i really wouldn’t prefer that unless there’s no other option)


Have you tried to boot the iso in Virtualbox in order to be sure it don’t boot.
I’ll test it when I’ll back home.

I don’t know if it can solve the problem but maybe you can try to use this tool Raspberry Pi OS – Raspberry Pi


Don’t have vbox installed rn so cant try that but tried rpi-imager and it didnt work as well

On my side 64 bits iso boot correctly in a VirtualBox and i’ve launch installation (not the post-install).
With the 32 bits iso, it boots in a VirtualBox but i have not launch the installation.

I’ve you tried to erase completely your usb stick before format it :

It’s in french but it could helps you :


I have the same problem with YunoHost 4.1
I tried to boot on two laptop on Mac Intel and one Toshiba…
I tried few software and fews USB Stick.

And it is not working.
I tried other OS and it works properly I get this problem only with YunoHost.

I been able to install YunoHost using the tool VENTOY.
It not worked on my mac intel but it did worked on my old Toshiba.

Same here with YunoHost 4.1.8 and a Sandisk USB on a Thinkpad T480s

Yes, I am having the same issue. Initially, I installed on an Raspberry Pi 4 and then when I realised the sheer variety of apps and tools available I thought I would be better to use something more powerful.

I have an older Intel-era Mac which has Linux running. However the boot image will not appear for Yunohost. Is there a work around?

Hi all, welcome to the forums :slight_smile:

Most unfortunate that the ready made image does not boot, but yes, there is a workaround:

  • start with a plain Debian installation (note: Debian 10 / Buster, for the time being)
  • run the Yunohost installation script from the installation instructions from the page for remote installation. It will take only a few minutes, with two questions/remarks about Yunohost improving security.

After the Yunohost installation script, you are asked to run yunohost tools postinstall, which is where the ready made image would have let you start.

Good luck!


I installed Buster and then Yunohost. All seem OK.
If I understand well, Debian should not have any firewall, because yunohost will manage that.
But what about networking, should we manage this from the os?

Thanks! I may try this out. Although… I’m up and running on a RPi4 and impressed with the performance.

Yunohost is so much easier and more flexible than all the alternatives!


Yunohost will provide an interface for Debian’s ‘standard’ firewall; Yunohost uses the network that Debian provides. For getting started, the easiest is to leave Debian to defaults (DHCP, if you didn’t change anything during install).

To get a fixed private IPv4 (ie, always, for example), use your router’s settings to always provide the same IP to that computer.
You’ll need to explore your router a bit, because that is also where you enable portforwardings/NAT/firewall/DMZ (depending on what it is called in the router’s firmware) for your Yunohost.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.