[solved] Can't create bootable USB media for YUNOHOST installation


System: Old PC, ver: 11.0.9.

Description of my issue:

  • Yunohost installation .iso didn’t create a bootable USB disk.
  • Tried multiple USB drives, all known to be fine for installing other distros from.
  • Tried using dd command and using the “Etcher” application.
  • Similar sounding issues cropped up in this post and this post, but had gone unsolved. The threads were closed so I couldn’t provide my solution.

Solution [linux]:

  • use gparted to remove all the USB drive partitions
  • make a FAT32 partition that takes up the whole drive
  • safely remove the USB drive, wait, then re-insert it
  • use unetbootin to write the .iso to the USB drive
  • copy all the files on the drive onto another USB drive formatted with NTFS
  • safely remove both USB drives
  • use the USB drive made by unetbootin to install yunohost on the hardware of your choice
  • when the error message comes up that it can’t find the installation files (this is a known snag), insert the second USB on which you have a copy of all the files, and allow the installation to proceed
  • carry on being awesome.


I have NO idea why this worked, but it did, and clearly it’s a problem that had stumped others. I wanted to record it here so folks web-searching don’t fall at the first hurdle like I almost did, and like I suspect those other folks did. Peace!

edited to add: thank you to all the devs, mods, documenters, maintainers, and myriad others that keep all this spinning, and to whoever put workadventure on the application wishlist :smiley:


Hi splunko,

Welcome to Yunohost!

Me neither, I had no idea things could get so complicated before starting!

Thank you for your write-up and have lots of fun with your new installation :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.