YunoHost 3.8 testing / Call for feedback

I use the script on a 3.7.1 yunohost on my local desktop with any port redirection.
The script abort after the question :

# curl https://install.yunohost.org/switchToTesting | bash

   % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   459  100   459    0     0   2555      0 --:--:-- --:--:-- --:--:--  2550
----
Patching sources.list to enable testing repository...
----
----
Running 'apt-get update'
----
Hit:1 http://forge.yunohost.org/debian stretch InRelease
Ign:2 http://ftp.debian.org/debian stretch InRelease
Hit:3 http://ftp.debian.org/debian stretch-updates InRelease
Hit:4 http://ftp.debian.org/debian stretch Release 
Hit:6 http://security.debian.org stretch/updates InRelease
Reading package lists... Done         
----
Running 'apt-get dist-upgrade'
----
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  etckeeper fonts-lyx glances hddtemp iproute javascript-common libblas-common libblas3 libgfortran3 libjs-angularjs libjs-jquery libjs-jquery-ui libjs-lodash
  liblapack3 liblcms2-2 libsensors4 libwebpdemux2 libwebpmux2 lm-sensors python-gnupg python-matplotlib-data python3-bottle python3-crypto python3-cycler
  python3-dateutil python3-docker python3-matplotlib python3-netifaces python3-numpy python3-pil python3-psutil python3-pyasn1 python3-pyparsing python3-pysnmp4
  python3-pystache python3-tz python3-websocket
Use 'sudo apt autoremove' to remove them.
The following packages will be upgraded:
  metronome moulinette ssowat yunohost yunohost-admin
5 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 10.6 MB of archives.
After this operation, 15.4 kB of additional disk space will be used.
Do you want to continue? [Y/n] Abort.

I run the upgrade manually :

 apt-get update
 apt-get dist-upgrade

And the script works :

 Info: Running migration 0013_futureproof_apps_catalog_system…
Success! App catalog system initialized!
Info: Updating application catalog…
Success! The application catalog has been updated!
Success! Migration 0013_futureproof_apps_catalog_system completed
Info: Running migration 0014_remove_app_status_json…
Success! Migration 0014_remove_app_status_json completed
Re-diagnosing server health...
Error: Found 1 significant issue(s) related to Base system!
Warning: Found 2 item(s) that could be improved for Internet connectivity.
Error: Found 2 significant issue(s) (and 2 warning(s)) related to DNS records!
Error: Found 7 significant issue(s) related to Ports exposure!
Error: Found 1 significant issue(s) related to Web!
Error: Found 5 significant issue(s) related to Email!
Success! Everything looks good for Services status check!
Success! Everything looks good for System resources!
Success! Everything looks good for System configurations!
Success! Everything looks good for Security checks!
Warning: To see the issues found, you can go to the Diagnosis section of the webadmin, or run 'yunohost diagnosis show --issues' from the command-line.

My test :

  • My yunohost 3.8.1.1 seems to work. I can create user, and previous app (zerobin) working.
  • The diagnostic alert me on errors those are real (Ports not redirect)
  • I find my usual apps in the app manager and can install it and they work : dokuwiki, gitea, lstu…
1 Like

In my case, Cron sends diagnostic reports twice a day. It seems a lot…

@ericg you can click on “ignore” in the diagnostic panel, if some warnings/errors are not relevant.

1 Like

First thanks for al the work on yunohost it work really great for me.
Migration run smoothly.
Concerning the new diagnosis tool, It seems very interesting.

However, I tried the new xmpp http upload fonctionnality and it doesn’t work for me.
I first had an ssl error fixed by regenerating my letsencrypt certificate but now I can’t upload image with Dino, I get

“Error getting upload/download url (Error Iq)”

and when I use an other client like gajim, it upload but the download file is the nginx 404 not found page.

Thanks in advance.

@oiseauroch hmokay, looks like a bug indeed …

Can you try to run

tail -n 50 /var/log/nginx/xmpp-upload.yourdomain.tld-error.log

(replacing yourdomain.tld with … your domain)

@Aleks you can find my logs here : https://paste.yunohost.org/eruruxugod.vbs

@oiseauroch :

hmmmokay … not sure how we would have missed this earlier but can you try to :

  • open the corresponding nginx conf file with nano :

nano /etc/nginx/conf.d/yourdomain.tld.conf

  • at the bottom, find the lines :
    location /upload/ {
        alias /var/xmpp-upload/yourdomain.tld/upload;
  • add a / after upload :
        alias /var/xmpp-upload/yourdomain.tld/upload/;
  • save with Ctrl+X, Enter, then systemctl reload nginx ?
  • check if that works ?
  • in any case, please make sure to undo the change after doing this, otherwise the file will get flagged as manually modified … You can make sure of this by looking at yunohost tools regen-conf nginx --dry-run (the file name should not appear in the output)

It works thanks a lot !

Hardware: Olinuxino lime2 at home
YunoHost version: 3.8.x
I have access to my server : now yes (SSH and webadmin)
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes
If yes, please explain: it’s an intercube with a HDD via sata port mounted on /home. The most part of the system is on sd card. The yunohost has been installed in 2.0 and updated until now into 3.8 .
Apps : vpnclient, my_webapp, nextcloud, several wordpress, 2x borg, several borgserver, rainloop, roundcube, opensondage, glowing bear and dokuwiki.

I don’t know if it’s related to the 3.8, but i experience some freeze (i suppose). The server lost ping. I need to restart it and no log between the freeze and the restart.

If some one in 3.8 have same kind of issue say it. For now i suppose it’s an hardware issue, or other things unrelated. If it arrives again i will try to plug a screen on it to see if i am able to see an error displayed.

About the scope of 3.8, i notice an error on my configuration around IPv6.

@oiseauroch : thanks for the test ! I pushed the fix upstream: https://github.com/YunoHost/yunohost/commit/194a0bb187902e90572fcde1d51afc15f542d750

Will be there in next iteration

2 Likes

Hi there,
I just installed the 3.8.1 on an ARM VPS and everything seems to work so far.

Apps : my_webapp, nextcloud, lufi, redirect.

I had a look at the brand new diagnosis tool and it looks great.
A tiny UX suggestion, when reruning the tool after fixing something for instance, the collapsed parts should stay collapsed, rather than having to scroll all the way to the next part.
I do have an issue with lufi in the Services status check. It says it exited, but it seems to work anyway. I tried running the suggested commands nonetheless, it still works but the issue is still there.

I also have multiple problem for the DNS part. It tells me that subdomains are type A with name @, and that the current value is [u'mondomaine dot fr.', u'111.222.333.44'] and the expected value is 111.222.333.44, but in my DNS records subdomains are type CNAME with name mondomaine dot fr.
Note that applications are installed on those subdomains at /, and the Yunohost default domain is not the root, it’s admin dot mondomaine dot fr.
Since I began all those self-hosting and registrar stuff last week, my knowledge is very limited so I can’t say if it’s a problem with the diagnosis tool or with me.

Also, I have a security issue regarding meltdown vulnerability. I already did apt upgrade and dist-upgrade and rebooted my server but the issue stays.

Apart from that, all seems great !
Thanks to all involved in this wonderful system.
Cheers,
Guillaume

Note : my domain and IP have been modified, and the . in adresses have been changed to “dot” because Discourse tell me I can’t put link in my post.

2 Likes

It’s definitely an issue with the diagnosis tool not handling CNAME correctly at the moment, as already reported by somebody in the previous feedbacks. Will fix it for the next iteration :wink:

Hmyea I was thinking eventually somebody would end up encountering this … It’s not easy to fetch accurate results / easy to interpret from systemd…

If you have some time, I’m curious to know if ‘systemctl show lufi | grep ConsistsOf’ returns something ?

Hmmm yea dunno what you can do about this … I would try to poke your VPS provider support to see if that’s an issue on their side or not …

I agree with you about the scrolling UX when refreshing the diagnosis page :+1:

Thank you for your feedback!

No, it does not return anything.

Thanks for your feedback on my feedback :blush:

1 Like

Bonjour,

J’ai sauté le pas sur ma Raspberry Pi 3B : passage de YunoHost 3.7.1.1 à 3.8.1.1.

Les applications Custom Webapp, phpMyAdmin et Rainloop qui étaient installées semblent fonctionner normalement (j’ai pas encore tout essayer).

J’ai bien 2 fois par jours un mail avec les warnings sur la configuration.
Certains sont normaux car je n’ai “NATé” que certains ports sur ma box, et d’autres comme le blacklistage de l’IP ne sont pas vrai partout mais j’ai cru comprendre qu’il y avait des modifications en cours sur le code.

Si je m’aperçois de quelque chose je repasserai par là :wink:

Merci à tous pour tous les efforts faits afin d’avancer sur le portage de YunoHost pour Buster :heart:

ppr

2 Likes

Hi,

When I installed pi-hole, it modified files like /etc/dnsmasq.conf and /etc/resolv.conf. Then it adds a warning in the diagnosis tools.

Besides that, everything works well so far ! :ok_hand:

1 Like

Here I go !

My YunoHost server :
Hardware: remote server, running Debian 9.12
YunoHost version: previously 3.7.1
I have access to my server : yes, ssh and webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Had the same issues than TitusPiJean at the install. Then I got mostly some “Success !” messages, and I understand the errors and warning are listed in the diagnosis tool, as they should :slight_smile:

Overall I really enjoy the diagnosis tool, makes me want to spend some time just tidying up my server. The warnings for DNS are sometimes a false alert, but i think most of it has been reported here.
Same for the application catalogue, it has a really nice outlook, but a search bar available in the “categories” view would be nice.

Now for the updates, I encountered the same issue listed before : updating all the applications (in my case, Netdata and Pixelfed) at once fails. Doing them one by one, Netdata succeeded and Pixelfed failed. I’m not entirely sure this relates to the beta version of Yunohost though, i would be curious to hear from other users.

1 Like

Thanks to everybody’s feedback !

Here’s another iteration, version 3.8.2, that should fix a few issues reported, and other things :

Major changes (with respect to 3.8.1)

Diagnosis system

  • [fix] Some DNS queries triggered false negatives about CNAME/A record or email blacklisting (YunoHost#943)
  • [enh] Add a check about domain expiration (YunoHost#944)
  • [enh] Dirty hack to automatically find custom SSH port and diagnose it instead of 22 (YunoHost/b78d722)
  • [enh] Add a tip / explanation when IPv6 ain’t working / available (YunoHost/426d938)
  • [fix] Small false-negative about not having IPv6 when it’s actually working (YunoHost/822c731)
  • [enh] Webadmin: Save/restore collapse states when refreshing diagnosis view (YunoHost-admin/a110e56)
  • [enh] Webadmin: Add an explanation text on top of the diagnosis view (YunoHost-admin/ccefdd6)

Webadmin

Helpers

  • [fix] When setting up a new db, corresponding user should be declared as owner (YunoHost#813)
  • [enh] Add dynamic variables to systemd helper (YunoHost#937)
  • [enh] Clean helpers (YunoHost#947)
  • [fix] getopts behaved in weird way when fed empty parameters (YunoHost#948)
  • [fix] Use ynh_port_available in ynh_find_port (YunoHost#957)

Others

  • [enh] Setup all XMPP components for each “parent” domains (YunoHost#916)
  • [fix] Previous change in Postfix ciphers broke TLS (YunoHost#949)
  • [fix] Update ACME snippet detection following previous change (YunoHost#950)
  • [fix] Trying to install apps with unpatchable legacy helpers was breaking stuff (YunoHost#954)
  • [fix] Patch usage of old ‘yunohost tools diagnosis’ (YunoHost#954)
  • [enh] Misc optimizations to speed up regen-conf and other things (YunoHost#958)
  • [enh] When sharing logs, also anonymize folder name containing %2e instead of dot (YunoHost/b392efd)
  • [enh] Keep track of yunohost version a backup was made from (YunoHost/54cc684)
  • [fix] Re-add ‘app fetchlist’, ‘app list -i’, ‘app list’ filter for backward compatibility… (YunoHost/69938c3)
  • [i18n] Improve translations for Catalan, German, French, Esperanto, Spanish, Greek, Nepali, Occitan, Polish

Thanks to all contributors :heart: ! (Bram, C. Wehrli, Kay0u, Maniack C., Quentí, Simon, Zeik0s, amirale qt, ljf, pitchum, tituspijean, xaloc33, Éric G.)

6 Likes

HI @Aleks
thanks for the upgrade
I just tested the diagnostic , I still have 7 false negative on blacklisting on email
just let me know
pascal

Hi,
DNS checks in diagnosis tool are fixed, great.
Lufi is still flagged as exited.
The page stays on the item you were looking after a rerun, that’s good.
Cheers!

Hello,
Same here as @guilg with lufi.

Still false negatives on IP blacklisted (but this isn’t mention on the version changes)

In Configurations système, I have a

Le fichier de configuration /etc/ssh/sshd_config semble avoir été modifié manuellement.

I do not remember having modified this file

Otherwise, good work!