YunoHost 3.8 testing / Call for feedback

hi @Aleks i have a pb
i can t access anymore the applications catalog within the web interface

i got this error message

can someone help me here please?

What does

sudo ls /etc/yunohost/apps

and

sudo ls /etc/yunohost/apps/*/manifest*

returns ?

hi here
sudo ls /etc/yunohost/apps
archivist grafana monit netdata nextcloud phpmyadmin piwigo roundcube

`sudo ls /etc/yunohost/apps//manifest
/etc/yunohost/apps/archivist/manifest.json
/etc/yunohost/apps/grafana/manifest.json
/etc/yunohost/apps/netdata/manifest.json
/etc/yunohost/apps/nextcloud/manifest.json
/etc/yunohost/apps/phpmyadmin/manifest.json
/etc/yunohost/apps/piwigo/manifest.json
/etc/yunohost/apps/roundcube/manifest.json

sudo ls /etc/yunohost/apps
archivist grafana monit netdata nextcloud phpmyadmin piwigo roundcube
seems monit did not removed properly as few stuff remain here?

@Aleks
fixed it by removing the monit folder and files in it
now i can access again the app part
please advice NOT to install Monit as the installation failed and create this pb
again thank you

1 Like

So here we are with an important iteration : 3.8.1 ! (still in testing). Note that :

  • there was some breaking changes regarding the remote diagnosis server on our infra, used by the diagnosis client on Yunohost instances, so it’s expected that the diagnosis results will be half broken as long as you stay in 3.8.0
  • there has been many messages rework and new messages, which are therefore not yet propagated to the translations. So expect to see funky stuff if you’re in French or any language other than English for now. Consider forcing your browser to English if you wanna see the Diagnosis in its full glory :stuck_out_tongue_winking_eye:.

Major changes (with respect to 3.8.0)

Diagnosis system

  • [enh] Many improvements for diagnosis (see PR 923 for a more detailed changelog…) (YunoHost#923, YunoHost#921, YunoHost#940)
  • Many small cosmetic and mechanics improvements for the Diagnosis view in the webadmin

App packaging helpers (PHP, apt)

Others

  • Display ‘All apps’ button at the top in app category selector (YunoHost-admin#291)
  • Add a ‘Restart’ button for services
  • Drop ‘Security feed’ and ‘Download self-CA auth cert’ features from the Tools section
  • Move ‘Share on Yunopaste’ button to make it more obvious to users (YunoHost-admin/dd2570e)
  • [fix] custom_portal and custom_overlay redirect (YunoHost#925)
  • [enh] Improve systemd settings for slapd to prevent it from getting killed / staying dead (YunoHost#933)
  • [i18n] Spelling and typo corrections (YunoHost#931)
  • [i18n] Improve translations for French, German, Catalan, Turkish

Thanks to all contributors :heart: ! (Kay0u, Maniack Crudelis, ljf, Eric G., xaloc33, Yasin S. T., Zeik0s)

2 Likes

(I think I found a small regression where, after a fresh login on the webadmin, pacman hangs forever … Will fix it tomorrow, but in the meantime you can just F5 the webadmin and the pacman will stop hanging)

1 Like

@tituspijean: thanks for the extensive feedback earlier btw … I was mostly focused on iterating on the Diagnosis system so didn’t look at all the things you mentionned. Many bugs you found should be fixed in 3.8.1 though maybe not all of them. Will have a closer look for the next iteration :wink:

1 Like

:heart:

1 Like

Hello,
I have update my yunohost instance (NUC computer) with 3.8.0 then with 3.8.1. For both version I have the following problem with admin https interface. When I connect I got this message:

# Error: 404 Not Found
Sorry, the requested URL ‘http://domain.tld/diagnosis?locale=fr
caused an error:
Not found: ‘/diagnosis’

“Mettre à jour le système” and “Diagnostic” --> when I click nothing is done
“Applications/Installer” -->
Could not find the app ‘catalog’ in the list of installed apps: *
** ampache

** hextris*
*

“Services” --> I am unable to select a service to start/stop

However all the application and services seems to works well. Command line are also working.

Thanks,

Eeeeeh wokay … Can you try to force-refresh the cache of the browser with Ctrl+Shift+R on the page ?

If that doesnt work, can you make sure with yunohost --version that yunohost-admin also is in 3.8.1 ?

On the Diagnostic / Email section I get my IP adress blacklisted in 5 services. After a quick check, none of them output my IP as blacklisted.

In Exposition des ports, it gives me the issue Le port 22 n’est pas accessible de l’extérieur. For security, I changed the port for SSH. I would rather put a warning when the port has been changed to something else… (Le port 22 a été changé manuellement …)

Bon et puis my Enregistrements DNS is just red everywhere :scream: except a green check for xmpp config.
All my sub-domains (registered in CNAME) are red. They are considered as type A or AAAA…

Some of the useful information on the system (Système/ Réseau / Disque) have disapearred from the Outils tab.

Voilà

Hello @Aleks
same here diagnostic/email i have alarms in diagnostic regarding been blacklisted by many spam sites - just check in each and every site and my ip nor my domain are not blacklisted at all
for sure there is something weird in the way the diagnostic run this.
Could you please have a look thanks in advance?

Eh, that’s weird indeed, probably a bug in our code … Hmm could you possibly share (in private if you want) what the diagnosis showed exactly, maybe including the IP ? (Or could it be that it’s in IPv6 but not in v4 or viceversa ? )

Yes indeed, we can try to take this into account and show a warning instead

Are you meaning not considered as A / AAAA ? I’ll try to reproduce the issue at some point to try to make this work

Yes … basically they should be available in the diagnosis (in resources section) or where deemed too technical for it to make sense … Do you have anything specific in mind ?

FWIW: upgraded a test serveur this morning, everything worked fine, love it so far :smile: (As it is a test server, I could not meaningfully test the DNS part of the diagnostic)

Congrats for this, it’s awesome really :slight_smile:

1 Like

@ Aleks Is Message direct = private message ?

1 Like

Thanks you very much Aleks for your quick answer👍 Indeed Ctrl+Shift+R correct the problem. I note the trick for next time.

1 Like

(So we pinpointed the issue about false-negative for blacklist, it’s a sneaky DNS resolution issue because of the infamous search keyword in resolv.conf … we’re working on a fix)

seems clear
thanks for the output , lets wait your fix - just let us know when ok