We plan to release YunoHost 11 as stable in the next days, please test it :)

@Dutch84 If you want to test a new install of a fresh YunoHost on top of a fresh Debian 11/Bullseye then you just have to do :

$ wget https://install.yunohost.org/bullseye -O install_script
$ bash install_script -d testing
1 Like

I like to wait for the stable version to install, I don’t have enough knowledge to fix problems.

2 Likes

Hello,

I am new to both Yunohost and Wireguard, but I am reporting the following in case it could relate to the current debugging effort.

I have just installed YNH testing branch using the install script on a fresh Debian 11.3 VPS (KVM) with kernel 5.10.0-14-amd64. It worked perfect.
Then I have installed the Wireguard package via YNH web admin interface and got the following error message:

Packagers: ynh_add_app_dependencies is deprecated and is now only an alias to ynh_install_app_dependencies
wg-quick.target is a disabled or a static unit, not starting it.
Loading new wireguard-1.0.20210219 DKMS files...
Building for 5.10.0-8-amd64 5.10.0-14-amd64
Module build for kernel 5.10.0-8-amd64 was skipped since the kernel headers for this kernel does not seem to be installed.
Building initial module for 5.10.0-14-amd64
Error! The /var/lib/dkms/wireguard/1.0.20210219/5.10.0-14-amd64/x86_64/dkms.conf for module wireguard includes a BUILD_EXCLUSIVE directive which does not match this kernel/arch. This indicates that it should not be built.
Skipped.

There’s no “5.10.0-14-amd64” folder in “1.0.20210219” folder, but there is a dkms.conf at /var/lib/dkms/wireguard/1.0.20210219/source/dkms.conf which contains:

PACKAGE_NAME="wireguard"
PACKAGE_VERSION="1.0.20210219"
AUTOINSTALL=yes

BUILT_MODULE_NAME="wireguard"
DEST_MODULE_LOCATION="/kernel/net"


if ls /lib/modules/5.5*/source/include/uapi/linux/wireguard.h >/dev/null 2>&1 ; then
    # debian backported wireguard into the 5.5 release:
    BUILD_EXCLUSIVE_KERNEL="^((5\.[0-4]($|[.-]))|(4\.)|(3\.1[0-9]))"
else
    # upstream requires kernel 3.10 - 5.5, inclusive:
    BUILD_EXCLUSIVE_KERNEL="^((5\.[0-5]($|[.-]))|(4\.)|(3\.1[0-9]))"
fi

I can nevertheless access Wireguard’s unofficial webUI without any glitch.
Since I havn’t been further in WG config yet, I cannot tell so far whether it actually works. But I noted - launching diagnosis command within YNH - a related error about port 8095 apparently closed from outside with a warning saying that it is necessary for wg-quick@wg0 to work properly. The diagnosis also reports that service wg-quick@wg0 failed to start, due to /etc/wireguard/wg0.conf not existing, but i assume that this is because I have not finished the configuration phase yet.

Thank you for testing. Regarding the dkms issue, it should be fixed with a testing version of the app that is waiting the release of YunoHost 11.

Problem known and not critical, cf. the app’s Github issues or maybe even WireGuard thread here.

You assume correctly.:slight_smile: Report back after configuring it and hitting "Apply config " in the webUI.

1 Like

You assume correctly.:slight_smile: Report back after configuring it and hitting "Apply config " in the webUI.

Thanks for your quick reply. Indeed, despite the error message in the Wireguard install process, it does its job properly (basic VPN configuration in my case).

I am encountering two issues while testing the Movim package:

  1. Uploads within a chat fail everytime (both file upload, and drawing functionality which doesn’t get uploaded in the end).
    [Edit] Actually this might be due to YNH integrated Metronome’s configuration, as I have just tried with Gajim desktop client with default XMPP account created at YNH install, and file upload does not work either
    [Edit2] I will report later on that one, it might be due to me messing with the /etc/hosts file and “xmmp-upload” value.
    [Edit3] Reporting back - couldn’t make that work, but it happens to be known issues which seems to be unrelated to the version of Debian.
  2. The sticker functionality (button on the left of the chat’s typing text box) is also bugged - stickers thumbnails do not get displayed, although they can be clicked, successfully sending the given stickers.

Side question - is there an easy way to at some point shift YNH from testing to stable branch, or does it have to be done as I guess via a fresh install?

1 Like

When we will release the new stable version, you should be able to return into stable mode.

3 Likes

The update has worked well (seems to)

  • Nextcloud still working
  • Mattermost still working (need a reboot)
  • webmail is working

So glad! good job every body

1 Like

Hi, I test Yunohost 11 on my armbian system arm64
So I had this problem with rspamd, solved a first time by installing the latest version of rspamd from “sid” but bad idea although functional.
So I reinstalled everything and this time by running the command sudo apt show rspamd -a I found that version 3.2 of rspamd is available in the bullseye backports so I was able to force the install of rspamd version 3.2 this finally solves the problem with rspamd on my armbian…
Concerning user@1007 I also had this problem which I had been able to solve by adding systemd.unified_cgroup_hierarchy=0 in boot kernel parameter
But this solution was only temporary because since the kernel update in 5.15.43 it overloads the system from the start, if I remove this systemd.unified_cgroup_hierarchy=0 I find again this error with user@1007 this seems to be related to the use of cgroup v2
Hoping this helps the Team, thanks again to all the Devs…!

1 Like

Installation on a raspberry 2, modem B+.

Fresh install of raspbian and then used the install script.

I found the bug as Yunohost is broken on RPi 0 and 1 because metronome builds are not armv6 compatible · Issue #1423 · YunoHost/issues · GitHub and solved compiling metronome: after the install script was completed.

After the install I found the user admin not in the sudoers group so I needed to use the command su - to add the user to that group.

The command yunohost service status gives many warning about configuration: unknown, for example:

yunohost-api: 
 configuration: unknown
 description: Manages interactions between the YunoHost web interface and the system
 last_state_change: 2022-06-05 12:05:26
 start_on_boot: enabled
 status: running

Run the update 3 weeks ago on an odroid hc4 and everything is working fine with the following apps :

  • Element
  • Grafana
  • Netdata
  • Nextcloud
  • Only Office
  • Unattended Upgrades
  • Vaultwarden
  • Vpnclient

I had a little bit of trouble with the following apps

  • Matrix
  • Mautrix Signal
  • Mautrix Whatsapp

But reinstalling the apps fixed the problems :slight_smile:

Still have a little bug with a custom backup script using duplicity, but I guess it has nothing to do with yunohost, just duplicity version updated which is not working the same with scaleway cold storage.

Thank you yunohost team for the great job you do !

Retex migration version stable à jour → Debian11-testing 11.0.7

tl;dr : migration ok malgré quelques cahots.


  • Materiel : Serveur x86 distant
  • Type de migration : en CLI via SSH
  • Apps installées :
    • Nextcloud
    • Roundcube
    • Transmission
  • Package supplémentaire : mailutils

Résumé des opérations :

  • Lancement de la migration
    • Warning sur les packages mailutils et certains trucs python et php : dependency problems
    • La migration se poursuit jusqu’à l’upgrade de fail2ban: perte de la connexion SSH.
  • Impossible de pinger le serveur : redémarrage à la dur via l’interface de mon loueur après ~45 minutes à laisser le serveur mariner.
  • Apparemment F2B a banni mon IP, reboot de la box pour renouveler l’IP.
  • OS bien upgradé en Debian 11.
  • yunohost tools update : 171 choses à upgrader.
  • yunohost tools upgrade system: dpkg/APT est en état broken
    • sudo apt install --fix-broken : E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
    • sudo dpkg --configure -a: l’OS reconfigure un tas de choses et upgrade/install une demi-douzaines de packages.
  • L’accès en HTTPS est bien rétabli, je peux me connecter à mes apps. La config SSH est toujours celle que j’avais custom à base d’AllowUsers et pubkey.
  • Accès aux apps ok.
  • Envoi et reception de mails ok.
  • Utilisation de mailx (qui est inclus dans le package mailutils) en ligne de commande pour envoyer des mails : ok
1 Like

Hello,

Is there a date planned for yunohost 11 ?

Thanks

1 Like

In “the next days” is starting to take a month. Are there any good news yet?

1 Like

Tiens c’est étrange, l’OS est bien Debian 11, mais j’ai toujours ça qui traine dans les migrations :

## Pending migrations

23. Migrate databases from PostgreSQL 11 to 13

22. Migrate php7.3-fpm 'pool' conf files to php7.4

21. Upgrade the system to Debian Bullseye and YunoHost 11.x

Lorsque je tente d’effectuer les migrations en question, j’obtiens ceci :

Running migration 0021_migrate_to_bullseye...
Migration 0021_migrate_to_bullseye did not complete, aborting. Error: The current Debian distribution is not Buster!
Could not complete the operation 'Run migrations'. Please provide the full log of this operation by clicking here to get help
Run these migrations: '0021_migrate_to_bullseye', before migration 0022_php73_to_php74_pools.
Run these migrations: '0021_migrate_to_bullseye', before migration 0023_postgresql_11_to_13.

La log est plutôt famélique : https://paste.yunohost.org/raw/pafujavure

Par acquis de conscience j’ai regardé l’état du package php7.4 : il n’est pas installé.

root@serveur:~# apt-cache policy php7.4
php7.4:
  Installed: (none)
  Candidate: 7.4.29-1+0~20220422.62+debian11~1.gbp6939ea
  Version table:
     7.4.29-1+0~20220422.62+debian11~1.gbp6939ea 500
        500 https://packages.sury.org/php bullseye/main amd64 Packages
     7.4.28-1+deb11u1 500
        500 http://mirrors.online.net/debian bullseye/main amd64 Packages
        500 http://security.debian.org/debian-security bullseye-security/main amd64 Packages

On dirait que la migration vers Debian 11 n’est pas bien reconnue, ce qui bloque les migrations suivantes (php et postgresql).

L’OS est pourtant bien migré, et yuno aussi :

root@serveur:~# lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 11 (bullseye)
Release:        11
Codename:       bullseye
root@serveur:~# yunohost tools versions
yunohost:
  repo: testing
  version: 11.0.7
yunohost-admin:
  repo: testing
  version: 11.0.7
moulinette:
  repo: testing
  version: 11.0.7
ssowat:
  repo: testing
  version: 11.0.7

Are we there yet?

1 Like

Thanks for your suggestion, we have added the rspamd 3.2 package from backport into our own repository. It should fixed the bug.

Tu n’as pas de logs de cette opération? Ce serait pratique pour savoir si il y a un vrai soucis (ou si tu as été trop impatient).

No! :stuck_out_tongue: (we are still trying to create some images for arm cards)

2 Likes

Si tu me dis dans quel log chercher je peux jeter un œil :slight_smile:

Il y a logiquement un log de la migration disponible dans l’interface yunohost. Ou via la ligne de commande yunohost log list

Here it is :

https://paste.yunohost.org/raw/afazicuter (migration)
https://paste.yunohost.org/raw/iqecelerun (upgrade)