Wallbag won't upgrade

Hey guys, just saw there was an upgrade for Wallabag today, but upgrading ended with an error (specifically, “an error occurred inside the app upgrade script”). I’m using YunoHost (stable) on a laptop. It’s at home and I have access to my server. The log is at https://paste.yunohost.org/raw/xasupuyavo

Any help would be appreciated.

1 Like

For reference, that seems to be a common issue : Cannot update to 2.4.3 : php dependencies issue · Issue #141 · YunoHost-Apps/wallabag2_ynh · GitHub


There’s already a french topic here. Wait and see…

The same here.
I needed to restore the automatic backup coming from upgrade to make wallabag run.

Do you have nextcloud installed ?

Yes and it works normally

My current guess is that Nextcloud require php-redis, which is not compatible with php7.4-redis that we try to install. That’s the issue.
We are searching for a solution…

I have Nextcloud installed as well. Thanks for working on this.

1 Like

i got "An exception has been thrown during the rendering of a template
(“The Symfony\Component\Locale\Stub\StubIntlDateFormatter::__construct() method’s argument $locale value ‘en_IN’ behavior is not implemented. Only the ‘en’ locale is supported.” and wallabag doesn’t work. so i role back.

Wow, I never saw this one… it might be worth checking if there is a reported bug in Wallabag repository…

I also had trouble with the recent upgrade to 2.4.3. But the upgrade to 2.5 yesterday worked flawlessly :slight_smile:

1 Like

yessss, works :smiley:

1 Like

I tried with Wallabag 2.5.0 and upgrade failed. Issues with php7.4
And yes, I have Nextcloud aswell.

I had also issues with php7.4 and the upgrade went fine with this command (i have Nextcloud aswell):

yunohost app upgrade wallabag2 -u https://github.com/YunoHost-Apps/wallabag2_ynh/tree/fix-php-dep

But don’t forget, it’s not the stable repository, make backup and use at your own risk.

1 Like

Could you elaborate (paste the error message ?) on that php7.4 issue ?

It is now the testing branch : you need to use https://github.com/YunoHost-Apps/wallabag2_ynh/tree/testing.
Also it’s Wallabag 2.5.1 now.

Tests welcomed :slight_smile:

Test is OK with testing branch, great job! Perhaps your job on wallabag can be used for snappymail which suffers from the same bug (php).

I upgraded via the testing branch and it appears to be working other than I can’t change to the dark theme.

I take this back. It didn’t work when I had no articles to read. I just added a new article, and the dark theme is working.

It’s because the cache browser must be refresh after upgrade with ctrl+maj+R. Without refresh cache, you can’t change the theme.