Verify Backups?

My YunoHost server

Hardware: Old computer

YunoHost version: (stable)
I have access to my server :through the webadmin

Are you in a special context or did you perform some particular tweaking on your YunoHost instance ?** : no

I have recently tried to restore a single app, Mastodon, from several backups and each time they are unreadable, this makes me doubt that any of my backups are valid since I’ve never needed to use them until now.

Is there a way I can verify my backups without actually running them? I am trying to do this through terminal using the command: yunohost backup restore “backup name” --apps mastodon

This is part of a bigger problem of not being able to use the Web Panel for backups which is why I’ve been exclusively doing backups from the terminal: yunohost backup create (they were successful without any errors)


Can you elaborate on what message you get

Then why are you “not able to use” the webadmin

1 Like

I’m not sure why I can’t use the backup web admin, I’ve been struggling with it for sometime with no solution:(

and more recently when I hoped that a migration might fix it

I don’t have logs for the error since I attempted a recovery via the terminal but I will run again to see the specific error.

I was now able to upgrade Mastodon after successfully restoring an older backup. I unfortunately lost many of my posts and new subs I may try to restore from a newer version however these are pre-migration 3.8x - 4x, so I hope I don’t break anything.

I am still having issues accessing the Web Admin for backups (doesn’t load, hangs forever)

This is the error I receive from the corrupt backups

" ```
tarfile.ReadError: missing or bad subsequent header

It seems to be the same error with multiple backups:(

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.