Building a new image for raspberry debian jessie - fr - en

,

Déjà tu peux regarder s’il est démarré avec metronomectl status sinon, pour vérifier s’il fonctionne vraiment il faudrait implémenter un client XMPP qui se connecte avec un utilisateur du ldap. Mais je ne suis pas sûr que celà soit vraiment nécessaire.

Sinon, au démarrage, il crée un fichier metronome.pid ici : /var/run/metronome/metronome.pid

donc un truc de ce genre devrait marcher :

if ps -p $(cat /var/run/metronome/metronome.pid) > /dev/null;then
   echo "metronome is running"
fi
root@raspberrypi:~# ps -p $(cat /var/run/metronome/metronome.pid)
  PID TTY          TIME CMD
 1146 ?        00:00:16 lua5.1

on my raspberry, Wich means? I never used Metronome yet.

it means it is running, metronome is written in lua, as an interpreted language it is the lua vm that is running.

@darkbeer42 how its behave on your install?

@n00dl3, is it sufficient to tell that it’s working well?

OK merci.
J’ai un raspberry: cat /proc/cpuinfo

processor	: 3
model name	: ARMv7 Processor rev 5 (v7l)
BogoMIPS	: 38.40
Features	: half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm 
CPU implementer	: 0x41
CPU architecture: 7
CPU variant	: 0x0
CPU part	: 0xc07
CPU revision	: 5
Hardware	: BCM2709
Revision	: a01041

EDITED.

J’ai automatisé le process de création de la carte SD.
J’ai bien aussi l’erreur mentionné par @darkbeer42 sur metronome.

C’est toujours en progrès, la sdcard.

D’après le log il se peut que ce soit un problème d’architecture.

Dec 16 21:52:00 raspberrypi metronome[799]: Starting Metronome XMPP Server: metronomeIllegal instruction
Dec 16 21:52:00 raspberrypi metronome[799]: failed!

Je n’ai pas creusé.

Savez où est installé Metronome dans l’installeur?


I commited some script which are supposed to automate the process of creation of the sdcard image. Still in progress.

For metronome, no clue. I’m guessing it’s a conflict of binary instruction not handled by raspberry. Where is this package installed inside the install script?

May be some hint here: Upgrade on Raspberry Pi B/B+
Sylvain.

Salut,

Pour ceux qui veulent construire l’image Rasbian jessie de yunohost, j’ai formalisé les scripts ici:

À part pour 02_install_yunohost.sh qui ne lit pas encore l’IP en ligne de commande au moment où je poste ce message, tout est écrit dans la doc et dans le code source.

Changer votre IP ici

Happy hacking pour ceux que ça intéresse.

Je n’ai pas encore effacé l’usager pi du raspberry.

fonctionne sur xubuntu 14.04.


If you want to rebuild the Raspbian image with jessie and yunohost, I pushed scripts here:

The doc should be uptodate. Except for 02_install_yunohost.sh which doesn’t read the IP from command line yet.

You have to edit the IP here

Happy hacking…

default user pi is still on the restult scard.

done from xubuntu 14.04.

Regards,
Sylvain.

Salut,

Je n’ai pas eu le temps de retester l’image yuno sur mon raspberry.
J’avais effectivement ces mêmes traces d’erreurs de Metronome.

Il y a ce post qui a une erreur similaire: [solved] Problem with metronome upgrade
mais il semblerait que la raison évoquée sur ce post là ne puisse pas s’appliquer à notre problème.

Concernant metronome, j’ai vu sur Wikipedia :slight_smile: qu’il était utilisé par Jappix, proposé par Yunohost. Je ne sais pas s’il est utilisé pour autre chose.

Je n’ai pas vraiment le temps de creuser plus pour le moment, mais si je devais me prononcer, je dirais que le problème ne vient probablement pas de Yunohost ni de ta génération de l’image @sylvain2.

A+


Hi,

I did not test again the yunohost image on my raspberry.
I did have the same traces you got.

There is a post with a similar error: [solved] Problem with metronome upgrade but I don’t think the root cause given can be the same for our problem here.

About metronome, I saw on Wikipedia :slight_smile: that it is used by Jappix which one of the official Yunohost apps.
I don’t know if metronome is used for something else.

I don’t have the time to dig the problem for now, but I don’t think it comes from Yunohost or your image @sylvain2.

Bye.

OK @darkbeer42. merci. Je n’ai pas creusé le pb de metronome.

J’ai poussé dans le github tous les scripts de rebuild de l’image sdcard. On va pouvoir se concentrer sur ce bug.

https://github.com/Sylvain303/install_script/tree/master/build_arm_image

À suivre.


Metronome error still not explored.

I updated the github with all step scripts to rebuild an img for sdcard for raspbian from scratch:

Enjoy!

Sylvain.

@darkbeer42 après le post install le problème semble disparu pour moi.

Peux-tu vérifier?


After post-install everything is working for me

admin@raspberrypi:~ $ sudo systemctl status metronome
● metronome.service - LSB: Metronome XMPP Server
   Loaded: loaded (/etc/init.d/metronome)
   Active: active (running) since mar. 2015-12-22 14:47:17 CET; 27min ago
  Process: 5217 ExecStop=/etc/init.d/metronome stop (code=exited, status=0/SUCCESS)
  Process: 5223 ExecStart=/etc/init.d/metronome start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/metronome.service
           └─5235 lua5.1 /usr/bin/metronome

déc. 22 14:47:17 raspberrypi metronome[5223]: Starting Metronome XMPP Serve....
déc. 22 14:47:17 raspberrypi systemd[1]: Started LSB: Metronome XMPP Server.
Hint: Some lines were ellipsized, use -l to show in full.

We have to test an XMPP connection be sure.

I think it should be related to missing hostname configuration or something may be.
No more problem after a reboot.

Is it the expected behavior?

Sylvain.

Hello,

I’ve just installed the image on a SDcard, proceed post-installation setup, but couldn’t connect on the RPI because of bad password.
The identifiers to use are :
login: admin
password: the one entered in the web interface at post-installation

But take care the keyboard layout which is by default in QWERTY… Now, let’s go forward… :slight_smile:

Hi @gnuraph,

Réponse en Français ci-dessous.

Yes default keyboard layout in console is us-qwerty. Is it expected or not? How was behaving previous raspberry image?

May be we could provide help with command to change the layout?

I suppose you’re speaking about the admin login on the console (USB connected keyboard and screen), right?
You can also ssh to the raspberry too, which uses local layout not console keyboard layout.

Useful commands on terminal are (chose your own matching keymap):

sudo apt-get install console-data
# azerty
sudo loadkeys fr
# bépo
sudo install-keymap dvorak-fr-bepo

If someone knows what is the expected behavior at the end of the install of yunohost, please provide info.


French:

Donc sur la console (clavier écran connecté au raspberry) c’est bien par défaut en qwerty us, faut-il forcé une autre layout ou aider au choix ?

Par ssh, ça utilise la layout (disposition clavier) de votre ordinateur local.

J’ai mis ci-dessus des commandes pour la gestion de la layout en console pour indice, veuillez vous renseigner sur les usages, ou bien ouvrez un topic sur la gestion des layout et poser un lien ici. Mais ça sort de l’usage de l’image raspberry et tombe dans l’utilisation normal d’un système debian.

Maintenant, concernant l’image raspberry, est-elle différente des images précédentes au niveau du clavier ?

Sylvain.

Hello all,

@sylvain2, can you tell us which defconfig you used to build the kernel ?

I explain, I installed the YuNoHost Wheezy image in my raspberry pi 2. I would like to install xbmc/kodi on it so I follow this page. When I try to install alsa I got the following error from dev/sndstat file :

Sound Driver:3.8.1a-980706 (ALSA emulation code)
Kernel: Linux raspberrypi 4.1.13-v7+ #826 SMP PREEMPT Fri Nov 13 20:19:03 GMT 2015 armv7l
Config options: 0

Installed drivers: 
Type 10: ALSA emulation

Card config: 
bcm2835 ALSA

Audio devices: NOT ENABLED IN CONFIG

Synth devices: NOT ENABLED IN CONFIG

Midi devices: NOT ENABLED IN CONFIG

Timers:
7: system timer

Mixers: NOT ENABLED IN CONFIG

It seems the kernel doesn’t support audio feature.
Why the kernel config for RPI2 doesn’t have audio config enabled by default though the hw has a sound card ?
Why not to use the default/appropriate defconfig file instead of a custom one ?

Thank you!

Hi @gui

en Français ci-dessous.

I used the default rasbian image. I didn’t change anything on the kernel. May be yunohost installer did. The script I used are shared above:

I don’t know if the sounds drivers are enabled by default. Did you look for help on this forum about this specific needs, to build a media center? Is yunohost compatible by default on this king of service? I mainly see it as a server running most of the time away from the operator. So by default sounds is useless. Maybe it was not enabled.


Français :

Gui demande, si les drivers son ont été désactivés ? Dans le cadre de la construction de l’image debian jessie pour raspberry avec yunohost, j’ai pris l’image officiel de rasbian qui a un noyau préinstallé et j’ai ensuite appliqué l’installeur yunohost dessus pour avoir la version yunohost la plus à jour sur une debian jessie. Cf. script ci-dessus.

L’image obtenue sur le raspberry est ensuite extraite de la carte SD et “rapetissée” pour être installée à nouveau sur la carte SD (d’une taille peut être différente) d’un autre raspberry. Lisez les instructions ou demandez moi de les traduire si vous bloquez.

Je ne sais pas si yunohost désactive les drivers son du noyau, ni si s’est supposé avoir du son sur une appilance (boîtier) qui a pour but de faire un serveur. Généralement le serveur travail seul et l’émission de son est inutile pour l’opérateur qui est absent.

N’hésitez pas à contribuer et a documenter la partie son, on peut l’introduire à la construction si nécessaire.

À suivre,
Sylvain.

Hi @sylvain2,

EN:
Since the image is international, qwerty keyboard being the default behaviour seems to be coherent. Simply I didn’t notice the status initially. I don’t remember what is the default keyboard is for other Yunohost images.

FR :
Puisque l’image est internationale, il semble cohérent qu’un clavier qwerty soit celui par défaut. Juste que je n’avais pas fait attention à ça initialement. Je ne me souviens pas quel est l’agencement par défaut pour les autres images Yunohost.

Hi @sylvain2,

I tested a raspbian install from image “2016-02-09-raspbian-jessie.zip” (size 1.5Go) downloaded on the official website. I got a full capabilities kernel with sound on jack and HDMI port. So it seems to be a different image from the one you used as a base for your yunohost one. Or I could simply missed something when installing Alsa…

I think I will install Yunohost from the script (git repo) over my raspbian install ? Do you see any problem that I could get compared to a direct Yunohost image install or is it completely the same result ? I will have some small rights and install problems I guess…

Thx,
Guillaume

Bonjour @gui (Est-ce une réplique du film Rrrrrr)

So, you’re right a new image from rasbian, not tested. I may try to rebuild the yunohost image with it.

Did you try already?
My proposed scripts are only to automate the process of building the raspberry image of yunohost based on jessie, So no limitation is expected.

Si vous avez besoin de la trad en français, dites le moi…
Sylvain.

1 Like

Bonsoir,

J’ai posé rapidement posé un truc là (c’est totalement expérimental) :
http://avignu.wiki.tuxfamily.org/doku.php?id=documentation:yunohost-jessie

En fait, les soucis viennent a priori de metronome qu’il faut installer manuellement et qui reste non-configuré après un upgrade ou dist-upgrade.
Je n’ai malheureusement pas les compétences pour aller plus loin mais si ça peut aider :wink:

ppr

Salut @ppr,

English reader: Ask for English translation, if you need it.

Merci pour le retour, si j’ai le temps vendredi, j’essayerai. Mais c’est loin d’être sûr…

Tu peux créer des tickets sur leur système de ticket pour l’image jessie.
De mémoire, le metronome rentre dans l’ordre à la config du yunohost, il me semble, mais peut être pas…

C’est un serveur jabber je crois, à quoi sert-il au départ ?

À suivre,
Sylvain

Metronome est le serveur XMPP de YunoHost.