Failed to update to 2.4

I’m running YunoHost on a Raspberry pi 2B

It started with an authentication problem on owncloud. As I couldn’t log as admin anymore I decided to uninstall and reinstall owncloud but installation failed as it requested a more recent version of moulinette.

I first followed the update instructions here (automatic then manual): YunoHost 2.4 released, then I searched many other pages like http://avignu.wiki.tuxfamily.org/doku.php?id=documentation:yunohost-jessie but update still failed. I event removed moulinette but it didn’t change anything.

Somme error messages:

root@raspberrypi:/tmp/install_script# apt-get update && apt-get install yunohost
Get:1 http://repo.yunohost.org jessie Release.gpg [490 B]
Get:2 http://repo.yunohost.org jessie Release [18.5 kB]
Hit http://repo.yunohost.org jessie/stable armhf Packages
Ign http://repo.yunohost.org jessie/stable Translation-en_GB
Ign http://repo.yunohost.org jessie/stable Translation-en
Fetched 19.0 kB in 0s (20.9 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 yunohost : Depends: python:any (>= 2.7~) but it is not installable
            Depends: moulinette (>= 2.3.5.1) but it is not going to be installed
            Depends: python-miniupnpc but it is not installable
            Depends: netcat-openbsd but it is not installable
            Depends: procmail but it is not installable
            Depends: avahi-daemon but it is not installable
            Depends: rspamd (>= 1.2.0) but it is not going to be installed
            Depends: rmilter (>= 1.7.0) but it is not going to be installed
            Depends: redis-server but it is not installable
            Depends: opendkim-tools but it is not installable
            Recommends: yunohost-admin but it is not going to be installed
            Recommends: etckeeper but it is not installable
E: Unable to correct problems, you have held broken packages.

root@raspberrypi:/tmp/install_script# apt-get install moulinette
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 moulinette : Depends: python:any (< 2.8) but it is not installable
              Depends: python:any (>= 2.7.5-5~) but it is not installable
              Depends: python-argcomplete but it is not installable
E: Unable to correct problems, you have held broken packages.

Following the error message I installed python 2.7.11 (I had to remove the old version then download and compile python) but it didn't change anything.

Does anyone have any idea what could be wrong or in which direction I could search?

Nicolas

1 Like

moulinette is the more important dependencies of YunoHost.

Is your yunohost cli here ?

try:
yunohost --version

It seems that you lack some core Debian repositories! From what you pasted with the apt-get update output, you only have YunoHost one… That’s why the upgrade failed since almost all dependencies cannot be installed, see ... it is not installable.

Which image did you used at installation?

@ljf I don’t have yunohost cli anymore

@jerome I used the image I downloaded from the raspberry pi page the 18th of November (something like https://yunohost.org/#/install_on_raspberry), the file was called yunohost4rpi2.img.7z. I removed some debian repositories as it was asked on the update page (YunoHost 2.4 released). Before I had the following repositories in /etc/apt/sources.list:

deb http://mirrordirector.raspbian.org/raspbian wheezy main non-free
deb http://archive.raspberrypi.org/debian wheezy main
deb http://repo.yunohost.org/ stable/rpi main

Adding them back doesn’t help anyway

That makes me think I had version 2.2 because of Upgrade on Raspberry Pi B/B+

Oh, where did you see that you have to remove Debian repositories?? YunoHost just provides a few packages which are not part of Debian - i.e. the YunoHost CLI and Web admin, the rest comes from Debian repositories! In other words, YunoHost is just a Debian system with some extra packages. So, if you remove the Debian repositories… a huge part is missing.
Also, note that - as it’s stated in the announcement - you need an up-to-date Debian Jessie system to upgrade YunoHost.

So, in your case, you must add back the two first lines in your /etc/apt/srouces.list file to have back the Debian repositories and consider to upgrade to Debian Jessie - as quickly documented in the announcement.

Thank you for your help.

I understand the two first lines should not have been suppressed but after adding them back the result is almost the same after apt-get update & apt-get install yunohost:

The following packages have unmet dependencies:

yunohost : Depends: python:any (>= 2.7~) but it is not installable
Depends: moulinette (>= 2.3.5.1) but it is not going to be installed
Depends: python-miniupnpc but it is not installable
Depends: rspamd (>= 1.2.0) but it is not going to be installed
Depends: rmilter (>= 1.7.0) but it is not going to be installed
Recommends: yunohost-admin but it is not going to be installed
Recommends: etckeeper but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Reading package lists… Done

with apt-get install moulinette I have exactly the same error message as before about python

Did you also upgrade your Debian system from Wheezy to Jessie at first?

I did update the system from Wheezy first.