Unable to upgrade to Debian Buster and Yunohost 4x

My YunoHost server

Hardware: Old computer

YunoHost version:
I have access to my server :through the webadmin

Are you in a special context or did you perform some particular tweaking on your YunoHost instance ?** : no

I am unable to upgrade to Yunohost 4x via the migration tool due to these errors. Any advice would be greatly appreciated:)


  • It would help if you could share the full log of the failed migration, the log you share is only the “system upgrade” suboperation
  • It looks like you installed a graphical environment on your server, do you confirm that ?

Please let me know if this is what you’re looking for, it is the log specifically for the migration


And yes, I didn’t install Gnome Desktop to more easily navigate the server locally.

Well idk what the hell happened, but from the timing of the logs, it sounds like you started the migration, then it failed, then you somehow thought “well it failed but whatever, let’s launch a system upgrade anyway”

Anyway … let’s first get rid of some boring warnings with :

rm /etc/apt/sources.list.d/sury.list

Then : it looks like the actual upgrade issue is related to

The AppStream system cache was updated, but some errors were detected, which might lead to missing metadata. Refer to the verbose log for more information.
E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/cache/app-info -a -e /usr/bin/appstreamcli; then appstreamcli refresh-cache > /dev/null; fi'

Does “appstream” means anything to you ? It sounds like it’s related to desktop environment stuff, which honestly is just boring, it’s not related to Yunohost and i’m starting to get tired of fixing stuff that are unrelated to yunohost itself…

1 Like

(But anyway you can still go in Tools > Migrations, confirm migration 15 is still pending, then try to re-run it …)

I have no idea what appstream is and I’m not concerned with it either.

When I originally attempted the migration it failed telling me that I needed to complete existing system upgrades first, or at least that’s what I thought:(

I will try what you suggested, thanks!

It is pending, I am retrying now, it seems to be working so far … fingers crossed.

No luck:(


If the Gnome Desktop is causing issues should I be uninstalling it to make it headless again? Or is it something else?

2021-03-02 19:36:46,912: WARNING - /dev/disk/by-id/ata-KINGSTON_SA400S37240G_50026B778253D15C does not exist, so cannot grub-install to it!
2021-03-02 19:36:46,913: WARNING - You must correct your GRUB install devices before proceeding:
2021-03-02 19:36:46,913: WARNING - 
2021-03-02 19:36:46,914: WARNING -   DEBIAN_FRONTEND=dialog dpkg --configure grub-pc
2021-03-02 19:36:46,914: WARNING -   dpkg --configure -a
2021-03-02 19:38:59,039: WARNING - Errors were encountered while processing:
2021-03-02 19:38:59,040: WARNING -  grub-pc

That error sounds similar to Update Errors, also on fix commands!

You should run sudo DEBIAN_FRONTEND=text dpkg --configure -a and probably select /dev/sda … (though difficult to be 100% sure)

Also please run rm /etc/apt/sources.list.d/sury.list as advised previously to get rid of a bunch of warnings …

To give you some background, I was nervous to do these upgrades and break the whole system so I decided to use Clonezilla and simply clone the entire drive to a second identical drive in case something terrible went wrong.

Is there a better way of getting to Yunohost 4x? Possibly by doing a clean install on the new drive and restoring a backup from my original install?

Yes you can …

Or you can just try to run the one command I provided about grub-pc (btw this particular issue ain’t really about yunohost itself, it’s just the grub people who somehow broke the upgrade of the grub-pc package … maybe it’s not even related to moving from stretch to buster)

and possibly relaunch the migration after this …

Don’t underestimate the cost of reinstalling everything from scratch (or from a backup) compared to taking “only” a couple hours to iterate with us on the support …


thanks, I truly appreciate all the help and make every effort not to cause you any grief;( I’ll try the grub command and see where it gets me.

This is what it presents me with 1 - is the drive (sda) and 2 - is the boot (sda1)

which should I be selecting?


Same disk as where the boot partition is installed, so yes, /dev/sda (NOT /dev/sda1)

k, that worked, I’ll try to do the migration now

image Looks like it worked but I’m getting 500 Internal Server Error now, I will reboot to see if this is required.

1 Like

Okay, upgrade complete but I’m unable to upgrade several apps

Nextcloud: https://paste.yunohost.org/raw/bawutucowe

Roundcube: https://paste.yunohost.org/raw/cezixalufe

Mastodon: https://paste.yunohost.org/raw/xesesuzegu

is there anything obvious that you can see?

A backup archive with this name already exists.

There are already a bunch of archives named nextcloud-pre-upgrade2 and same for other apps … the may be remains from failed upgrade attempts earlier, maybe you can delete those

I thought that might be the issue. I had a similar error with my initial Mastodon failed upgrade, I removed the existing file and tried again. Please compare the 2 Mastodon logs:

1st attempt, duplicate detected: https://paste.yunohost.org/raw/xesesuzegu

2nd attempt, duplicate removed: https://paste.yunohost.org/raw/suhoqipuku

Mastodon still failed.

I think this may be an issue with the backup utility. I’ve been having issues for months where the Web Admin doesn’t load the backup tool, it simply times out. The only way I’ve been able to do backup is with the command line.

I will try Nextcloud to see if I remove the duplicate, the issue persists. Thanks!

WARNING - /usr/share/yunohost/helpers.d/backup: line 412: 1908 Killed BACKUP_CORE_ONLY=1 yunohost backup create [...]

Sounds like the issue is that yunohost got killed while trying to perform the backup … that’s usually indicative of an overloaded machine, lack of RAM, etc…

Do you have a lot of stuff running on your server ? Anything in particular in the diagnosis section “System resources” ?