Unable to install dependencies

Mon serveur YunoHost

Matériel: Vieil ordinateur core I7 - 16 Go RAM - SSD 160 Go - 2 X HDD 2To / Brique Internet avec VPN.
Version de YunoHost: 4.2.8.1 Toute MAJ faites.
J’ai accès à mon serveur : En SSH | Par la web admin | En direct avec un clavier/écran | …
Êtes-vous dans un contexte particulier ou avez-vous effectué des modifications particulières sur votre instance ? Non

Bonjour tout le monde,
désolé je n’ai pas pu répondre sur mon dernier post pendant les vacances concernant Nextcloud car le post a été fermé… mais la MAJ a résolu le problème… c’était là => Dossier Nextcloud disparus de l'interface web

Sinon, mon problème actuel et pas des moindres…
Impossible d’installer n’importe qu’elle application sur mon serveur, peut importe ce que je veux faire j’obtiens la même erreur du style : Unable to install dependencies si je comprends bien…

Je vous joins le Yunopast d’une tentative d’installation de Peertube : https://paste.yunohost.org/raw/mepehejoqa

A la base j’avais déjà Peertube avec 2 vidéos simplement donc pas grave mais à force d’essayer de déplacer les datas pour que les vidéos soient sur mon HDD2 dans un dossier /media/peertube au lieu du SSD de base où se situe YunoHost, j’ai flingué mon Peertube…
Bon pas grave en soit pour 2 videos que je pourrais remettre.

Ceci dit, j’avais voulu installer d’autres Apps, et à chaque fois j’ai la même erreur, que cela sois pour peertube, matrix-synapse, NetData, etc.

Voilà, j’ai tenté de regarder du côté des sources.list mais cela me semble correcte, je n’ai pas trop d’idées pour le coup ?..

par avance, merci pour votre aide.
Amicalement,
Francis

Edit :
Problème résolu pour le moment, en fait j’avais des soucis avec mes tentatives d’installation de Matrix-Synapse visiblement…
en Suivant cette piste ici : [SOLVED] Matrix server can't federate - #11 by mms ça a résolu le souci, j’ai pu re-installer Peertube…

Maintenant il faut que je retrouve comment je m’y connecte car cela ne fonctionne pas ! Lol…
Bon en me^me temps j’aimerais bien trouvé la solution pour déplacer les datas sur le HDD2…

Edit, encore une fois…

Le problème en fait est partiellement résolu.
La solution citée au-dessus a permis de régler le problème pour installer Peertube mais cela ne résoud pas un problème identique pour d’autres applications.

Par exemple, je cherche à essayer d’installer synapse/matrix mais j’obtiens le même types d’erreurs.
Voici le paste Yunohost : https://paste.yunohost.org/raw/ovuvuyotur

Par avance merci de votre aide, amicalement.

On voit que des paquets nécessaire au service ne peuvent être installé

2021-09-12 14:36:01,779: WARNING - E: Package 'libffi-dev' has no installation candidate
2021-09-12 14:36:01,779: WARNING - E: Package 'libxml2-dev' has no installation candidate
2021-09-12 14:36:01,780: WARNING - E: Package 'libxslt1-dev' has no installation candidate
2021-09-12 14:36:01,780: WARNING - E: Package 'libjpeg-dev' has no installation candidate

Sa semble etre des paquets dans les depot oldstable

Si tu essayes de les installé a la main ? cela devrait ne pas fonctionner mais l’erreur retourner pourra peut etre aidé

1 Like

Salut, je n’avais pas eu de notification, désolé pour mon retard de réponse…
Je dois changer de fournisseur aujourd’hui même, du coup je vais être occupé à faire en sorte que mon serveur fonctionne et tourne sur la nouvelle box et qu’il soit accessible.
Une fois prêt j’essaierai ta solution, merci. :slight_smile: