The peer didn't know the key we used

What type of hardware are you using: Raspberry Pi 3, 4+
What YunoHost version are you running: 12.0.16 (stable)
How are you able to access your server: The webadmin

Describe your issue

I’m trying to set up yunohost for the first time. I ran the initial diagnosis and it complained about DNS. When I run sudo yunohost dyndns update --force over ssh I get

Info: Updated needed, going on…
Error: The peer didn’t know the key we used
Info: The operation ‘Update the IP associated with your YunoHost subdomain ‘x’’ could not be completed. Please share the
full log of this operation using the command ‘yunohost log share x’ to get help
Error: Could not update IP address to DynDNS

Share relevant logs or error messages

Tried to share the link but new users weren’t allowed to
efuyuqowat

i have nothing to really help but this problem seems to be popping recently

Hi @Awelfo, sorry about the issue and the delay. It should be resolved now, can you confirm?

Yes, it seems to be working now. May I ask what the issue was?

A piece of our infrastructure was down, which prevented subscriptions to be passed over to the DNS server. So on one hand DynDNS said “registration complete”, and on the other hand the DNS was saying “GTFO I don’t know your key”. :sweat_smile: