Temporary Lookup Failure php7.4-fpm no Synapse UID

My YunoHost server

Hardware: Digital Ocean VPS
YunoHost version: 11.2.5
I have access to my server : Through SSH | through the webadmin | through DO web CLI
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:

Description of my issue

Hello friends,

Unfortunately I am receiving an error when sending or receiving emails:

Invalid Addresses
451 4.3.0 <user@email.com>:
Temporary Lookup Failure

Concurrently with this error I am unable to start php7.4-fpm service due to this error in the log:

ERROR: [pool synapse] cannot get uid for user 'synapse'
ERROR: FPM initialization failed

The onset of this error was when my apps all became unresponsive. When I accessed the server again I had to first run:
systemctl start dbus.service and then manually yunohost service restart all of the YNH services. This was able to get all of my apps working again, except for email. However, when I reboot the server, I have to do this again at the start to manually start all of the services. Still php7.4-fpm does not seem to work.

When I try to update the synapse app, it fails with a similar message as the service message - log is here.

At this point I am stumped. Any help is appreciated.

Mon serveur YunoHost

Matériel: VPS en Digital Ocean
Version de YunoHost: 11.2.5
J’ai accès à mon serveur : En SSH | Par la webadmin | avec Digital Ocean web CLI
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

Description du problème

Bonjour mes amis,

Pardonnez moi parce que mon Francais est élémentaire.

Malheureusement, Je reçois ce message d’erreur lorsque j’envoie ou reçcois des emails:

Invalid Addresses
451 4.3.0 <user@email.com>:
Temporary Lookup Failure

En même temps, le service php7.4-fpm n’initie pas et Je reçois cette erreur, et log:

ERROR: [pool synapse] cannot get uid for user 'synapse'
ERROR: FPM initialization failed

Premier, toutes mes apps n’ont pas répondu et J’ai dû exécuter systemctl start dbus.service et puis exécuter yunohost service restart avec toutes les services YNH. Cela a corrigé toutes mes apps, à l’exception d’email. Cependant, quand Je redémarre mon ordinateur Je dois répéter ce processus. Et php7.4-fpm est cassé encore.

Quand Je mise à jour de l’application Synapse, il échoue et Je récois cette log - c’est similaire à l’autre log.

Je suis perplexe. J’apprécie toute aide.

Does the YunoHost diagnostic complains about mails or service configurations ?

Yes, actually the Diagnosis gives two service errors - one log for php7.4-fpm and one log for fail2ban (just noticed this error today).

Interestingly, the fail2ban service error also mentions synapse (see below) but I restart the service and fail2ban is running again just fine without being flagged again in a subsequent diagnostic run.

ERROR   Failed during configuration: Have not found any log file for synapse jail
ERROR   Async configuration of server failed

As for the email there are no diagnostic errors except one that I have always ignored since DO said they won’t unblock this port 25:

The SMTP mail server cannot send emails to other servers because outgoing port 25 is blocked in IPv6.

Another update - there is a related issue on the synapse_ynh Github. Where the github user reports they can find a process id for user synapse, this user does not exist on my server. So, as they suggest at the end, I changed the /etc/php/7.4/fpm/pool.d/synapse.conf user and group to user = matrix-synapseand group = matrix-synapse (as they were in php7.3) and this allows the startup of the PHP7.3-fpm service. At this point, my diagnosis shows that everything looks ok!

Unfortunately, I am still unable to send or receive emails as I am getting the “Temporary Lookup Failure” message.

And still, whenever I restart the server I must also manually start the dbus.service and all the Yunohost services.

I tried reverting to a backup from a week ago and this was the case with that backup as well.

Well, I don’t think I have solved whatever is the root problem, but I have managed to slap on enough bandaids to restore all my services. I was finally able to restore my mail service by restarting the postsrsd service. This, along with the other fixes, has solved my “Temporary Lookup Failure” and I am able to send/receive mails again. Special thanks to this post since my postfix logs were quite similar.

In Summary

When I reboot the server several services do not start (including all the yunohost services) and I often receive cannot connect to /var/run/nscd/socket error.

To get the server operational again, I take the following steps:

  • systemctl start dbus.service
  • systemctl start postsrsd
  • nano /etc/php/7.4/fpm/pool.d/synapse.conf and change the user and group from synapse to matrix-synapse
  • yunohost service start * to start all YNH services

Again - there is definitely a deeper issue here, but hopefully these steps will be able to limp me along until the next major update, which I hope will solve the root cause.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.