Sync problem between Nextcloud and Onlyoffice

My YunoHost server

Hardware: VPS bought online
YunoHost version: 4.3.2 (stable)
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:

Description of my issue

I thought my Nextcloud had some issues with dates: some of my files were stuck at their creation date.
In fact, I just discovered that Onlyoffice had trouble to save my files to Nextcloud and kept them in his cache and then delivered them upon request to Nextcloud.
Everything went “fine” until I uninstalled then re-installed Onlyoffice : I’ve just lost the content or change of hundreds of files.

On the user side, as the autosave is on, the only “signal” is the date that doesn’t change.
If I “force” the save, I get an error message:
Une erreur est survenue lors de l'enregistrement du fichier. Veuillez utiliser l'option "Télécharger en tant que" pour enregistrer le fichier sur le disque dur de votre ordinateur ou réessayer plus tard"

Looking at journalisation on Nextcloud I found:

GuzzleHttp\Exception\ConnectException: cURL error 7: Failed to connect to toto.tld port 443: Connection timed out (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) for https://toto.tld/onlyoffice/cache/files/1379793184_7718/output.xlsx/output.xlsx?md5=8EPPP25EGN9U5egsc2hluQ&expires=1636975859&filename=output.xlsx

On YNST diags my 443 port is okay

Do you have any idea of what could be the source of the problem?

1 Like

Oups…
Personne n’a d’idée ou de piste pour m’aider à débloquer ça ?

Aucune idée, mais je suppose que j’ai le même problème (je dis que je suppose parce que je l’utilise très peu, mais que j’ai du sauvegarder le fichier à la main depuis onlyoffice puis l’uploader sur le serveur afin que YunoHost soit au courant)

J’ai déjà bossé à intégrer ondyoffice à un autre outil et c’était une galèse sans nom, sans succès parfait, mais comme nextcloud, qui leus sert pourtant de vitrine, a les mêmes soucis, je ne comprends pas pourquoi ils ne bossent pas plus sur leur système de sauvegarde qui est foireux (mais j’ai peut être mal lu leur doc, et eux aussi en faisant le plugin nextcloud)

Hum… merci pour ce retour d’expérience @Mamie pourtant, à lire les témoignages, il semblerait que ça fonctionne plutôt bien.
En fait, ici, tout à bien tourné pendant au moins 1 an je pense. Ce n’est qu’en octobre que je me suis fait la remarque que les dates sur Nextcloud ne changeaient plus (est-ce lié à une MàJ…)
Là, c’est surtout que moi je ne comprends rien au journal d’erreur :frowning:

Hello @ljf @Aleks auriez-vous des idées pour m’aider à résoudre ce problème d’enregistrement de fichiers d’Onlyoffice vers Nextcloud ? (je pense à vous car depuis le début de mes aventures avec YNST vous m’avez à chacun fois proposé de super pistes ou des lignes de code qui semblent totalement magiques à mes yeux ! :slight_smile: )

Je te conseille de voir chez onlyoffice

Ou chez nextcloud, il y a beaucoup d’utilisateurs qui se plaignent du même problème

C’est plus un problème de connecteur ou de serveur onlyoffice, je ne pense pas que yunohost y est pour quelque chose.
J’ai les deux installés, mais je n’utilise onlyoffice qu’en lecture.

Merci @jarod5001 oui, j’ai été sur ces forums, mais je n’ai pas trouvé de post éclairant sur ces questions. Souvent ce sont des problèmes de configuration initiale.

Là, j’en suis à me poser la question remonter un autre VPS et à réinstaller un serveur Onyoffice depuis le départ… :frowning:

Essai avec cette solution

Hum… non, ce n’est vraiment pas ce problème là.
J’ai cru également que c’était lié à la limitation de 20 sessions mais non, même avec un seul utilisateur, un seul document ouvert, la sauvegarde manuelle ou automatique ne se fait pas, comme si OnlyOffice ne trouvait pas le serveur Nextcloud.
Comme les données sont bien gardées dans le cache d’OnlyOffice, je n’ai pas l’impression de perdre de données lorsque j’ouvre à nouveau le document. Par contre, si je récupère le fichier en local depuis Nextcloud il est vide (ou pas à jour).

Je viens d’essayer avec mon serveur et ça marche bien.
Mon installation : toutes les applications sont Ă  jour
Nextcloud installé sur domain1.com/nextcloud
Onlyoffice a par contre son sous domaine, et du moment que je n’ai pas pu utiliser de secret key, j’ai opté pour un sous domaine alphanumérique aléatoire de 15 caractères (je sais pas si ça peut aider à “éviter” les connexions non autorisées) du genre azerty123456789.domain2.com
Les domaines principaux sont différents (j’ai lu dans la documentation de onlyoffice qu’il lui faut un domaine différent de celui de nextcloud)
Autre modification que j’ai fait c’est le fichier /etc/hosts auquel j’ai ajouté les lignes

127.0.0.1 domain1.com
127.0.0.1 azerty123456789.domain2.com

J’ai aussi ajouté quelques lignes au fichier config de nextcloud. Juste avant la dernière parenthèse

  'allow_local_remote_servers' => true,
  'onlyoffice'=>
   array ( 'verify_peer_off' => true, ),

@jarod5001 Que veux-tu dire quand tu Ă©cris
du moment que je n’ai pas pu utiliser de secret key ?
Pour info, la config secret key est située dans /etc/onlyoffice/documentserver/local.json et son contenu devrait ressembler à ça.

{
  "services": {
    "CoAuthoring": {
      "sql": {
        "type": "postgres",
        "dbHost": "127.0.0.1",
        "dbPort": "5432",
        "dbName": "onlyoffice",
        "dbUser": "onlyoffice",
        "dbPass": "xxxxxxxxxxxxxxxxxxxxxxxxxxx"
      },
      "token": {
        "enable": {
          "request": {
            "inbox": true,
            "outbox": true
          },
          "browser": true
        },
        "inbox": {
          "header": "Authorization"
        },
        "outbox": {
          "header": "Authorization"
        }
      },
      "secret": {
        "inbox": {
          "string": "secret key"
        },
        "outbox": {
          "string": "secret key"
        },
        "session": {
          "string": "secret key"
        }
      }
    }
  },
  "rabbitmq": {
    "url": "amqp://guest:guest@localhost"
  }
}

En espérant que cela puisse t’aider

1 Like

Merci @jarod5001 pour ces idées.
Je suis en train de tester cette config chez moi.
Lorsque tu parles du fichier de config de nexcloud, peux-tu m’indiquer où il se situe sur ynh ?

sudo nano /var/www/nextcloud/config/config.php

Merci @jarod5001
Finalement, je n’ai pas eu à modifier ce fichier : en plaçant réellement le serveur de document OnlyOffice sur un autre VPS (et pas seulement un autre domaine), tout fonctionne bien.

Par ailleurs, avant cette manip j’avais pris soin de récupérer les fichiers présents dans le dossier /var/lib/onlyoffice/documentserver/App_Data/cache/files/ → là où Onlyoffice stocke les fichiers qu’il ne réussi pas à copier sur Nextcloud.

Donc lĂ , maintenant, tout va bien !

Ce qui est étonnant c’est que ma config précédente (serveur OnlyOffice sur le même serveur, et même le même domaine que mon Netxcloud) fonctionnait parfaitement.
C’est surement une MàJ qui a causé le pb mais je ne sais pas bien laquelle (je la situe autour de septembre).

1 Like

@adepetigny donc pour toi le fait d’héberger sur le même domaine peut entrainer un soucis ? De mon côté je fais toujours une install type drive.domain.tld pour nextcloud et office.domain.tld pour onlyoffice, ça expliquerais pourquoi je n’ai pas le soucis peut être.

J’ai deux domaines différents (cloud.domain.tld et onlyoffice.domain.tld) et pourtant, j’ai des soucis de sauvegarde.

Je dirais que le problème n’est pas apparu de suite. Pendant plus d’un an tout a bien fonctionné.

J’ai l’impression que le problème est arrivé avec la MàJ 21 de Nextcloud (mais sans certitude).
Jusque lĂ , tout fonctionnait bien avec Nextcloud et Onlyoffice sur le mĂŞme domaine.

Hier en testant ce que proposait @jarod5001 j’ai obtenu le message d’erreur “Host violates local access rules” lorsque j’ai indiqué mon serveur Onlyoffice présent sur un domaine différent, mais sur le même serveur (même IP) que Nextcloud.
Si j’ai bien compris, pour ça, il suffit de modifier le fichier de config /var/www/nextcloud/config/config.php

Comme je ne savais pas où était ce fichier de config et que j’avais un autre VPS dispo sous le coude, j’ai installé Onlyoffice sur cet autre serveur et là, tout fonctionne bien.