Starting System Administration With Yunohost

So I just tried two methods to install Yunohost. The first method was to install Debian Stretch on my physical computer and run the Yunohost script. The aecond method I tried was to install the Yunohost packaged distribution on my physical computer. Both did not work for me.

Debian Stretch Method: I had an issue with the script where it could not use my sources.list file. However, after a clean install of Debian stretch I ws having trouble with updating my system using apt from the beginning. Saying it could not connect due to security reasons.

Yunohost “Stretch” Method: After installing my computer reboots and asks me to enter my domain name and admin password, then after processing aome more ends with a warning saying I need at least one user.

Im confused about how this fundamentally works. Do I need to register with a service that Yunohost provides in order for me to use Yunohost? My website is hosted by another company. Do I need to migrate it to Yunohost? Apologies if these are really basic questions. I just dont know what to expect.

Well, it’s normal. No, Yunohost doesn’t provide any service (without the dnydns domain) and you don’t need to have an account on some website. :wink:

Yes, in fact, this warning is normal… and normally doesn’t block the installation/post-installation.

You will need indeed to create an user, at least to have access to your app (if they are private or not), in order to manage them, to set permission, create some email (if one day you want to configure a mail server). Just enter the command you see on your screen. yunohost user create.

For the security problems on Stretch, you will have to be a bit more precise. But if it’s a fresh installation, it’s quite strange.

There is no basic question. Every questions are interesting. So, if you have more questions, don’t hesitate.

Thank you. Lets just focus on the Yunohost “Stretch” install… So, that “normal” message asking me to create a new user - I am unable to type anything. The prompt seems frozen… Do I need to wait much longer? What is the next expected step?

Mh… strange. Normally, it has to continue. Normally it don’t take so much time. If it take too long, just so ctrl+C and do again : yunohost tools postinstall.

Normally the shell appear again after postinstallation.

Can you try perhaps open a browser and type your domain/ip/local ip ? (to see if it still ask for the postinstallation)

So, that is why I felt that perhaps there is some special service I need to sign up for…

Why do I need a Domain/IP/local IP? When asked for a domain, I just typed which is my website which is hosted by a company. I dont host it. Should I be putting my IP address instead as the domain?

Maybe this is why the installation is freezing?

How can I open a browser? Keep in mind I am doing a Yunohost install on a physical computer. How can I open a browser when all I have is a terminal? I feel we are getting close to my misunderstanding about Yunohost.

Well, you have Yunohost on a physical computer, so it’s ok. Well, I didn’t understand where was this computer ? in your home ? a VPS ? (VPS == Datacenter in a company).

To have access to the Admin interface of Yunohost or the future apps, you will need to know the domain you type during the postinstall or the ip where you host the server (Normally, the domain name redirects to the ip of the server).

No, I mean your browser on another computer (laptop/smartphone/or another device where there is a browser.

And it’s me who surely misunderstood. You can explain again.

Normally, the domain you wrote during the postinstall, must redirect to the Yunohost server. If you don’t have domain, you can wrote something in, or Just replace “yourname” with the word you want to have.

As I see, you have already a domain name hosts by company… and your domain redirects to the ip of the company. There are several solutions if you want to use this domain :

Haha. I’m new to being an admin. I have never used a VPS and barely know what that is. I know what a VM is. My Yunohost server will be my desktop computer at the same time. I know this probably sounds liek a bad idea, but like I said, I am experimenting and learning.

I’m not interested in hosting this at a Datacenter. I am only interested in hosting this from my home computer.

And finally, if your goal is only to test Yunohost before having it in production if it works, just type what you want as domain : yunohost.local or something like that. You won’t be able to access from outside and many things won’t work completely. But it’s still good to begin. Then you will be able to acess to your server with local ip or this domain (in your local network and you will surely need to change a line in a file on your client computer – /etc/hosts).

1 Like

Ok. The big problem you will have is that, I think ( as far as I know) that you won’t be able to use server side and desktop side at the same time.

I just want to use Yunohost locally in my own network for now. I actually don’t want to use my website. I just typed that there because I didn’t know what to put. Should I use “localhost” instead?

Later, once I understand Yunohost better, I want to host publicly and maybe even host my website, or even a mastodon instance. I’m sorry but please understand I dont know much about hosting myself. My hope is Yunhost can help me understand system administration and hosting better.

So I ask again, what do I put for my domain so my installation can continue? Can I use “localhost”?

Oh… I can’t use Desktop and Server side at the same time? Why?

You can. I was just thinking about another thing. If your Yunohost instance has already a desktop, so, it’s ok.

Yes, “localhost” is ok, I think.

1 Like

OK, I just tried “localhost” and that didnt work.

… So, I typed “davidphilipefil.local” and that was accepted. However, I am still still at the “yunohost user create” prompt and Ctrl+C wont work to let me type anything and I cant type at all at this point…

… The cursor is blinking, but i cant type…:crying_cat_face:

Welll, it’s quite weird. Moreover, everything seems to be ok… (Success) I will try to do a little research on the subject.

Not sure why exactly this is happening, it might be the install script not understanding that the postinstall is done … To me, this install script should just tell to launch “manually” the postinstall with the corresponding command.

Anyway, it should be fine to just Ctrl+C (“cancel” the command) when getting to this point then keep on with the rest

1 Like

OK, heres an update. So, after this point I found that if I reboot I get a username and password prompt. after numerous trial and errors, I found that if I typed “admin” and used the admin password I chose, that it would let me into a terminal where I COULD type “yunohost create user username” … immediately afterwards I did a “sudo install gnome” and got my DE installed.

i then used sudo to create a new user in the terminal “sudo useradd -m username”. I did this because in Gnome I could not use the GUI to add a user. My password which I used to login to “admin” would not let me gain GUI access to add a new user for some reason. I even tried to change the “admin” user password in the terminal using “passwd username”… the prompt was different than usual. It said “LDAP administrator password:” instead of Enter new UNIX password:".

Its details like this that has newbies like me scratching their head… I will keep updating this thread as I figure more stuff out and have questions.

1 Like

Uh okay, but be aware that installing a desktop environment on a server is not something usually recommended … except if you really have the use of it. Servers are usually not meant to have a desktop environment as it just take a lot of resources for something that is unused 99.9% of the time.

Also I don’t understand why you didn’t create the user using yunohost user create as was advised by the postinstall ?

1 Like