[SOLVED] Yunohost-firewall does not start automatically with Proxmox CT

, ,

My YunoHost server

Hardware: PC moderne 64Bits - 15Go RAM
YunoHost version: 11.0.9.14
I have access to my server : Direct access via keyboard
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes
If yes, please explain: YNH is in CT Proxmox

Description of my issue

When I reboot the YNH CT proxmox, the yunoshost-firewall service does not start automatically.

The SSH service did not start as well, but the problem was known. The following commands allow to correct the problem:

systemctl disable ssh.socket
systemctl enable ssh.service

I have consulted the following topic: Yunohost-firewall ne démarre plus au démarrage ,but the commands indicated do not allow to correct my problem

When I run the command, we can see that the service is active

~# systemctl status yunohost-firewall
● yunohost-firewall.service - YunoHost Firewall
     Loaded: loaded (/etc/systemd/system/yunohost-firewall.service; enabled; vendor preset: enabled)
     Active: inactive (dead)

However, when I manually activate the service via the administration panel, the service works properly.

What is disturbing is that I backup the server daily in stop/restart mode.

This forces me every morning to activate the service manually.

Do you have an idea?

Thank you in advance for your help.

Sincerely,

hi,
to get around the problem, I added in the crontab the execution of the service in the following way:

crontab -e

and I added the following line:

@reboot sleep 10; systemctl start yunohost-firewall

If you have another solution I’m interested, because I don’t find this method very orthodox :slight_smile:

Nevertheless, I will close this topic if the backup of this night went well and the service was correctly restarted

Sincerely

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.