[SOLVED] Need to access /var/www via ssh but no permissions

Hello everybody

My YunoHost server

Hardware: Raspberry Pi at home with VPN
YunoHost version:
I have access to my server : Through SSH, through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

I’d need to access the apps folder (var/www as far as I know) in order to paste some files in my Omeka S app folder, like plugins files or themes, which have their specific path there.

Is this possibile? I’ve tried through sudo on ssh or even changing permissions with chown but still can’t access the folder due to permission issues.

Hello, I had the same problem and the top answer here solved the problem for me! (After many weeks of trial and error and all sorts of horrible workarounds I’m too ashamed to admit to.)

Hello edoardo,

We need to know what you are typing and seeing in your terminal to understand what’s the issue.

Hello both and thanks a lot for your answers :slight_smile:

After thoroughly searching I found some similar cases which contained some solutions for accessing those paths through sftp instead, like here in the forum and here in ynh’s documentation.

At the same time now I’m facing some troubles for accessing a calibre database on the server through calibre desktop app… again for read/write permission issues, but very weird. Different topic but if you feel to give a look at it I’d be glad! I’m posting it here

Thanks again

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.