[Solved] I get a FetchFailedException python error when attempting to update

My YunoHost server

Hardware: OVH Dedicated server
YunoHost version: x.x.x
I have access to my server : Through SSH + through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hello ! I tried to update it via the shell with yunohost tools update, or via the administration interface, but I got the same error in both cases:


PUT /update


Traceback (most recent call last):
  File "/usr/bin/yunohost", line 213, in <module>
  File "/usr/lib/python2.7/dist-packages/moulinette/__init__.py", line 136, in cli
    moulinette.run(args, output_as=output_as, password=password, timeout=timeout)
  File "/usr/lib/python2.7/dist-packages/moulinette/interfaces/cli.py", line 390, in run
    ret = self.actionsmap.process(args, timeout=timeout)
  File "/usr/lib/python2.7/dist-packages/moulinette/actionsmap.py", line 519, in process
    return func(**arguments)
  File "/usr/lib/moulinette/yunohost/tools.py", line 467, in tools_update
    if not cache.update():
  File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 466, in update
    raise FetchFailedException()

The reason why I tried to update is because I fellt like my Yunohost installation was starting to be unstable. Why ?

  • It’s been ages I’m getting this error when loging into the administration panel:

    Failed to get status information via dbus for service NAME_INIT.D, systemctl didn't recognize this service ('NoSuchUnit').

  • I can’t access to the Nextcloud settings page. I get an Internal Server Error from Nextcloud.

These two issues might not be related at all, but I just thought I’d say it in case it would be relevant.

Basically, I was trying to perform the update in order to fix everything, it didn’t ! Yet :slight_smile:

Any suggestion would be welcome, I’ll keep digging meanwhile, although I’m really a newbie!

And thaaaanks again for the good work!

1 Like

Please run apt update through SSH manually if you can, that should give more insight about what’s going on

Ha good shout !

I have two problems apparently:

Signature verification and a unreachable repository, http://debian.mirrors.ovh.net/debian. No idea how to fix this thougt, I’m going to investigate :slight_smile:

root@asinus:~# apt update
Hit:1 http://security.debian.org/debian-security stretch/updates InRelease
Hit:2 http://forge.yunohost.org/debian stretch InRelease                                                                                                   
Hit:3 https://download.docker.com/linux/debian stretch InRelease                                                                                           
Hit:4 https://deb.nodesource.com/node_6.x stretch InRelease                                                              
Ign:6 http://repo.mongodb.org/apt/debian jessie/mongodb-org/3.2 InRelease                                                
Ign:7 http://repo.mongodb.org/apt/debian jessie/mongodb-org/3.4 InRelease                                                
Ign:8 http://repo.mongodb.org/apt/debian stretch/mongodb-org/4.0 InRelease                         
Get:9 https://last-public-ovh-kernel.snap.mirrors.ovh.net/debian ovhkernel InRelease [4,930 B]                           
Hit:10 http://repo.mongodb.org/apt/debian jessie/mongodb-org/3.2 Release                                                                                   
Hit:11 http://repo.mongodb.org/apt/debian jessie/mongodb-org/3.4 Release                                                 
Hit:12 http://repo.mongodb.org/apt/debian stretch/mongodb-org/4.0 Release                          
Err:5 https://packages.sury.org/php stretch InRelease                                              
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B188E2B695BD4743
Ign:16 http://debian.mirrors.ovh.net/debian stretch InRelease                                                                                              
Get:17 http://debian.mirrors.ovh.net/debian stretch-updates InRelease [91.0 kB]
Get:18 http://debian.mirrors.ovh.net/debian stretch Release [118 kB]
Fetched 214 kB in 2min 0s (1,771 B/s)                         
Reading package lists... Done
Building dependency tree       
Reading state information... Done
181 packages can be upgraded. Run 'apt list --upgradable' to see them.
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://packages.sury.org/php stretch InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B188E2B695BD4743
W: Failed to fetch https://packages.sury.org/php/dists/stretch/InRelease  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B188E2B695BD4743
W: Some index files failed to download. They have been ignored, or old ones used instead.

All sorted by cleaning the cache:

sudo apt-get clean
sudo mv /var/lib/apt/lists /tmp
sudo mkdir -p /var/lib/apt/lists/partial
sudo apt-get clean
sudo apt-get update

(from here)

Thanks :slight_smile:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.