[SOLVED] Disabling SSowat login for some url / (FR) Désactiver la connexion avec SSowat pour certaines url

,

(french version at the bottom)

Hello,
I’m struggling with SSowat unique login system with a few apps, like Tiny Tiny RSS (and FreshRSS) and Ampache.
I need to connect to those apps with their API. For both apps it means they will send the login info in the url.
But all the time SSowat login step came first, so the client is not working as I can’t connect (even if it’s the same password, as the url changed - no login info is given).
Is there any way to disable this login step only for a few apps/url ? (Ampache for instance always prompt a login screen - so there is no security issue)

Thanks :slight_smile:

(version française)

Bonjour,
Je rencontre un problème avec le système d’authentification unique de SSowat avec des applications du type Tiny Tiny RSS (ou FreshRSS) et Ampache.
J’ai besoin de m’y connecter par leur API. Pour ces deux applications cella implique un envoi des informations de connexion dans l’url.
Mais SSowat prends systématiquement le relais, donc les clients ne sont pas fonctionnels - je ne peux pas me connecter (même si les informations sont les même, puisqu’elles ne sont pas transmises).
Y-a-t-il moyen de désactiver cet écran de connexion pour ces applications/url ? Il n’y aurait pas de problème de sécurité, Ampache par exemple affiche dans tout les cas sa propre fenêtre de connexion.

Merci :slight_smile:

1 Like

Tu peux utiliser cette commande:

sudo yunohost app setting ID_APP skipped_uris -v "/"
Ensuite il faut recharger la config sso avec
sudo yunohost app ssowatconf

Ça fera sauter le sso sur l’ensemble de l’app.
Mais le mieux est de poster une issue sur le github du package de l’application, car il est souvent plus intéressant de tenter de garder une entrée sur les API tout en gardant le sso.

Merci de ta réponse. Mais je me retrouve avec une erreur 405 Not Allowed :frowning:
Sans ça pas de réponse des clients.

Ce qui est étrange c’est que d’autres non pas de problème avec les paramètres de base…

Après avoir posté sur le github, un des développeurs, très réactif, m’a indiqué la solution: https://github.com/plopoyop/freshrss_ynh/issues/11
La seule url à mettre en skipped_uris est celle du fichier php de l’API:
sudo yunohost app setting ID_APP skipped_uris -v "/api/ttrss.php"

Puis: sudo yunohost app ssowatconf

Merci @Maniack_Crudelis pour ton aide :slight_smile:

2 Likes