I can't make a bootable USB

,

Hardware: Beelink S2
YunoHost version: yunohost-stretch-3.5.2.2-amd64-stable

Hi guys,

I’m trying to install YunoHost on a computer, but I’m having trouble to get started. I download the ISO and then use DD to make a bootable USB (dd if=/path/to/yunohost.iso of=/dev/sdb) but none of my computers detects the disk as bootable.

Am I doing something wrong?

Bonsoir,
As-tu fait bien quelques vérifications, genre :
http://debian-facile.org/doc:install:usb-boot
?

Hi there,
You can try to do it with the software Etcher.

[quote=“anonyme18, post:2, topic:8356”]As-tu fait bien quelques vérifications, genre :
http://debian-facile.org/doc:install:usb-boot ?[/quote]

Hi, I’m not great with French but I’ll try to give that page a good look and translate as much as I can’t. I assume there’s no English version?

I did:

But when I tried to boot it:

(Sorry about the double post, the forum won’t let me upload two images in the same post).

Maybe the USB is disabled in your bios?

By the way, is it an SD card?

I don’t think so. The USB fails to boot on several computers where I regularly use other live USBs.

No, it’s a regular USB. I’ve tried it on two different USBs with the same results, actually.

Well, it’s weird.
Could you check in the setup of the BIOS just in case…?

I did, it doesn’t see the USB :frowning:

I ran into this problem once with a ubuntu live usb. I tried with 2 different usb sticks. Then I downloaded the iso again and bought a new usb. It then worked.

So it was either a corrupted download or I had 2 bad sticks at the same time.

I just tried with my second ISO and my third USB, and I’m getting the same results. So it seems it’s neither the ISO nor the USB…

Not to sound like a jerk, but you did download the right iso? Not the virtual machine and the right 64 or 32 bit. Just looking at the simple things first.
I’ve tried installing virtual machine images on usb and they intalled but would not boot.
Hence my name. Lol.

You don’t, thanks for the help :slight_smile:

I’m pretty sure I got my ISO from “regular computer, 64 bits”, but who knows. Maybe I got it wrong the first and second times. I’ll download it again and let you know how that works out. Thanks again!

Hopefully its something simple as that.

I wish, but no. I downloaded the ISO again (this time making extra sure it was "regular computer, 64 bits), installed it with Etcher, and it still doesn’t work.

Meh, I would guess it’s related to the stupid UEFI / secure boot stuff in the BIOS because they always get in the way (though recent ISO should handle that correctly…)

… Maybe tweaking the corresonding setting in the BIOS could solve the issue (if that’s indeed a UEFI bios)

I guess it could be. What would the corresponding setting look like?

Something called “UEFI” or “Secure boot” or “Boot type : Legacy / UEFI”

press F7 , security, secure boot, disable “secure boot” and “fast boot”