Server error trying to use the linux snap Invoiceninja app

I open this issue as suggested by @rndmh3ro (see here).

My YunoHost server

Hardware: Raspberry Pi at home
YunoHost version:
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I tried to use the linux snap invoiceninja app (because I have problems using the web app in Firefox), but I have the following error when trying to log in:

Error: please check that Invoice Ninja v5 is installed on the server

I checked that port 443 are opened on my internet router (it shows green in ynh diagnosis).

I don’t know where to get more information about the error.

Can you open the URL of Invoiceninja in any browser? If yes, it’s maybe a problem with snap.-

1 Like

Yes I can open it normally in a browser.
I reported the issue on the github of invoiceninja.

1 Like

Ok I found out what was wrong.

The app was not set as “public” in the Yunohost group and permissions settings. It took me a while to realize that as I’m always logged in my Yunohost account usually. But when I tested in a isolated tab I realized I was redirected to the Yunohost login page first and understood that was probably the problem.
This is probably something interesting to state in the documentation.

So now I can use the Invoiceninja linux snap app at least. But ideally I would prefer to not set the app public and only use the web app, but I still run into this strange keyboard input problem where I can’t type any text… I hope to solve that soon.

Great that you solved it!

Yeah, you’re right. I added it here: Add proper documentation to yunohost homepage · Issue #15 · YunoHost-Apps/invoiceninja5_ynh · GitHub

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.