Secure Scuttlebutt Room Not Showing Up Online

[there is NO Secure Scuttlebutt Room tag!!]
[il n’y a pas de tag “Secure Scuttlebutt Room” !!]

Hardware/ Matériel: Raspberry pi4

  • Server is running Linux kernel 5.10.11-v7l+
  • Server is running Debian 10.11 [updated]
  • Server is running YunoHost 4.3.5 (stable) [updated]
  • App: Secure Scuttlebutt Room Server 2.0.6~ynh3
  • Yunohost domain mydomain.noho.st (auto dns config)

Apps:

  • Manyverse Version 0.2201.7-beta (desktop Mac)
  • Patchwork 3.18.1
  • Manyverse Version 0.2112.3 (mobile Android)

So, I have it all setup, but my Scuttlebutt Room does not show up in any apps (Patchwork/Manyverse) even though people have successfully connected with the Room. We can connect to the Room’s noho.st http address, login to the Admin panel, I can see there are members of the room, etc., but nobody, including myself, can see the Room in their apps.

It should be there… what can I do to solve this issue? I’ve been trying many different things, but I’ve run out of ideas.

J’ai donc tout configuré, mais ma Scuttlebutt Room n’apparaît dans aucune application (Patchwork/Manyverse), même si des personnes se sont connectées avec succès à la Room. Nous pouvons nous connecter à l’adresse http noho.st de la Room, nous connecter au panneau d’administration, je peux voir qu’il y a des membres de la salle, etc., mais personne, y compris moi-même, ne peut voir la Room dans ses applications.

Elle devrait être là… Que puis-je faire pour résoudre ce problème ? J’ai essayé de nombreuses choses différentes, mais je suis à court d’idées.

Hi Scocasso,

Welcome to the forums!

I didn’t notice (or search for) Secure Scuttlebutt in the apps, thanks for mentioning. I have been intending to try out SSB for years!

I intended to reply earlier, but had some (self inflicted) trouble installing it myself, so I turned to the documentation of the app on Github. I noticed, under the disclaimers,

Maybe “doesn’t need yunohost SSO” needs to be elaborated to “does not need or support Yunohost SSO”.

That explains the lack of a tile for the app: it is only the server, not a client package.

Does the Yunohost diagnosis give a hint about closed ports? I guess your RPi4 is running at home, behind the ISP router. I guess you opened the ports (else no one would be able to connect), asking for sure :slight_smile:

The installation asks whether it is a private or public room, and mentions private rooms will only be accessible for Yuno-users. You made it public there, I think?

I have been intending to try out SSB for years!

I have been doing some research on decentralized communication methods for the last couple years because many of my friend want to get off big tech messaging, and they’re not computer savvy, so it was up to me to look into it. I have come the the conclusion that SSB is the best option at the moment, and it has a promising future too. Imagine connecting via shortwave radio and other methods, lots of potential.

public mode

Yes, I tried changing the modes. It had no effect on whether or not the Room or Peers in the Room were visible. Still nothing.

diagnosis give a hint about closed ports

I was able to open all the ports except for Port 25 as that one is closed by my ISP, but it is not needed for the SSB Room. All of my diagnosis alerts are regarding email and port 25.

For your room to fully work the following TCP ports need to be allowed:
• 80 (HTTP)
• 443 (HTTPS)
• 8008 (SSB)

All of those ports are greenlit and open, no probs.

diagnosis
Also says this:

  • Your IP or domain is blacklisted on Invaluement
  • Your IP or domain is blacklisted on SPFBL.net RBL

No idea if that’s a prob or not, but my guess is not. Nobody has a problem signing up, logging in, etc. The only prob is that the room is not showing up in the SSB network. It’s like it can’t been seen for some reason by the SSB apps (Manyverse and Patchwork). Everything works fine locally via WiFi.

“To run an SSB room you need to have a static public IP, ideally with a DNS record (i.e.<hostname.yourdomain.tld>).”
ssb-room/manual-setup.md at master · staltz/ssb-room · GitHub

“requires a full dedicated domain and does not support sub-paths”

Hm… I do have a .noho.st address… that I set up during install with yunohost… not sure if that qualifies.

But, my IP address, even if it is dynamic (which it is as my ISP), it doesn’t change very frequently, and we should be able to see the Room and connect through the Room if we just moments ago connected with the Room. I can see other Peers immediately after connecting. Also, the Room is on the same local network as I am, and I still cannot see it or connect through it with a SSB app to other Peers, local or distant.

I read somewhere… not sure where, that SSB Room needs a static IP address. Well, I’m on residential internet and it’s a dynamic IP address.

No indeed, it means that emails sent from your server have a higher chance of being marked as spam, but it has no relation to SSB.

Yes, it qualifies. You could even create a sub-sub-domain, and use that for SSB. If your domain were scocasso.noho.st, you could have SSB running on securegossip.scocasso.noho.st, for example.

I think that it is intentional / the way SSB works, as a P2P app. There is no central server that you connect to that will give a list of pubs and rooms, but peers can gossip about a room and so you get (or, actually, your app gets) to know about it. From the SSB FAQ:

As much as I like the concept of SSB, Matrix is already there with a slightly less P2P approach (there is a mechanism to announce your presence or the presence of your server to centralized directories (though as far as I know vector.im is the only public directory server running atm). Serverless P2P was shown during FOSDEM last year, and Bluetooth BLE is talked about in more depth in a Matrix vlog from a year ago. Pretty cool as well :slight_smile:

In the mean time I have my SSB room running as well. I expected the installer to create an admin account for me based upon my input (I didn’t have an SSB account yet). So I entered a name for the admin, and it kept crashing on install in different scenarios.
In the end I figured I’d need to enter an actual SSB key ID. I couldn’t figure out how to make an account, until I just tried searching for a SSB/manyverse client in f-droid, installed manyverse, created an account and guessed I’d need the key from that account. Got the room installed in an instant then.

1 Like

Hey, guess what? I do have a tile for SSB!
image

I didn’t expect to get it, and had not opened the portal yet today. Didn’t do anything to get it, but I did perform apt reinstall moulinette yunohost yunohost-admin, which took a minute, but did repair an unrelated problem.

It leads to this page, where I am unable to use user/pass login (don’t have the device with manyverse installed at hand) :
image

When you see a Peer online through a Room, it should look like this above example [from the Manyverse website].

It’s like it can’t been seen for some reason by the SSB apps

What I mean is, I have sent out invite codes, people have joined my room, and when there are members of my Room who are online, they do not show up as being online and cannot connect to other Peers through my Room. Everyone can visit the .noho.st address and see the Room “description” page, no problem. They can even login, too. But Manyverse, or Patchwork does not connect to my Room.

Ah, it’s good that you’ve got it up and running. You just need to run a diagnostic and go through opening ports etc. to make everything work. I followed all the instructions, but still, my Room doesn’t communicate with Manyverse or Patchwork.

I had no problem logging in now that I had the phone with Manyverse at hand:

  • click the SSB-tile in the Yunohost portal
  • arrive at the web page with the room-description, press sign in top-right
  • scan the QR-code with a browser on the phone
  • the browser or the phone opens Manyverse, confirms something that let the browser on the computer open the room-page
  • there was some question from Manyverse whether I liked to log in to the room (slipped my mind what exactly)

The webpage shows

Manyverse lists the room on the ‘connections panel’, saying ‘(only you online)’. Pressing the line gives me options to sign into the website, manage aliasses, disconnect and disconnect+forget.

The room itself does not provide any functionality for me as a single user; there is no ‘chat room’ like experience. Without other users, there is no one to copy my (non existing) chat log either.

In how far does this resemble your experience? If I understand correctly, the problem you describe starts when other (Yunohost or non-Yunohost) SSB-users connect, correct?

I guess you set the room configuration to all of the available option for testing?

I scoured the manyver.se website, but did not come across the screenshot you posted. I think I can not see that image anyway, because there is no peer to connect to.

Manyverse lists the room on the ‘connections panel’

So you can see your Room in your Connections Panel?? Fuck, why can’t I see mine? Can you see your Room in your Connections Panel all the time? Or, only when you are logged into the Room web login?

So, I sent Invite codes to people, including other accounts of my own on Manyverse and Patchwork. The others all installed Manyverse on their phones. Went to the invite page, clicked to accept invite code, the pages says that it’s trying to find a SSB app, after a few moments it says there is no SSB app on their phone and to install Manyverse. Of course, it’s already installed. So, they chose the other option, of pasting in the code. That seemed to work, but there was no confirmation such as “you have successfully connected with this room”, but if I go into the Room Admin Panel, I can see that they are now members of the room and their invite codes were Claimed. But, zero people online. So, your screenshot shows “1 Online” mine always shows “0 Online”.

Okay, so I just went to my mydomain.noho.st > Login >

Usually, I choose to login with my password because the other method never works.
So just now I tried again…

Sign In With SSB > Then it opened Manyverse

Wow! It usually never does that. Usually it says that it cannot find a SSB app. Manyverse asked me if I want to allow it to sign in, I clicked yes. Great!

Then a blank tab opened in my browser. Huh? Why??
I went back to the Login Page tab and it says “waiting for confirmation”.
Screenshot 2022-01-09 at 14-19-13 Sign in with SSB

But wait… I could suddenly see my Room in the Connections Panel!!! Said ‘unknown’ but it was there! What does this mean?? Why did it suddenly appear?

Back at the Login page it was still in “Waiting For Confirmation” from Manyverse. Waiting, waiting… then my Room disappeared from the Connections Panel and I got a message on the login page:

Sign-in failed. Please make sure you use an SSB app that supports this method of login,
and click the button above within a minute after this page was opened.
Manyverse Room Login Error (public)

Shit!! Was the sudden appearance of the Room a coincidence, or connected to my Login attempt??

That doesn’t make sense, because once you are a member of the room, aren’t you automatically connected to the room with Manyverse everytime you open the app? You don’t have to Sign In to the Room every time to connect with friends, do you?? Or is that how it works?? I’m pretty sure once you are connected, it’s automatic after that.

So maybe all of this problem is something to do with improper communication between the Login Page and Manyverse. I’ll try to recreate the sudden appearance. I’m using Firefox, but my friends were using their phones, so it didn’t work for them either, they had to paste the code to accept the invites.

I’ll try SSB Login again…

Yes, my Room appeared again! It stayed in the Connections Panel until just before the “Sign-in failed” message. Holy fuck, I feel like I made some progress. Before it disappeared, I quickly opened the profile for the Room in Manyverse and clicked Follow, I thought maybe that’s what it wanted me to do. But, no, the Room soon disappeared again. When “Sign-in failed” on the browser login page. :roll_eyes:

I will try again with Safari…

The exact same thing happened with Safari, Manyverse opens, click Yes, blank page opens in Safari, then on the login page says “Waiting For Confirmation”, and eventually the Room disapears from the Connections Panel and the same error is seen in the broswer SSB Login page.

I kept my dashboard open the whole time in Firefox while trying to Login with Safari, and always “0 Online”. I thought that maybe it might say “1 online” while the Room was visible in the Connections Panel, but no. I asked my friend (distant location) to try to sign in with SSB (android phone), but when they do that, it opens a blank page on their browser.

I have called my friends on the phone to see if they can connect to anyone, no they cannot. The Room doesn’t appear in their Connections Panel and they cannot see others online when we know they are online, and I’m online, and the Room is online. Uuuuug!

This is what my friends see on their phones:

They try to sign in, it opens a blank page in their browser.
It does not open Manyverse.
Then it says “Waiting for confirmation” and just stays like that.
It doesn’t change to “Sign-in failed…” as it did with me on a desktop computer.

In my case: yes, Manyverse stays connected with the room by itself. My session in Firefox on the desktop and my session in Firefox on the phone timed out, I’ll have to log in again to open the room in my browser.

Manyverse does convert the room-id to the location in my case, is your room on a (sub)domain by itself?

Where did you get Manyverse? I installed it from f-droid, version 0.2112.3-beta-fdroid. I installed it yesterday, but now a newer version 0.2201.5-beta-fdroid is available.

Damn, can’t believe your Room is working so easily, and mine isn’t. Super annoying.
I’ve been trying to do this for like 9 fucking days.
I downloaded Manyverse from Download | Manyverse
I have Version 0.2201.7-beta (desktop Mac)

is your room on a (sub)domain by itself?

Um… I guess so. There are no other apps/services running on the yunohost server, only SSB-Room, if that’s what you mean.

What if you take your Room offline, does it still show your room in Connections Panel, only saying (offline, i.e. no green dot)?
Or does it totally disappear from Connections Panel?
I joined my room with an invite code that I pasted in, but there is Room indicated in Connections as being online or offline.


Ok, I started with:

  • Manyverse running on Android, logged in to room ssb.osba.nl
  • room logged out in Firefox on Android (Line
  • room logged out in Firefox on desktop (Debian)

Now I want to bring the room offline.

  1. On the desktop: Log in to Yunohost portal
  2. Click the Scuttlebutt Room
  3. Arrive at the white page with the pink ‘Description’ logo
  4. Click ‘Sign in’
  5. Click ‘Sign in with SSB’
  6. I can not use the green ‘Sign in with SSB’, because I don’t have a desktop client for SSB installed; use the QR code
  7. On the phone: open a new Firefox-tab
  8. Use ‘Scan QR code’ for URL and point at the QR code on my desktop Firefox window
  9. Firefox asks “Allow Firefox to open https://ssb-url”? Yes, OK
  10. Firefox on phone shows the SSB room login page, with the green ‘Sign in with SSB’-button
  11. Tap the green button
  12. Manyverse pops up, asking ‘Allow sign-in?’, “A web browser is requesting permissions bla bla, with my ID”, Yes, OK
  13. Nothing happens. Not on the phone, not on the desktop. The admin login to the room in the browser does not succeed.

I think Manyverse is already connected to the room, so it does not bother to allow me admin access. I next tried:

  • in Manyverse, in the connections panel, tap the room, select ‘disconnect’ in the popup; no action
  • in Manyverse, in the connections panel, tap the room, select ‘disconnect and forget’; no action
  • I am still connected to my room; once again the popup, select ‘Sign into website’; nothing happens

Maybe the new version of Manyverse brings improvements. It is building database indexes now…

Hmm… yeah, so since we’ve already accepted the invite code (by copy/pasting the invite code), nothing happens when we try again. That would make sense.

I’ll try removing an account from the Room and seeing what happens when I try to send another invite code.

So, I tried removing my Manyverse ID from the Members list, then made another invite code.
This time, when I click “Join This Room”… it says “Opening SSB app” and the MacOS asks me which app to open, I choose Manyverse and… then nothing happens. It doesn’t switch to Manyverse, it doesn’t as me “Allow sign-in”. WTF? Huuuuuuuuuh. Tiresome.

I closed Manyverse. Tried again. This time the Manyverse app opens and it switches to the app, but it doesn’t ask me “Allow sign-in”. Nothing happens. And it still says “Opening SSB app”. It never changes to “Error…”. OMG, I feel like I’m going in circles. Around and around and around. Invite is still unclaimed in Room Admin Panel. I see nothing in the Connections Panel.

I clicked and clicked on the “Join This Room” button until I get the other screen:

I click Insert SSB ID. This is how I had to do it originally. So, I’m just doing it all over again.

I enter my Manyverse ID, and hit Submit
Invite accepted.

So, it accepted it invite. I have no idea what a multiserver address is for.
I can see the member in the Room Admin Panel just as before. And likewise, no room shows up in Manyverse. I’m so close to just giving up on the entire thing, but I spent all this money on setting up a rasp pi. Sucks.

What did you set your room up on?

Weeell… It did not :stuck_out_tongue:

It would stay at indexing databases; maybe it’s fixed in the next release, or it does not expect to have nothing to index.

I tried downgrading to the previous version, that gave an error (maybe because the new version got stuck).

Uninstall worked, clean installed the latest version. It does not have my account, but restore from 24-word security code worked.

Log in (browser on desktop, show QR, scan QR on phone, open with Manyverse, allow access) works immediately.

The room is listed in Manyverse, and my account is listed in the room as a member (with addition ‘this is you, admin’ )

What do you mean? The hardware?

Hmmmm… but I also have the latest version of Manyverse 0.2201.7-beta on my desktop MacOS. You are using the QR code to connect to your Room with Manyverse on your phone, maybe that’s the difference. ??? I’ll have to see which versions my friends are using on their mobile android because 0.2201.7 is the newest but google play is still 0.2201.5 and fdroid is 0.2111.5, and I know some of my friends use Fdroid.

One of the bug fixes in the latest version is " Bug fix: room 2.0 invites also connect to room" - maybe doesn’t really work with MacOS, or work very well with anything, but only with QR code.

What do you mean? The hardware?

Yes, the hardware. DIY or offsite hosted server?

restore from 24-word security code worked.

Was that automatic, or did you have to setup a 24-word security code prior to uninstalling?

I think the QR code is nothing more than the URL to the room. When the browser on a phone pick it up and displays the website, the website offers the same button as is on the desktop, the difference being that in my case I do have an app installed on my phone that can understand what the button says to the OS.

DIY, more specific, pentium-class CPU on a mini-ITX board in a NAS-sized enclosure. I used to run Yunohost on Orange Pi’s, but at some point I couldn’t spill coffee on my desk without causing server outage.

Yes, ‘Backup’ under ‘Data & Storage’ in the Manyverse settings.

That would be such a waste. If your friends are somewhat flexible, have a look at Matrix for you Yunohost and Element (for example, there are quite a few clients by now) for their phones.

You can set up a private server, but can also federate with the wider network. The latest clients do offline chat, but the network is not dependent on accidental encounters to have data flowing.

have a look at Matrix for you Yunohost

Naw, I really want to go with SSB.

These are the things that come up in yunohost diagnostics:

Internet connectivity:

  • DNS resolution seems to be working, but it looks like you’re using a custom /etc/resolv.conf.

Ports exposure:

  • Port 25 is not reachable from outside. [blocked by my ISP]

Web:

  • Your local network does not seem to have hairpinning enabled.

Email (due to port 25):

  • The SMTP mail server cannot send emails to other servers because outgoing port 25 is blocked in IPv4. * The SMTP mail server cannot send emails to other servers because outgoing port 25 is blocked in IPv6.
  • The SMTP mail server is unreachable from the outside on IPv4. It won’t be able to receive emails.
  • The SMTP mail server is unreachable from the outside on IPv6. It won’t be able to receive emails.
  • The reverse DNS is not correctly configured in IPv4. Some emails may fail to get delivered or may get flagged as spam.
  • The reverse DNS is not correctly configured in IPv6. Some emails may fail to get delivered or may get flagged as spam.
  • Your IP or domain 50.98.175.154 is blacklisted on Invaluement
  • Your IP or domain 50.98.175.154 is blacklisted on SPFBL.net RBL

Then this too:

“Unable to update the cache of APT (Debian’s package manager). Here is a dump of the sources.list lines, which might help identify problematic lines:”

And this:

E: Repository ‘Index of /debian buster InRelease’ changed its ‘Suite’ value from ‘testing’ to ‘oldstable’

E: Repository ‘Index of /raspbian buster InRelease’ changed its ‘Suite’ value from ‘stable’ to ‘oldstable’

All else says “Everything looks good for…”

So, I will put some screenshots to show that local WiFi connections work fine as I have some local connections right now, I might as well take some screenshots for the record. Yes, I changed their names and avatars for anonymity:

I click on Connections and it goes to > Connected Peers:

Then, if I click anywhere on the white bar it goes to the Connections Panel:

But, as you can see there are no Room/Server connections, it is not detecting or not connecting to my Room for some reason.

Most things are no issue for SSB. If you don’t intend to use email, you can turn off email functionality for the domain:

That will spare you the warnings in diagnosis.

Hairpinning might come into play. Hairpinning is when the router recognizes you want to reach your (web)server from inside the LAN, and lets you visit it directly on the internal IP instead of going to the internet first, and then returning to your home LAN. When you ping your Yunohost by its hostname versus pinging it on the internal IP, is there a large difference in reply time?

Debian got a new version, ‘recently’. Since the image was created, the apt configuration is outdated. Are you familiar with SSH? Then have a look at this post on how to correct the configuration.