Seafile WebDAV not working

My YunoHost server

Hardware: VPS: OVH
YunoHost version: (stable)
I have access to my server : Through SSH & through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no (although it’s based on Debian 11)
If your request is related to an app, specify its name and version: Seafile 9.0.2~ynh2

Description of my issue

I can’t access Seafile through WebDAV, getting a 502 Bad Gateway error. Seafile works fine, also with macOS and Android official apps, just not WebDAV. It is properly configured, here are the config files:

(i have obscured my domain with domain.tld, but the subdomain is the same)


enabled = true
port = __WEBDAV_PORT__
fastcgi = true
share_name = /seafdav


location /seafdav {
        proxy_set_header   Host $host;
        proxy_set_header   X-Real-IP $remote_addr;
        proxy_set_header   X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header   X-Forwarded-Host $server_name;
        proxy_set_header   X-Forwarded-Proto $scheme;
        proxy_read_timeout  1200s;
        client_max_body_size 0;

        access_log      /var/log/nginx/seafdav.access.log;
        error_log       /var/log/nginx/seafdav.error.log;

(Note: domain.tld is current obscured domain and domain.old is an old domain I had configured, also obscured)

There’s a different Topic that shows the same error, but I wanted to create a more generic one, as that one is related to integration Joplin with Seafile, although the problem is with Seafile.

Thanks y’all!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.