[RESOLU] Comment transférer mon site WEB sur YUNOHOST

Si j’arrête le service PHP 8.1 la console YNH ne me donne pas la main pour démarrer mon Joomla.

Où puis-je demander à ce site joomla de tourner avec PHP 7.4 s’il vous plaît ?

Cette question fait à présent l’objet d’un “NEW TOPIC visible ici

Et pourrais-tu s’il te plaît installer complètement car moi le système me bloque au moment de renseigner la Configuration de la base de données.

Voici ce que j’obtiens :

pq ne pas installer le joomla du catalogue de yuno ?

il te suffirait d’exporter le joomla qui est chez ton hébergeur et de l’importer dans celui de yunohost

sinon pour installer un second site , tu installes un second my web app

Je confirme qu’il y a un bug avec le mot de passe généré. Il ne correspond pas à celui réellement assigné dans la base de données. J’investigue et te tiens au courant.

J’ai effectivement fait cela.
Mais il y a un hic dans mon cas.

Il m’arrive de rendre sevice à des associations bénévolement.
J’ai même, à mes frais, réalisé chez Jcook un composant dédié à leur besoin.

Le site que j’essaye de transféré sur YNH ne fonctionne pas car le PHP est en 8.2. Hors chez l’hébergeur actuel (LWS) je tourne en PHP 7.4 (de mémoire).

Et donc, bien évidemment, ca bug sur YNH. Je n’ai pas les connaissances pour modifier les lignes de codes et les rendre compatibles pour PHP 8.2

On a pas mal fait le tour ici sur ce forum, et sa progresse.
La solution n’est pas loin en utilisant mywebapp qui permet de choisir le php ad-hoc.

Merci beaucoup, je dis tu, pour ton implication.
Ce forum est complètement en adéquation avec la philosophie de YNH. Je remercie celles et ceux qui me lisent et m’apportent des réponses à mes problèmes.

Peux-tu réessayer avec sudo yunohost app install https://github.com/YunoHost-Apps/my_webapp_ynh/tree/fix-db -f ? ça résout le problème du mot de passe (celui affiché correspond à celui de la BDD)

J’ai tapé cela sur le command shell de webmin et cela donne ceci :

> sudo yunohost app install https://github.com/YunoHost-Apps/my_webapp_ynh/tree/fix-db -f
Packagers: option phpversion has 'choices' but has type 'string', use 'select' instead to remove this warning.
This URL is either unavailable, or conflicts with the already installed app(s):
 * lcz.nohost.me/site → My Webapp (my_webapp__2)

Il vaut mieux passer par SSH. La commande implique de réinstaller l’app, l’erreur indique que l’emplacement est déjà utilisé.

DOnc je désinstalle my webapp, bien compris.
Passer par SSH, cela signifie t il d’étre directement sur le serveur ?
Où puis je faire cela à partir de webmin ?
Désolé de poser cette question.

Peut-être, mais ne connaissant pas Webmin, je préfère te diriger vers ce que je maîtrise.

Très bien je comprends que le terme SSH signifie le serveur lui même. J’y vais maintenant.

Je viens de désinstaller les deux my webapp.

Il s’agit d’un protocole permettant d’ouvrir une ligne de commande distante sur le serveur, en effet. J’imagine que Webmin fait la même chose, mais ressert cette ligne de commande dans ton navigateur, sans que tu aies besoin d’installer un terminal.

Bon j’ai utilisé webmin.
La raison est que je veux pouvoir gérer mon serveur à distance et le laisser tranquille dans son coin sans écran.

Bref voici la réponse. Il est à noter que My webapp a été désinstallé juste avant et que je n’ai pas fait de redémarrage serveur.

> sudo yunohost app install https://github.com/YunoHost-Apps/my_webapp_ynh/tree/fix-db -f
Packagers: option phpversion has 'choices' but has type 'string', use 'select' instead to remove this warning.
Installing my_webapp...
Provisionning system_user...
Provisionning install_dir...
Provisionning permissions...
Provisionning apt...
[+++.................] > Validating installation parameters...
You need to set a password to enable SFTP
Unable to install my_webapp: An error occurred inside the app installation script
The operation 'Install the 'my_webapp' app' could not be completed. Please share the full log of this operation using the command 'yunohost log share 20230816-160512-app_install-my_webapp' to get help
Here's an extract of the logs before the crash. It might help debugging the error:
DEBUG - + local psql_installed2=no
DEBUG - + [[ no != \n\o ]]
DEBUG - + ynh_exit_properly
DEBUG - + [[ provision_or_update_apt =~ ^install$|^upgrade$|^restore$ ]]
DEBUG - Executing command '['sh', '-c', '/bin/bash -x "./install"  7>&1']'
DEBUG - + source _common.sh
DEBUG - + source /usr/share/yunohost/helpers
DEBUG - +++ set +o
DEBUG - +++ grep xtrace
DEBUG - ++ readonly 'XTRACE_ENABLE=set -o xtrace'
DEBUG - ++ XTRACE_ENABLE='set -o xtrace'
DEBUG - + password=
DEBUG - + app_nb=1
DEBUG - ++ grep '^Port' /etc/ssh/sshd_config
DEBUG - ++ awk '{print $2}'
DEBUG - + ssh_port=22
INFO - [+++.................] > Validating installation parameters...
DEBUG - + '[' '' '!=' '' ']'
DEBUG - + ynh_die '--message=You need to set a password to enable SFTP'
DEBUG - + ynh_exit_properly
Removing the app after installation failure...
[++++++..............] > Removing NGINX web server configuration...
'/etc/nginx/conf.d/lcz.nohost.me.d/my_webapp.conf' wasn't deleted because it doesn't exist.
'/etc/nginx/conf.d/lcz.nohost.me.d/my_webapp.d' wasn't deleted because it doesn't exist.
[######++++..........] > Removing PHP-FPM configuration...
'/etc/php/7.4/fpm/pool.d/my_webapp.conf' wasn't deleted because it doesn't exist.
[####################] > Removal of my_webapp completed
Deprovisionning apt...
Deprovisionning permissions...
Deprovisionning install_dir...
Deprovisionning system_user...
The operation 'Install the 'my_webapp' app' could not be completed. Please share the full log of this operation using the command 'yunohost log share 20230816-160512-app_install-my_webapp' to get help

:arrow_up:

Les logs sont ici :
https://paste.yunohost.org/raw/avuhejomel

Et où dois-je faire cela ? et avec quel identifiant ?

Dans le formulaire d’installation, on te demande de renseigner un mot de passe pour la connexion SFTP. Il ne faut pas laisser la réponse vide.

On parle donc de My webapp.
J’ai désinstallé les deux que j’avais.
J’ai toujours renseigné le mot de passe SFTP pour l’attaquer avec filezilla.
Je viens de réinstaller une appli my webapp vierge.

Je relance la commande sur le shell maintenant.

Voici ce que j’obtiens :

> sudo yunohost app install https://github.com/YunoHost-Apps/my_webapp_ynh/tree/fix-db -f
Packagers: option phpversion has 'choices' but has type 'string', use 'select' instead to remove this warning.
This URL is either unavailable, or conflicts with the already installed app(s):
 * lcz.nohost.me/site → My Webapp (my_webapp)

Je dois donc désinstaller l’appli my webapp.
Cela signifie que je dois rechercher où je dois renseigner le mot de passe SFTP.
Ce que je ne comprends pas c’est que j’accède aux fichiers avec filezilla en sftp.
Et donc je suis bien authentifié non ?

L’erreur fait mention qu’il existe déjà une my_webapp installée sur ton.domaine/site. Est-ce correct? Si oui, et qu’il s’agit d’un essai pour Joomla, supprime-la.

Ou alors installe-cet essai sur un autre chemin que /site.

Le mot de passe est demandé lors de l’installation de l’app. C’est toi qui le définit pour ensuite te connecter avec Filezilla.